TRS19 crashing on database repair


New member
I've been running TRS19 with the latest patch (build: 117009) for a while without any big problems now,
However, a few days ago when i closed content manager and wanted to launch trainz it initiated a Database Repair.
Nothing big, i thought, however when it got to "checking for faulty assets" it crashed to desktop, closing all TRS19 windows with it, and i've not been able to get it running ever since.
I've tried an extended Database rebuild, even tried reinstalling TRS19, and when i point it to my local content file it starts building a database again, crashing back to desktop again on "checking for faulty assets"

my next guess was a faulty asset causing these crashes, however, after removing the faulty assets the problem still persists.

is there any way i can maybe see a log after the crashes? hoping that might tell me what TRS19 is doing when these crashes happen.

hoping someone is able to help me get TRS19 running again.

Thanks in advance and regards from the Netherlands,

Have you updated or made any changes to your antivirus software?

If your antivirus is running a real-time scan of your Trainz folders, this can cause weird things to occur such as database crashes. You may want to check your settings and exclude your Trainz program and data folders from real-time scanning.

You can check the logs. On the Launcher, click on Developer located on the menu bar.
Click on Clear Logs.

Run Trainz...

Click on Show Logs.

or better yet, run Trainz in a window by setting that up under Trainz settings. Start the developer log and then start Trainz. You can resize the windows to fit so you can watch what's going on and hopefully see the crash. If you have two monitors it's even more helpful.

Does this occur with only a single route or any other routes? If it's only one route, then there's a corruption issue with that route and there are things we can try to recover that, although that's not always successful.
Hello John,

Thanks for the reply and for trying to help.
I've tried excluding the trainz program and data folders from real time scanning, this has not had any effect on the crashes unfortunately.

After that i've tried clearing the logs and showing the log before i start another database rebuild, and used my phone to record the log so i could look up the KUID of the asset that is potentially causing these crashes. However, the last shown KUID in the log at the time of the crash turns out to be a DLS Asset, which does not show up as faulty in Content Manager.

As for your last question, i can't trainz or open a route at all, when i open the TRS19 launcher it automaticaly starts a database rebuild, and it won't run trainz until this database rebuild is done, but that never happens since it keeps crashing and closing all TRS19 windows when it gets just over halfway done with "Checking for faulty assets"

Regards from the Netherlands,

mmaatthhiijjss - Suggest delete the contents of the cache/internet folder found in your UserData directory. It may be trying to load something cached there that is faulty.
Also check your remaining disk space allocated to TRS19 is sufficient to load the program and your UserData.
In case there's another instance of the TRS19 executable running somehow in the background, I'd also suggest restarting your computer before attempting to run another FDR.
Once you've done that, try another Full Database Repair by holding down the Control Key whilst initiating the Database Rebuild from the Launcher's Developer menu. (Do this before attempting to start Trainz again).
Hello PC_Ace,

I've tried removing the cache/internet folder, however unfortunately the database rebuild still crashes on "Checking for faulty assets" closing all TRS19 windows.
Looks like my only option now would be to reinstall TRS19, and then slowly import all content from my local folder, seeing if there's any particular piece of content causing these crashes to happen.
Thanks for trying to help.

Regards from the Netherlands,

Hi Mathijs,

I've had the same thing that occured once with my TS2019 b.111951 :
I've tried to install a map done with a version superior to 4.8, after changing the build to a lower one :eek: .
When launching TrainZ, it immediatly and repeatedely crashed with a database repair ... until I uninstalled the damn tweaked map :sleep: .

Hope this helps,


mmaatthhiijjss - That's frustrating, but it was worth a try. (BTW, in future, simply delete the contents of the cache/internet folder and not the folder itself).
I think your new strategy of reinstalling a clean version of TRS19 is best. Make sure it is functioning correctly before slowly reintroducing ANY content from your old UserData folder and files.
(The offending asset is likely to be one of the last routes or sessions you were working on before the auto-rebuilds began, so reinstall that last - or not at all in its previous state).
Good luck with this quest!
I had to do that a few weeks ago because Trainz 19 was getting stuck during the database repair. I gave up and installed another Trainz 19. It takes a long time to install and all the service packs. Then, I moved some files over that I wanted.