Possible Resolution for Raildriver Steam Engine Problem

I had an engine today, The Union Pacific Big Boy, that when loading the engine spec Kuid into the Enginekinds.txt file, the controller would not work. I had gotten the engine spec from the CMP config file as always. I then decided to look at the "Discovering engine type kuid as stated in the OP, and found that the kuid number listed there was different. I took that number and put it in the enginekinds.txt file and everything worked. So if you run into a problem with one engine, check the Discovering engine type for <kuid:xxx:xxxxxxxxx>, recursion 0 and make sure the number matches the number you are inserting in he enginekinds.txt file.

I've found that just loading Content Manager and checking for those items that are Location = Local, Open For Edit and Category = Train Engine ... in-fact I've created a new filter in Content Manager specifically for this (so I can just select the Tab) ... seems to work pretty well ... then I just select all (CTRL + A), copy to clipboard (CTRL + C), paste (CTRL + V) at the end of the EngineKinds.txt file, get rid of the Engine Names and append with STEAM or MODERN as-needed ... and of course, making sure there are no extra lines added ... Save the updated EngineKinds.txt file, Restart Trainz and I'm good-to-go ... hasn't failed me yet.

I also revert (CTRL + R) the Content Manager entries (Local, Open for Edit, Train Engine) so that I know they've been put in the EngineKinds.txt file and are no longer Open for Edit so they won't be found by the filter anymore.
Overjoyed at potential solution - however, changing enginekinds in note pad somehow

however, changing enginekinds in note pad somehow prevents trainz from loading. When removed from file Trainz loads normally. Any help?


Confirmed, I tested the UP Big Boy which I hadn't driven in a long time, checked that it does not respond to the raildriver reverser or throttle. Didn't bother with the error log, I just went to content manager and copied the Big Boy engine spec KUID and pasted into a new entry in the EngineKinds.txt file. Fired up Trainz and tried the Big Boy again, now it's drivable with raildriver. Setting the reverser forward isn't necessary, once the engine spec is added to that EngineKinds.txt file it works like any other engine, if you have the reverser in the middle when starting it immediately responds to that and starts going toward zero.
however, changing enginekinds in note pad somehow prevents trainz from loading. When removed from file Trainz loads normally. Any help?


Typically a problem when there are blank lines at the end of the file. Also make sure you spelled STEAM or MODERN properly and that you have a space between the kuid and engine kind ... basically just follow the formatting based on previous lines that were included in the original EngineKinds.txt file. Notepad should work fine for editing the file.
This has been tried for me but no such luck. I think the software needs a update since in come out in Janauary 2014, Auran has updated some of the enginie kuids with the routes.

As we are now in June 2014. Please check the EngineKinds.txt file as it may have out of date kuids in place and check the engine specs if need be.:eek: I be :) suprise if this leads to be the problem. it's a shame for e.g

kuid:44090:51015 is out of date, all the steam in the EngineKinds.txt is out of date tested and tried.
I have not been using my Trainz for a while (been a bit busy), but this weekend decided to find the time to revive my favourite leisure activity. I run TS 12, and saw this thread a year ago, so have been using my raildriver with steamers for a while, by editing EngineKinds.txt for each type I used.

Well, on first running TS12 today it told me it was out of date, so I installed the latest hotfix to 61388, and my raildriver stopped working completely. Checking on the Raildriver web site showed a new driver for TS12 SP1, so I installed that.

I then had to re-enter the steam locos in EngineKinds.txt, and all was well, EXCEPT for the reverser – all the other controls worked as expected, but the reverser no longer moves the cut-off of the loco.

Have others found this? Is it a characteristic of the new Raildriver driver? Is there something I can do?