Not able to host/joinCan Multiplayer session in TS12


New member
I am getting error saying assets or dependencies are locally modified and asks if i want to revert but when i click revert i am getting err which says you cant join the session because the changes cannot be reverted. I even re-installed trainz and also i don't find any assets listed when i filter by open for edit/locally modified/missing dependency.

Can someone help me on this.

Did you already lookup these assets in Content Manager and try to rever them there?

If you can not revert them there: Delete them and re-download them.
Still not solved? Do a database repair.

For multiplayer you can not have any locally modified assets that are part of the route or session. This also goes for dependencies of dependencies of dependencies of... etc.
Thanks for response, I checked for missing dependencies, open for edit and locally modified but don't see any matching above filters in content manager. I also did both quick and full database repair.
Please do not PM me next time. If I have time and think I know the answer, I will reply to your topic eventually.

Other things comes to mind:

What build of the game are you (both) using? Check the number in the bottom-right corner of the start-up window.

Double check if you downloaded everything for that session. In other words: Check in Content Manager if you have missing dependencies.

Maybe the person you are playing with is using an illegal install of the game and somehow managed to get assets flagged as "not locally modified". This will confuse your game. Try testing this with someone who 100% sure has a legal version of the game with a small MP sessions+route.

Bit of an overkill solution (in amount of work), but you could try a fresh install and only download that MP session you are trying to play. If that does not solve it, it probably is caused by the game the other person has installed.