Bulk Asset Update/Replace drop down menu freezes TRS19 up.


New member
I hope someone out there can help me and the crew at N3V with my issue. We been working the last 6 days to try to resolve this issue with no success. The problem is: Whenever I try to assess the "Bulk Asset Update/Replace tool" in the tool drop down menu and click on it, it will freeze the screen so that I'm unable to progress. This happens as soon as you select the bulk replace tool and before you get the box asking what to replace and with what. I must use the Task Manager to end task to quit TRS19 then restart the sim to get back in. I tried using the Bulk Asset Update/Replace tool on several other routes with the same results. I am using TRS19 version 111951. My System is as follows:

Intel Quad Core i7-875K 4GHZ OverClocked CPU, on a EVGA P55 SLI E657 FTW Motherboard,
Cooler Master HAF 922 Chassis with Asetek, liquid cooled CPU matched to radiator & fan
Thermaltake 850w PSU power supply
Patriot Viper II 16GB DDR3 PC12800 Triple Channel 1600MHz Matched Certified Memory (4GB x 4)
EVGA GeForce GTX 980 Ti 7 GHZ PCI-Express 3.0 ACX 2.0+ Video Card with 6 GB GDDR 5 Memory
Creative Labs SB X-FI Titanium Champ PCIe Sound Card
“C” Drive Intel 660p SSD 2TB 2280 Solid State Drive Read/Write speed 1800MBPs
“E” Drive Seagate 3TB 7200RPM Hard Drive with 6GB per second access/64MB Cache
Sony Optiarc High Speed 24x LightScribe OME DVD Drive
Samsung 27 inch FHD Curved LED Monitor
Microsoft Natural Ergonomic Keyboard 4000
HUGE MMO Gaming Optical 7 button Trackball Mouse
Windows 10 Pro. 64 bit Operating System

Also a little something about me: I'm almost 75 years young which seem to happen in a blink of an eye. I've been a user of Trainz Train Sim since the first original Trainz came out and have every version registered to me that have been released since the first original one. I've been a member, helpmate, researcher, Beta Tester and friend of TrainItalia since about 2004. I've never had any problem with working on their large routes, such as Donner Pass Spring & Winter, Sherman Hill, West From Denver, and Rollins Pass, just to name a few thus, large routes are not a problem. I got involved with train sims since the very first release of MSTS including content creation and route building and modification. You will find many reference to me (Harbison) for my content, ideas, and features dating back to 2002 at TrainSim.com. I live in Northern California about 80 north of Sacramento and am very close to the Donner Pass route and the Feather River Canyon route. Went to college for 8 years and have 2 degrees. Worked for the USDA Forest Service in Engineering working with AutoCAD a computer aided drafting and design program for 13 years.

Back to my issue with TRS19 it should also be noted I reinstalled TANE and it's "Bulk Asset Update/Replace" work just fine as it always have. Just the one in my TRS19 doesn't, it use to the last time I had need to use it but not now.

After 6 days of working with N3V on the ticket I submitted on this following is the latest go-a-round which also didn't work along with everything we tried. Sure hope you guys have some ideas. For those who want to see the attachments I make reference to my ticket is #MKD-544-34185

After many hours of work, edit, and database rebuild you suggested here is where I'm at and what I found.

First according to your suggestion I deleted what the system let me all faulty, broken assets, and reference to missing assets that the content manager listed and also anything that referenced those faulty assets. I went into each and every routes and removed all missing assets and faulty assets. I check the dependency of all questionable assets for faulty or missing assets or reference to faulty or missing assets and took care of that. I deleted routes I had installed for a long time but unlikely to use or edit. All assets it listed and said was available I down loaded and check them. What wasn't available I deleted them and any reference to them and in some cases also deleted assets that referenced them. Once this was completed and nothing more could be modified or deleted I then did both a database rebuild and a control + left click database rebuild.

I now have a very clean and fast loading TRS19, however the tool "Bulk Asset Update/Replace" still does not work, as soon it is selected it freezes or locks up the screen before getting to the box with what to replace and with what. Game over. Need to do a content manager to kill the sim and then do a restart.

Getting back into the sim and upon further research there are 57 faulty built-in sessions, 1 track object, and 1 train, also are built-in faulty. See attachments. All the built-in can not be modified nor deleted thus I'm stuck with them. On checking the dependencies on them they seem to access the same assets. The list of assets for them all show some assets as installed with the word grayed out. These grayed out installed assets can not be found either by kuid nor by name. I'm assuming the reason for these sessions, 1 track object, and 1 train to show up as faulty. What do or can I do about them if they are what is causing the bulk asset update/replace not to work and freeze the game?

Don't know what to do or where to go from here. Beginning to wonder where the issue is, with the faulty assets or with possible with an aspect of the sim being corrupted. I would really love to get on with my route building. This problem effect all aspect of route building in TRS19.

I hope our next go around with a possible fix really fixes the issue with the bulk the bulk update/replace. Here hope.
I just tested the Bulk Update/Replace tool on my install of TRS19 Platinum build 111951 and it is working exactly as expected, no freezing.

The only "quick fix" suggestion I can make at this stage is ask if you are running TRS19 in Administrator mode? If not then you could change the programs mode to Administrator to see if it makes a difference. If you are unsure how to do this then

  1. locate the TRS19.exe file (usually in Drive:\Program Files\N3V Games\Trainz Railroad Simulator 2019) where "Drive" is normally C: or D:
  2. right mouse click on the file and select Properties
  3. select the Compatibility tab
  4. tick the box Run this program as an administrator
  5. click OK

Failing that, a corrupt install is a possibility.
Bulk asset update and replace works as expected here and I use it regularly and I have many faulty assets waiting for a repair. Items with missing assets really shouldn't cause a problem.
Something that may help is to do some maintenance on your database. In content manager, run the "out of date" filter and sort the resulting list by status. Download updates for "Installed from DLS" items by selecting all of that status and click download. For the remaining items, select each status in turn (built in etc.) and " view asset versions'". A second window will open, then select the latest version of each which shows "available for download" and download all of those. When this is complete, create a filter "Obsolete AND NOT Built-in" and run the filter deleting any assets shown there. Once complete, run a DBR.
**Any PAYWARE assets can only be updated with their packages through the Content Store located on the launcher.**
I hope this goes some way to solving your problem.
If the OP doesn't even get to the select objects to replace, I wonder if faulty assets could cause the freezing. Sounds more like a corrupt install.
@Harby, Is this Trainz installed in the C:drive in Programs folder? Perhaps Windows permissions is causing some issue. If you have another internal drive connected that is both big and fast, try a new install there.
I would also consider disk space. If the disk is low on space, there may not be enough space to perform the action.
Thank guys, you've given me something else to check out. In reply to as least some of the above. First until I get the Bulk Asset Update/Replace I try that tool on the smallest route I have installed which is "Content Sampler #1" which the bulk asset tool is not even working in it.

My C drive is a 2TB SDD with 553GB Free space, which is where TRS19 lives.
My F Data drive is a 3TB HDD with 1.34TB Free space
I have 16GB DDR3 memory on the motherboard

According to the Task Manager when TRS19 is running it is using:
12.8% of the CPU
50.3% (2,168.1MB) Memory
0.1% of Disk Space
73.3% of the GPU

I change the TRS19.exe to Admin. but that didn't work either. In accordance to N3V's suggestion on the ticket other that what I referenced up above on the built-in, there are no faulty, broken, missing, or unknown assets on my system. This took a while as I have as a route builder 575,621 assets on my system. I need to check for out-of-date assets and not-compatible-with-this-version assets to up grade those or get rid of them. That will be my next project unless N3V come up with something else. Over the last 6 day the database has been through several Database Rebuild and Control+left click Database Rebuild.

Thanks, keep the suggestions coming maybe someone will hit on it. If you are interested on what I've been working many thousand of hours since 2004 you can check it out here: N3V TrainzSim 19 Donner Pass/Valley Sub Route I'm building | Flickr
This is just a shot in the dark but is your birtual memory 3 times greater than the physical memory? It needs to be set as such. Sorry can't be much help still recovering from surgery but this fact on memory is important.
I thought I'd add to the information of my computer specs. in the first response and just above the following. As a test to see if the issue was my computer I reinstalled TANE which I had removed when I started using TRS19. Having reinstalled TANE I tried TANE's "Bulk Asset Update/Replace" and it worked fine as it always has, replacing the selected track with the new track. I then started TRS19 and tried the Bulk Asset Update/Replace only to have it lock up the sim again. Why would the one in TANE work and not the one in TRS19?
Try a fresh install of TRS19 to another drive or a different named folder on the same drive, see it bulk replace works and if so point the install tab to the old database and see if it still works.
hi Harby,
most of us are old men here, welcome to the club
You have disk space enough

A few things to check:
-is windows set to allow to adjust virtual memory or you have it at a fixed size?
-you have a fast system, have you tried to set it NOT overclocked?
-have you tried Bulk asset replace on a complete new map?

Personally i have TRS19 on a standard Harddisk (10k rpm),
but only the LOCAL folder's on a super fast m2.SSD (ssd on the mobo)
Bulk asset replace works here in build 100240(before SP1) and 111951(SP3)
it was partly broken in SP1 (now removed here)

hope you fix it
greetings GM
Last edited:
Hi GM,
I looks as if I'm in good company. I guess us old folks are mostly the only ones interested in trains of any kind. A friend my age wanted to get his grandson interested in trains, something they could do together. So he got TRS19, turned out his grandson wasn't interested if it didn't blowup or shoot something. Too bad.

N3V working on my ticket has finally determined that my TRS19 is corrupted. Came to that conclusion when among other things was unable to adjust or expand the columns in the content manager. Backing off the 3 critical folders (Local, Original, and Packages). Then my critical routes I will save to a CDP after which I will uninstall TRS19. Wipe the remaining folders and do a clean fresh install. Will let you know how that goes.

I got into route modification, super detailing, and building because I was trying to capture what I experienced growing up. I was born in 1946 and Southern Pacific ran steam in Northern California and over Donner until 1957. I vividly remember watching the cab-forward as though it was yesterday. I have every book on Southern Pacific available collected over the years and now with the internet very vintage or period photo I can get my hands on. I have been creating virtual replication of these into the route. If you would like as sample of what I've done check the following link. Again Thanks. N3V TrainzSim 19 Donner Pass/Valley Sub Route I'm building | Flickr
Hi All,

An update. Yreka! Success, the re-install did the trick everything is working as it should and lightning fast. I've very pleased to say the least. On thing is the same and that is the inability to change the column widths in the content manager. I can change the column width of the content manager in TANE but not in TRS19, however I can like with that, it is not an issue.

Thank you all for your help, suggestions, and insight.
Glad its working again Harby
really enjoyed the Flickr link you provided above, can see the love for trains

In Content manager if you hover your mouse cursor over the line with
| Name | Status | Asset ID | etc.
do you see the mouse cursor change to a symbol like this <==> ?
if not its maybe a mouse setting in windows.

greetings GM
Fixed the adjusting the column widths also. As it turns out the mouse cursor doesn't change for some reason. However if I place the point of the cursor very near or just against the line I can drag it to the width I desire. Again thanks for everything. I'm happily working on my route in TRS19. Also purchased TransDEM so looking forward to great things.