Another interesting bug in TRSS22 123794


I am on version 63 and still fixing my sole route/session since the disastrous 'Patch' from SP3. (Don't ask!)

Suddenly TRS22 has started to add 'Drivers' to driverless trains but with a twist.

It only does half of the driverless trains i.e. 3 of 6 driverless trains at about 45 seconds into the session.

The offending 3 then switch the junctions that were holding them on 'Autopilot Rule', 'Start Autopilot on trains with no Drivers'.

No amount of adjusting 'Add a new Driver' in 'Edit Session' or tweaking 'Autopilot Rule' will stop this.

The cure was to delete the 3 offending Driverless Trains.

P.S. 'Scott' who has been, by appearance, male since version 1.3 I believe, (still appears male in 'Edit Session'/'Driver Setup'},
has suddenly started wearing a long blonde wig and red lipstick in the 'Driver' animated portrait.

Waiting the next bug with bated breath ;)
"Unfortunately" N3V will not keep you waiting very long. These driver issues plagued me in the past. Drivers appearing out of the mists of Trainz. But, they eventually went away. I think that my cure was also deletion.
There is something definitely amiss here. I ran into an issue the other day which required so many let's try this and that to see if it would work things to finally fix a driver issue that I forgot what I did to make the issue go away.

I have an operating session set up on my relatively compact Gloucester Terminal Electric route. I run trolley cars (trams) under wires and diesel freight along the main line to serve various industries and ports. While there are many drivers, the operation is pretty simple and the session can usually run for hours on end.

That said, I came across some nice shiny new trams I thought I'd use instead of some really outdated GT8s. I replaced three of them by removing them one at a time and reassigning the same driver to the new trams. I've done this before not only on this route, but also on others over the past decades without any issues at all.

Well, this didn't go as expected this time.

When I attempted to drive the route, my driver setup rule showed the correct driver configured for the route, but when viewed from above in the "map view", there was a different driver in the tram. Okay, I saw this when I was setting up the drivers in the Session editor and I reported this as an anomaly ages ago in TRS19 early days and was told it's normal and ignore it. However, when I went into driver, the same not-assigned drivers were still assigned to the new trams, and they weren't moving because there was no schedule assigned!

After multiple deletions, readding consists, reassigning, and getting ready to delete the session and give up, it worked. At one point, I assigned drivers to all the trains in the session editor and then removed them. I thought that worked once, but I couldn't tell because I did other things.

Does anyone have an idea?
Hi JCitron
In Surveyor, NOT 2.0, Under 'Trains (F7)', the 'Edit Details (P)', you will see a 'Driver' Portrait and Name for the selected Loco. This portrait/Name bears no similarity to the driver you have assigned through 'Ctrl+R', 'Edit Session', 'Driver Setup' in Surveyor. Would not say this is part of the problem but....
My latest bug :(
I use "Drive to/Via..." for all but one instance on 10 AI/Driver trains.
Today I noticed a train backing out of a queue as if I were using 'Navigate To/Via...' commands instead.
The twist, there is always a twist with Trainz.
If a train is captured in a queue between 2 others it eventually falls back to a 'Stop Train' state i.e. stopped facing a green signal when the train ahead clears the section. The Ctrl+RClick menu has a 'Stop Train' command visible meaning it should be moving through the green signal but does not.

My work round is to Ctrl+RClick the Loco and 'Stop Train' followed a few seconds later by a 'Continue Schedule ' command.

Waiting the next bug😕.