Where's The Traffic?


Running TRS22PE edition I've used bnsf50 and yarnish roads and there is no traffic. Looked in the environment and the traffic are enabled. Any ideas?
If they are indeed turned on and properly set up, then they should appear in Driver sessions.
Animation is Paused in Surveyor (Route and Session Edit...) Modes
This depends upon a few of things.

1) The region is set to default.
2) The roads don't have traffic.
3) The simulation is paused. By default, Surveyor is paused and there's little or no carz on the roads when the simulation is paused.
Just to drive home the point, try pressing the "p" key while in Surveyor. As John and PC Ace say, animation is paused by default when you are in Surveyor. This doesn't mean that everything is paused just any asset that has any animation is not animating. You can move about and do everything you would normally do just fine. This is new in TRS22 and it has caught me out more than once. :)
I'll try pressing the p key and if that works is this something that has to be done all the time?
Yes, while in Surveyor if you want animated assets to be animated while you are working on a route.

The pause in Surveyor came about due to a request by us during beta testing the new Universal Driver Surveyor option originally found in Plus. With UDS, you can jump between Driver and Surveyor or the other way around while working on or driving a route. In the olden days, we had to save or quit a session to fix an AI issue, but with UDS, we can jump back in to Surveyor, which at this point is really the Session editor, and untangle AI. This is well and good, but the AI were still roaming around and doing their AI thing while making it difficult to move the stuck AI-driven consists out of the way. It was like herding cats on a good day and attempting to keep a swarm of mosquitos together on others. By pausing the action, we could do what was needed and return to driving without being attacked by the AI drivers.
Have tried 10 different roads from the DLS and no traffic even when pressing the P key in surveyor. When in driver mode no traffic either. I'm working in classic surveyor. Haven't tried 2.0 yet.
Last edited:
Check the region, which is used by the route. Some regions (like the default region) don't have any defined traffic.

Region is USA for current route. However, if I go in and create a new route then I have traffic showing in surveyor. Region is USA. Is this not strange?
While my route without traffic is parked on a siding, I decide to build another route and what a surprise there is traffic, so I'll finish it up and return to the other.

Create a new single baseboard route with the same region that you are using that generates traffic and merge your existing route without traffic into it. This may update the traffic on your existing route. Once the route is merged and traffic appears, you can either delete the single baseboard or keep it. Save the new route as a new version of your existing one. I've done this kind of thing in the past to remove weird things caused by some kind of corruption that occurred with my route.
category-region "AU"
category-era "2010s"
kuid <kuid:30577:100142>
kind "map"
water <kuid:-1:6353>
category-class "YM"
region <kuid:-1:78032>

this is a part of my config.txt from my route
I changed the category-region to AU

what is the region with the kuid of -1:78032... ??

this is in the config.txt of all my routes.
adding a question to this, where are all my assets?, I have maybe 7 tracks to use, minimal buildings and track items. Most of my routs are showing the missing items icon. The new route builder is a real pain in the ass. i found a road, but i can't put it down over a track, or make it curve, let alone get any traffic to appear!