Strange Track


I am amazed that after about twelve years of using Surveyor in all versions of Trainz it still produces "weird" situations !!
I have an extremely large route - fictitious UK - has been going for about nine years and grows steadily each day.
Today I opened the route in Surveyor and found a section of track on a new baseboard which did not look right - decided to
delete and rectify to find that a short section of single track would not react to delete - move - height adjustment etc.
To overcome this I deleted the baseboard for this area and found that the offending track was "suspended in space"
Help please

2 things is its part of a object/industry floating and you need to find the industry and nudge it to go away...or if the track is not a regularly used assetand you know the kuid number you can manually delete the asset from the configuration file...on hand I am guessing this is part of a bridge track which I ran into a problem with prior., I believe they were splined YR bridges which I had several do this to me.... good luck...
Last edited:
Dave - you can't delete an asset by removing it's kuid from the route config.txt file. It doesn't work that way because the assets are actually tracked in a separate file but listed as the dependencies in the config.txt. Deleting the line in the config.txt file will only remove the asset momentarily. Once the route is reopened and saved again, the asset will reappear.

Ron - I would check that you don't have a consist on the track somewhere outside of the area where you deleted the baseboard. This will prevent you from deleting or adjusting track.
Ya but some of these objects for example split up on the map you will have a invisible track , a spline section all removable then a non functional section in which I found removing the asset in config file then deleting it from TANE was one of the things I found temporarily allows you to adjust the bad object and replace...when reopening route in surveyor...
I found removing the asset in config file then deleting it from TANE was one of the things I found temporarily allows you to adjust the bad object and replace

Deleting the asset will allow you to use the Remove Missing Assets function, and that will often fix the problem Removing the asset from the config.txt has nothing to do with it.
Anyways so far with this latest beta I found that the problem I was mentioning has been fixed., so I am hoping the same will go for Ron_Smith s issue...
Dave =)
Hi everyone

Thanks for the suggestions - could not rectify problem so I compromised and made a siding to include the "offending track" and although this may not be the correct
solution it "looks ok" and we can now continue.
Thanks again.

I have this wierd unknown Red invisible track, it is "Track Invisible" by Auran, which is a builtin asset, and can not be deleted ... I have tried everything to get rid of it, and I think it is caused by sloppy inserting spline points from a distant, wide angle view ... I can make it visible in Driver by editing the track config "Surveyor Only 0", and I can make it invisible by deleting the texture and mesh ... but it comes right back as soon as you restart Trainz ... How is it that a track can be suspended in space when all the baseboards under the track are deleted ? it just doesn't make any sense ... it is there ... yet it is not there :confused: Puzzeled
Not sure if my problem track was the same but as I said above I incorporated it in a siding to hid it and several days later when opening in Surveyor a piece of track was "missing"
and as far as I know I did nothing to delete it after the first attempts.
The odd things that happen in Trainz !!!