Problem with ST_RMM assets in TRS22 PE


I have been using an early version of TRS22 (Build 116492) for quite a while so I finally decided to update and install the copy of TRS22PE (Build 123801) I had purchased. I installed TRS22 PE and then pointed it to a copy of the content file from the earlier build version. When I started the new version it did a database rebuild which did not surprise me, but when I opened the sim I found a number of routes were showing faulty dependencies in Driver/Surveyor. So I opened content manager and was surprised to find the a number of RMM's trees were showing as faulty since these were all fine in the earlier version. So I opened content manager and right clicked on a few of the supposedly faulty items to display errors and they all showed zero errors and zero warnings. I thought perhaps the items may haves become corrupted so I deleted a few items and redownloaded them from the DLS. They came back in as faulty again. I checked to see if perhaps there was a faulty dependency only to find a single dependency that is a mesh file and it does not show as faulty. Some of RMM's content reports as OK and I can see them in Surveyor. The ones reporting as faulty cannot be seen and show up as missing items.

Has anyone else run into this problem? I don't understand. I would appreciate any help with resolving this problem.

Thanks in advance for any help.

Paul :)
A while back a number of Euromodellers hemlocks that he allowed me to modify and use in one my routes were coming up as faulty in 2022 PE, however , now for some reason they are all ok, go figure. Have you done a extended database repair ?
@ Dan,

Thanks a bunch for the tip, it worked! I did a standard database repair when the problem showed itself and that did not work. But the extended repair did. I noticed when I started the process it showed a message that it was clearing cached items. Maybe that had something to do with it. Dunno, but it's fixed so I guess I won't think anymore about it.

@ John,

I did try that initially, even tried reverting but that didn't work either. The extended database repair did the trick. Thanks for taking the time to respond.

Trainz!! You can't live with it and you can't live without it! ;)

Best to both!

Paul :)