Jointed Rail website troubles


New member
Hi, is anyone else having difficulty logging in to I suspect that it may be a server overload with a spring sale combined with the recent release of a reasonably useable CEv1.2, but I wanted to double check here to see if others are having difficulty logging in.

To clarify, I had this problem a few days ago and eventually emailed the jointedrail team to which I never received a reply. I did log in the next day and the problem seemed to be resolved so I browsed the website for a few minutes but had to leave after a brief time. Once I was able to return, I logged in easily and started to add a couple items to my cart. After the second item was added, the website locked me out. I can't get past the 403 Forbidden error clicking any link on the jointedrail website. I've tried a dozen times in the last day to log in and I just can't. :(

The same error occurs in Firefox 37, Chrome, and Safari on my iPhone.

I hope someone can shed some light on this. I hate to see these guys loose an opportunity for business.

It seems to be working fine for me. I was able to add and remove multiple items from my cart, and the site, while a bit slow, never froze or locked me out. Good luck! :)
Thank you! Sure enough, I was able to log in shortly after posting and have had no problems. It must be server issue, hopefully high volume! :) To those who are having trouble, keep trying.