Attachment Points Not Found but...


Apprentice Creator
So with the almost total lack of any current standard Queensland wagons that will actually load goods I got permission to do a little adapting given I have a bit of an idea how to adapt scripts via config files. My plan was to take the QR MTW flat wagon which only has one attachment point for goods and make multiples possible. So instead of having one lonely general goods you could have several etc.. I know how to add attachment points using the PEVsoft attachment maker (as per adding crews to ships) and added two more to begin with. Noting the original model was Build 2.9, I changed that to 3.5 given this is the minimum to upload, any higher and it'd probably create all sorts of problems with different requirements. I also noted the original model although having one 'a.load0' did not have an attachment mesh? My version now does.

Problem is, it creates an error saying the two attachment points now listed in the config file "can't be found." Any ideas folks?
Did you add the 2 new points to the queue container, attachments points section?
so the original a.load0 and the new a.load1 and a.load2

it could be that trainz expects the 3 points to be in 1 mesh
I used to use PEVsoft attachment maker, but I've found IM Editor to be much better. There's a small learning curve with getting the hang of using it, but once you know how it's way more simple to add attachment points and a lot quicker too.
Blow me down, new posts showed no replies, but here I am lol. Yes, I added the extra attachment points as load1,

size 2
initial-count 0

0 "a.load1"
1 "a.load2"
}What I've found is prior to Build 3.8 attachment points seem to be part of the body im file, (as seen with other rollingstock). If I raise the build number to 3.8 this problem goes away. However... the warnings that the BMP files are a uniform colour become errors. Unfortunately if I add a slightly different colour to solve that problem (which I've done elsewhere successfully), I get an error that it then can't open the BMP files! I also now get an error that the im files (which I've updated from pm) must now be changed to LM, but I see no tool to do that?

As these are old assets I'm doing this in Tane, then I'll check them in TRS19. Just going to do a DBR incase that helps...

PS I find the attachment quite easy to use, it's now just a question of the BMP files and needing to upgrade IM to LM.
Last edited:
Make sure your BMP files are 24-bit.

I've run into the same issue with automatic settings in, so I'll assume it's the same with other programs as well.
Well I realised that lm files ain't going to happen, that requires LOD I believe, so I have to settle back to Build 3.5. That brings me back to "attachment points not found". From what I've seen, with cargo type attachment points in this build, they appear to be part of the file not separate, but the PEVsoft attachment maker only(?) makes them as a separate file. Meanwhile my pc locked up as I tried to get into this thread the first time, and I had to cut the power, second time in a month. HDD supposedly is fine, but a tad worried, and yes, files are backed up to an external drive just in case. I replaced the HDD 4 years ago, and they seem to only last 5-6 years, so may be time for a new and bigger one..... what next! lol
Anyone got any ideas for a solution to this problem? The lack of current standard QR rollingstock is frankly appalling unless there's some items I haven't found. This would have been a useful fix, if I can get it to work.
what was the kuid? or can you send me what you made sofar?

with 3 points and that product it would look like this

think it can use 6 points

later, tried with 6 points

here is a zip with the 2 versions, to test
do whatever you want to do with it, don't forget to ask Willem2 permission if you upload it on DLS
this is for test only
Last edited:
Anyone got any ideas for a solution to this problem? The lack of current standard QR rollingstock is frankly appalling unless there's some items I haven't found. This would have been a useful fix, if I can get it to work.

I still consider IM Editor to be the best solution. I've used it a goodly amount to add, edit and remove attachment points. True enough you need to be able to visualise invisible points in a 3D framework, but it's not that difficult to acquire the knack of doing so. I regard it as a good mental exercise to keep my porridge for a brain in some kind of a functional state.
Thanks, looks like the right one G.M., namely <kuid2:97008:60028:1> QR NG MTW Flatcar. I've already asked and got permission. I'll also look IM editor and see if that helps as I'd like to do others, and out of curiosity which program did you us? As for porridge, I haven't had that for a long time, maybe that's my problem?? :hehe:
Thanks to you two, I now have it working, with 1,2,3, or 6 loads. Now if I can get adding passengers to work I'll be even happier. Well actually it works, but they are invisible! More to study.
Good it works,
if you want to learn about passenger cars, just open 1 for edit and study it (specially the config)