.
Results 1 to 3 of 3

Thread: TRC Question

  1. #1
    Join Date
    Jan 2009
    Location
    United States of America, Oregon, parts unknown
    Posts
    356
     

    Default TRC Question

    So been redoing marias pass route cosmetically, and wanted to replace the crossings with trc, but every time i set them up the way the tutorial suggests, the triggers only seem to pick up the other triggers and the traffic stopper, they don't seem to pick up the crossings at all, am i doing something wrong?
    Professionally confused

  2. #2
    Join Date
    Oct 2018
    Location
    USA - North Carolina
    Posts
    2,202
     

    Default

    I had similar issues with TRC crossing when running Tane routes in TRS19. The triggers were not seing the lights/gates even though configured to do so. I had to delete and retype the names of the signals/gates in the trigger configs (making sure I had the name correct as per the config). After re-entering the names the lights/gates were then "seen" by the triggers and they worked fine.

    But since you are likely configuring for the first time you wouldn't likely have this issue. Confirm the names used, delete them, re-enter and see what happens. I doubt it works but you never know.
    Gold/Plus
    22+ beta 115628;
    19+ SP5 beta 115653; 19-Std SP3; Tane SP4
    Win10, GTX1060-6, 1TB SSD(C), 2TB SSD(D)


  3. #3
    Join Date
    Aug 2008
    Location
    United States of America
    Posts
    36
     

    Default

    Quote Originally Posted by Blackout16 View Post
    So been redoing marias pass route cosmetically, and wanted to replace the crossings with trc, but every time i set them up the way the tutorial suggests, the triggers only seem to pick up the other triggers and the traffic stopper, they don't seem to pick up the crossings at all, am i doing something wrong?

    You are not confused, some of the TRC crossing are missing information in the configuration files to work in 2019.

    They can be made to work if you one to go through the hassle of modifying the configuration files yourself.

    I answered how to fix the crossing in this forum post:

    https://forums.auran.com/trainz/show...ent-bug-fixed-!

    The information that needs to be added (and included in the above post under my user name) is:

    If you look in the config files you will see that they are missing:

    custom-category-list "TRC"

    This needs to be added under:

    category-class "WX"



    Alternatively you can look for TRC crossings that have custom-category-list "TRC" in the configuration file before placing them if you want to save time of trial and error to find the ones that work.

    I would provide a list but I've already updated everything to work in 19 that I have installed.
    Last edited by sd24b; October 17th, 2021 at 08:02 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •