Does TRC work for anyone in Trainz 2022?

ApproachMedium

Youtube dude
Has anyone been able to get TRC triggers/crossings to work in Trainz 2022 (123794) at all?

I've been trying to get them configured on my P&B route but there is utter inconsistency with any of the configurations saving. I can get a few crossings named and configured on the route layer, the triggers will see each other, the gates and stoppers, I'll save and exit and upon returning none of the triggers see anything. Then if I open a base session, I'll find some of the triggers are seeing all the things but others are not. If I leave and return again, a different set that weren't working are suddenly working again and the previous ones that were working suddenly have lost their configuration.

My hunch is that it has something to do with unified Driver/Surveyor and perhaps the game isn't sure where to save the configured info, ie session layer or route layer? It's just wildly inconsistent. As soon as I feel like I have it working and figured out, a different set of crossings breaks.

So I'm just curious if anyone else is having this issue and have you found a fix? Because I'm about to lose my mind here lol.

-Joe
 
Has anyone been able to get TRC triggers/crossings to work in Trainz 2022 (123794) at all?

I've been trying to get them configured on my P&B route but there is utter inconsistency with any of the configurations saving. I can get a few crossings named and configured on the route layer, the triggers will see each other, the gates and stoppers, I'll save and exit and upon returning none of the triggers see anything. Then if I open a base session, I'll find some of the triggers are seeing all the things but others are not. If I leave and return again, a different set that weren't working are suddenly working again and the previous ones that were working suddenly have lost their configuration.

My hunch is that it has something to do with unified Driver/Surveyor and perhaps the game isn't sure where to save the configured info, ie session layer or route layer? It's just wildly inconsistent. As soon as I feel like I have it working and figured out, a different set of crossings breaks.

So I'm just curious if anyone else is having this issue and have you found a fix? Because I'm about to lose my mind here lol.

-Joe
they work in the TRS22 (123799) Build! Reggies Crossings on thee other hand do not work for TRC...
 
I am having the same issues. If I merge or D/L a route that has TRS, they work. However, if I try and add to my existing route by editing the triggers, bam, no-go.

John
 
They don't appear to work. I ran into that the other day and resorted to the tried-and-true ATLS crossing components.

The TRS22 issue appears to be caused by the changes in the properties panel in Build 123794.
 
Has anyone been able to get TRC triggers/crossings to work in Trainz 2022 (123794) at all?
Hi @ApproachMedium.
I thought I would put my two cents in to see if I can help out. 👍🏼

I have been working with TRC4 crossings in b123794, in my rework of the JR Mojave Sub (hoping to get their permission to share). I actually discovered TRC by watching your YT channel! 😁 Anyway, I went through the process of replacing all the broken ATLS crossings, and had the new crossings all programmed and working properly. Then one day I loaded S20 as usual and in the corner of the screen it started displaying “Script Failure <kuid:xxxxxx,” (I did check if it was vincentrh’s kuid and it was) over and over at random times while I was editing. I got concerned that the crossings broke, but I tested multiple in Driver and they worked perfectly. Every time I load into S20 it gives me the same message, but I am not sure what could exactly be affected. Interestingly, if I edit the route in Surveyor Classic, it never gives me any errors. I need to double-check the kuid in the error message because I don’t know if it is for the crossings or the triggers.
I hope that sharing my experiences can help in any way Joe!

Cheers
 
TRC works for me and I've been using them on my WIP route but after a while of thinking I've decided to future proof my route and go back to ATLS as I've always had success with them. Don't want to go over 112 miles repairing crossings when they break...

With my session scripting knowledge, I can simply use ATLS commands with AI to add the 'advanced' crossing controls.

Cheers
 
I noticed that previously set up TRC crossings have information in the properties panels, but newly configured ones do not and are completely empty.
 
I was going crazy about this myself and found that if you change the trigger radius to 1 with (trackmark mode tool) the triggers will work properly... Also if you use the (TRC INVISIBLE RAIL CROSSING 90) you should add the command line that was mentioned in another post (custom-category-list "TRC") Update worked good with 2 tracks and with 4 tracks I was only getting 2 to work then I did a find object to detect the other 2 none working triggers and then reopened them and they worked? Also noticing they pick up the track objects (crossings) as scenery and crossing objects? Also if you use EIT towers to click the TRC COMPATABILITY to ON!
Just my take on them so far with them....
 
Last edited:
Back
Top