Uncoupling From Consist-does not happen?


Well-known member
122411 TRS2022
Engine couples to consist.
Drives to trackmark in a yard
Should uncouple, but does not happen, just sets there.
No sound of the coupler release. A horn sound instruction just prior to the uncouple instruction sounds the horn.

I have tried various trains, engines and locations to uncouple with no luck
Different vehicles, same issue, one car, many car consist-same.
Set the engine to sound horn and then uncouple. Horn sounds but no uncouple.
Tried different delay values between train stopping and executing uncouple but no luck.
When the train arrives at the trackmark it just sets there with no visible action.
Uncoupling works in other scenarios.
Uncoupling close to the area where the incoming consist is transferred to a local engine works ok.
But not in the yard a few miles away.
Last edited:
The obvious first question is, does the "uncouple" command pop off the stack, as in having been executed and ready for next driver command, although it doesn't actually take effect?

Do variants such as "uncouple at trackmark" and "uncouple from (number of car in train)" work?

What happens if you reverse direction and give it a little push before trying to uncouple (to give it some slack)?

Is there anything odd about the scripting of loco or the car being uncoupled?

Are you trying to do it on a slope so the car rolls back into the locomotive?
Thanks for the possible issues list. I have experienced some of them already as a learning experience.
This one WAS the need for a crossover between the origin of the train and the destination. Not an obvious condition that caused the uncoupling action to misfire. Doing more tests since the route is large and complex. Again, thanks for the response.
Last edited: