Unable to Download Kickstarter County I


''Trainz Veteran''
Hi all,

Recently, my new laptop arrived (finally!), and I am currently redownloading everything... including Trainz. I decided that, since TRS22 runs more stable than TRS19 in macOS Monterey, I would go ahead and use that as my version of Trainz on my computer. I am currently redownloading all my purchased items... however, I am having a problem with reinstalling Kickstarter County I.

Every time I try to install it, all the assets appear in CM, but I get an error message that reads:

CDP package installation failed:
Error: Failed to download preached data for package 'sc025d' at version '12345' for platform 'standard-7'
1 Errors, 0 Warnings

I don't know how to rectify this error at all. And if anyone's wondering why I'm trying to download Kickstarter I even though Kickstarter II is pre-installed... it's for the sake of having it. I'd like to have all my DLC items installed (unless it takes up too much space... but I made sure to buy this laptop with a 1 TB SSD to avoid storage issues), and I'd rather not reinstall TANE because... Rosetta. (My new laptop's an M1 Pro MacBook Pro 16", with 16GB of RAM as well.) Rather not risk running it in emulation.

Any help would be greatly appreciated.

EDIT: Just remembered - every time I click "Retry", Kickstarter I just goes straight to "Uninstall" in the Trainz Content Store. So I guess the game doesn't even know how to fix its own error! (Not that I expect it to fix everything for me, though)
Last edited:
I only see one in the Content Store - "Additional TANE Assets for TRS19". Is this what you're talking about? (Installing right now, by the way)

EDIT: It's throwing me an error as well!! What?!
Last edited:
My God, I'm an idiot...

Tried reinstalling Kickstarter I and the Additional TANE Assets for TRS19 in TRS22... got an error, clicked on the button, got the same error message. Clicked "Retry"... and it fixed it. I can access Kickstarter I and all of its content perfectly fine.

Sorry that I had to create an entire thread for such a simple issue. Sorry.
Don't worry about the thread. This is important for others in the future who will bump into the same thing at another time.

The Content Store does have a bug where you'll end up with a Retry button after downloading. Click on Retry then hit cancel and the status will change to installed. This was something we fell upon the hard way as we were installing content from the Content Store.