Trials and trubulations with taddeamon in TS12...


*HRH in real life*
What the hell is going on lately with my installed Collector's Edition of TS12, patched to 61388. Does anyone else being offline experience this below? Please let me explain. TS12 resides on a PC which I normally NEVER go online with. Why should I, this particular version of TS12 has a different serial number to the other TS12 Collector Editions I have installed on my Online PC and on another PC as well. I had bought 4 of these Collector Editions of TS12 in the past for specifically the above scenarios, so any of these versions will work on my PCs, whether off or online and only my Online PC needs to go online to download stuff like new patches, hotfixes and content CDPs.

Lately, almost every other day, I have to be online with my offline PC for validation, as TS12 refuses to load and gives me the now usual error of "not possible to load and repair database or seek Helpdesk help" or such. Once I go online, I get validated and I can close my internet connection and all is well for the next day or so. I use that version of TS12 ONLY to import created content I am presently working on, to look at and check to see how this works there, NOTHING else I need to do with this particular TS12 version on my "offline PC" but with which I still have to lately go online, as said, to get validated etc. to use this. Why?

When finally my TS12 is validated and opens up, I get this "video setting" error and the resolution of the screen in the options is suddenly reset to 1024x600 and changed from DirX to Open GL, when in fact, last night TS12 was still set in TS12's options clearly to 1980x920 and to DirX as this is/was always set there, with which TS12 is normally running. My windows vider resolution is also set to the same 1980x920 resolution, otherwise there will be a conflict somewhere. Why can I not SAVE in TS12 any setting I used just the previous day and getting the same settings back when restarting TS12 the next day, where I suddenly and lately get shafted like that above.

Why does taddeamon look and check for deleted items when doing a "Quick" data base repair when deleted items should have a delete flag against their file/entry or whatever, which tells that taddeamon, "DO NOT TOUCH, DO NOT EVEN LOOK HERE, I AM DELETED, hence I do not exist". Why isn't there in TS12 a "deleted item" log where taddeamon can check the deleted files index instead what it looks to me for the actual, physical deleted files in TS? If it has something like that in TS12 already, why is a "Quick Database Repair' taking so long and not so quick at all? Why does checking for deleted items take so long? All reasonable questions for me to ask, I guess.

Today, this morning after going through the above routine to finally get validated to open my TS12, which normally needs no validation whatsoever, I had a "can not open asset as this is corrupted" error. The same asset I was working on and had checked of being error free in TS12, before switching off my PC last night. Yet, as said, first time I could access Content Manager, that above error message came up. I thought being smart, I will now do a "Quick" data base repair. Strange, if that said asset is corrupted, this should not show me a preview window nor all the details of said asset.

So, after watching taddeamon first checking for over 28 minutes for "deleted" assets, again, why the need to do this, once deleted, it is ALWAYS deleted and not really worth crying about. If this was an important deleted asset, well, I can d/load this again, once CM tells me, this is deleted and I do not need any deleted asset checks. Nothing QUICK about any "quick data base repair" there if just the checking for deleted items takes so long.

But wait, there is more. After waiting with that "delete assets" repair, taddeamon started its "assets remaining to validate" orgy. Lucky for me, I only had a shade over 5000 assets to be validated, which still took so far over 103 minutes or so to do and is still presently stuck there. Just imagine, I had some 10ks or even some 100ks of assets in my TS12 as some of you have. Say good by for the day to use your PC, I might as well go fishing or do some other things. I bought Trainz to start up every time error free like any other games do and to enjoy these. Which was reasonable OK with TS12 in the past on this, my offline PC, with which now all of a sudden I still have to go online validating while experiencing the above. Again, why?

Just imagine, as some/many, perhaps all Trainz users get browned off with the above, just check the Forum for complaints about these issues. Heaven help us if TANE turns out to be similar. Why all this rigorous validating and checking, especial when I do not have any perceived corruption of TS12 from one evening, when closing it, to the next morning opening it? What else is there in play?

Can someone please explain, why Trainz seems to be the odd game/simulation doing this Data base thing when other games which you might play, never ever go into such hissy fits as TS's taddeamon does. Especial when I can see in this screenshot below how taddeamon is suppose to write to the database for the last 20 minutes BUT NO disk activity is shown yet and taddeamon just sits there presently as the screenshot shows:


Can someone please explain why the above is really necessary, which IMHO places extra frustrations, resentment and pain on a TS user for no apparent good reasons I can fathom?

As a side note, the CM window of TS12 with its error message earlier, which is presently open, is still giving me the "wait" message, taddeamon advanced to 103 minutes to write the database and is still not finished with its data base repair. So I still can not open that asset which showing in this CM window with "can not open as asset is corrupt". Yet, just now for testing I opened another CM window beside the first one, now all of a sudden I CAN OPEN this asset and do what I want to do with it.

My point is, just imagine, some new buyer of TS12 or even TANE is taken in by all the fancy and glossy screenshots and rendered videos and buys these games. Little does said buyer know what could or will happen on his/her PC by going through these "data base" repairs, He/she might say, hey, all I want to do is to drive my choo choos, I do not understand data repairs, I do not need to want to understand all this, all I want to do is to enjoy driving, creating, building or whatever takes my fancy I want to do with TS12 and possible TANE, once this has its final fix/patch, so we all know what TANE finally is capable of. Or possibly not.

Presently. I am still waiting for taddeamon to finish "writeDatabase", still stuck on 103 minutes for the last 20 minutes writing this post here and with my internet connection still open on that PC, in case this is needed for taddeamon to finally to finish. My hard drives are all USB 3 ones, why this slow saving on these drives?

My observations and opinion.

Arghh... it happened again, not enough to wait some more to finally have the database repair finished some 200 plus minutes in total, restarting the PC and not being online, the whole caboodle above starts again by giving me the same error message of not being able to "Open Trainz blah blah....". yet a minute later letting my firewall to access the internet, TS12 starts up troublefree as it did the last time some 2 weeks ago when being offline. I do not want to be online, I do not HAVE to be online, so what gives? Remember, I have a Collector Edition of TS12 patched to 61388 and never ever needed to go online with it before. I installed the patches and hotfixes via memory stick transfer from my Internet PC, from which I downloaded these.

Looks like I have to uninstall the whole shebang and see if this makes any difference at all. I have a sneaky suspicion that maybe, just maybe, N3V might have done something to the code of TS12 and not warranting a patch, this might get automatically patched when online. What do I know, my patching "automatically" in TS12 is turned off, my version number still says 61388 while my TS12 is behaving like that.

Anyone who can explain my tribulations? Why these things are happening to me with TS12? Anyone else being offline with TS12 getting something similar when starting TS12?

Thank you for any replies.

I feel your pain and frustration, Vinnybarb. There is no doubt in my mind that somehow, N3V has in fact messed with the internal workings of our games to make them unpalatable to us. This, of course, is supposed to force us to buy T:ANE, which, IN MY OPINION, is just more of the same with glitzy graphics. My gaming computer, which can run virtually any game I feel like running, is just barely over the limits for T:ANE. There is no way I have the funds to buy a water-cooled, supercharged, V8 computer for just one stinkin' game. I am a military pensioner, not rolling in dough.

To address your programming difficulties, I tried a few things myself here like pulling on and off the network connection and the like. I am hampered because each of my computers is either wi-fi or hardwire connected to my switches which, in turn, are connected to my router/ADSL modem. So, in order to keep Microsoft happy, plus all the little doo-dads and thing-a-ma-jigs that need to phone home once in a while (ostensibly to keep me safe from creepy-crawlers), I cannot just 'yank the Internet plug'.

But I can run a few analytical programs alongside Trainz when it starts up. Vinny, I am with you here on a couple of items: When TADDaemen says it is 'writing the database' quite a bit of the time it IS NOT DOING ANYTHING to the hard drive. I register NO writes at all - even though this process says it takes seconds to complete. The obvious conclusion is that those notifications are bogus and just there to keep us occupied while the game is frozen waiting for the thread to complete. Funnily enough, there are often WRITES to the HD even while the game progresses that are not logged in the TADDaemon window. Not surprising, considering just what it is supposed to do - be a 'be all-do all' to everything game-wise from kicking off threads that hang forever to keeping your game from running smoothly.

I fully expect that as time progresses, entropy will take over and TS2012 will continue to decline until it is a simple slide-show of its former self. When that happens, I will go back to my flight simulator and airport builder and do some creating in a game that works, all the time, every time, with no complaint - from me or it.

Last edited:
This is why I finally dumped all TS12 and have gone back to TS10. Very rare validation, mainly if I download a large amount of assets.
Got sick of waiting for 30 mins while Tad dithered about every time I started up.
I don't intend moving on to T Ane, finished with new versions after all the hassles with TS12.
I spend my time in ETS2 and Farming Simulator these days.

In the past on my particular offline PC, I had sometimes to go online when installing, say a different paint program or such to get that validated online. Similar with the odd TS hotfix or patch to get this to my TS12 61388. TS12 was working when offline again. My issues as said further above only happened some 2 to 3 weeks ago when patching TANE on the same PC. Like you, I have a suspicion something happened to my TS12 install to act as it now does. Whether intentional from whoever might benefit by doing this or not, my boxed Collector Edition of TS12 should NEVER EVER AGAIN have to go online to work. As said above, now each time I switch my offline PC off, restart it, say, the next day, I have to go online for validation again or the damn thing will not start up, only showing the same error messages I described above.

Just briefly to open the online connection when TS12 is trying to go online, only for 10 seconds or so, presumably to validate my DRM free TS12 copy, all is well again, I can kill my internet connection and get on with whatever I want to do in TS12 and restart TS12 as many times I want before switching my PC off again Then, when restarting my PC the same thing happens, I have to go briefly online to use TS12.. I do not have to go on the internet to use TS12, I do not want to do this. I do not know where to go from here, possibly only by doing a fresh clean install again. Sitting there for hours to get TS12 installed again, sitting again for hours to get a patch installed, sitting there again to install any other patch and any hotfixes to get me back up patched to 31688. NO other game, again, NO other game I know does this, why is TS12 and now TANE so cumbersome to install, patch and to use?

As said, I experienced all the above with taddeamon, a devilish program if you ask me. Often, another instance of it opens up at the same time to say something completely different in it. Why, isn't one instance of it stuffing up one's PC and telling lies not enough?

I thread the thought of reinstalling TS12 again, by what you also experienced, I do not think this might change anything with me. I am thinking similar, I never looked into my installed MS Flight Simulator X yet with all the extra planes, airports and sceneries I d/loaded and installed, I bought quite a few new current games in the past, ready to install, hence I probably never ever need Trainz again to occupy my time. Plus thereby not having to use TS12 and TANE and not getting frustrated, angry and disillusioned when trying to create content for TANE, as we still do not know the ins and outs of doing so.

Last edited:

Lately, I have been moving away from Trainz. There is a great, free, program for FSX that will allow you to create tiny local airports, or massive airports with hundred of gates. It is called Airport Designer. I love working with it and, since I got a set of pedals and a yoke from a yard sale (for $15) it is even more enjoyable. It doesn't require a massive database rebuild every time it starts up, and it operated in 3 dimensions much better than Trainz does in 2.

I've re-reinstalled TS12 for the last time. Bringing it up to 61388 this time was a painful experience that required four attempts. I will NOT got through that again. If this install dies, then TS12 will be off my system in a heartbeat. Like you, I don't plan to go to T:ANE. Mostly because I don't believe it is "a new era", just a rehash of the same thing, but with more strain on your graphics card.

I will say there have been some kind of connection issues. I got dumped in the middle of downloading and got the red error bar at the bottom of CM saying that my connection was terminated unexpectedly, or I was not a registered user the other day. I of course verified that the internet was working locally, even checked and rebooted my router and cable modem just to make sure. Then got the message again, waited about an hour and all was fine on the ether-net!

This might explain the errors you are getting recently, because I've been able to work offline with TS12 61388 any time before and with a second PC which I set up for travel. One thing I did fine, however, is disconnecting the wire doesn't work well with TS12. You need to disable the network completely on the PC via the control panel, otherwise the constant retries are awful.

The problem with TADDaemon is it was modified to do more than just connect, verify the connection, and then act as a database manager. Instead it became the jack of all trades and there is probably code in there with more than a few bugs. The messages about writing database... These could be just a generic message about some kind of database activity. I have noticed that occur when switching from scenery to trackside assets in Surveyor, this message will appear after the switch. Wouldn't this be a read and not a write? I noticed too big pauses during sessions that occur when an AI driver updates the schedule queue, or the script kicks in for a station then there's a pause, an actual write possibly, then the write database message.

So, yeah, I too have been doing some system checking as well. TADDaemon does its thing with the database management as it is the overseer of the database and prevents multiple writes and locks on the database the same time. This is why you get those write-lock or process locked messages. These make sense and I've seen these with the big guys as well including MS SQL when a user left a database record open and went to lunch...

TADDaemon is very verbose and reports everything that's going on. For database geeks and data geeks, this is a good thing as it tells what's going on under-the-hood. The reports about faulty dependencies, and missing dependencies are to me redundant and only confuse the issue more than help.

Those blasted data validations! ARGGHH! Yes, if you updated any DLC or built-ins, which of course are being done as I've seen some Auran IDs out on the DLS, you are going to get these. Unfortunately, too if the server goes tits up you'll get even more as TADDaemon goes looking for the login server and you may as well as hang up your hat for the day and do something else.


You probably already know that disabling your network at the system level isn't a real good idea. All the various bits and pieces of your OS communicate with the 'mother ship' (be it Microsoft, an A/V site, or simply an email server) so killing that connection makes them nervous. But, my investigations have discovered something about TADDaemon - it keeps banging it's electronic head against the closed steel door of your network connection hoping that someone will open it; and timing out while waiting. This keeps going no matter what. This is a programming error of a magnitude that defies imagination. I write and have written hundreds of programs that deal with the Internet and every one of them, upon detecting no connection will sit back and wait for it to be connected again. There is a SYSTEM flag that I check, which is in the registry, which changes state when the network is back. That does NOT require you to keep banging on the gate yourself. Since it is internal (to your computer and OS) you don't have to hang the entire game waiting to see if it opens. You just shrug and wait some more.

There are so many programming errors in Trainz that I am surprised it runs at all. To be fair, it is a massive bit of programming, but the in-house testing at the individual module level was sadly lacking. Auran, and later N3V, kept making the same mistake in rushing a product to market without adequate testing. I could see it one, and forgive it once, but each and every version has the same problems that haven't been corrected. Calling something "new" doesn't make it new.


I can't agree more. The only time I disable the network interface is if I am truly offline, as in not even connected to a network on my laptop. I noticed though having a poor network connection is actually worse. I was at one place where the wireless was so paltry it seemed as though I could walk faster to the server I was connecting to faster than the data could reach the router! ;)

With a situation like this, being totally offline helped as the program wasn't kinda sort of reaching the server a tiny bit but not fully, which caused TADDaemon to retry incessantly. When I totally disabled the network, Trainz TS12 didn't perform that bad as it was before though as the network interface was still chattering away in the background, it didn't have some information come back at it and force a reconnect when the connection dropped.

The programming errors, I agree are horrible. I'm not a programmer, but do understand code, and the structures that go in behind it. I would think that software functions that rely on I/O and other interfaces would make more use of the work that the OS developers did rather than attempting to rewrite history. This, I think, is one of the failings we have here. Instead of doing things simply, we have a team of young programmers who think they can do things better when the better way was already found. The other problems are of course legacy code and lost developer history as people have moved on from the early days.

The inherent baggage that has befallen the program, is now becoming more of an issue as assets and have been imported into "Trainz A New Error". This may explain many of the unexplained crashes we are seeing now as well as in beta. The unstable code makes intermittent problems, which are ever so difficult to find.

I tried to run TS12 three times yesterday, and had to wait twenty minutes each time while it validated the database. That's bad enough, but I was unable to use the PC for anything else while it was doing its thing.
A game playing friend, who also works on databases, says it's bad programming and he would never contemplate playing any game that behaves in such a manner.
I only run this version to test my creations prior to release, and it's no fun wondering whether I'll be unable to use the machine for anything else if I try to open TS12.

I tried to run TS12 three times yesterday, and had to wait twenty minutes each time while it validated the database. That's bad enough, but I was unable to use the PC for anything else while it was doing its thing.
A game playing friend, who also works on databases, says it's bad programming and he would never contemplate playing any game that behaves in such a manner.
I only run this version to test my creations prior to release, and it's no fun wondering whether I'll be unable to use the machine for anything else if I try to open TS12.


This might be due to some content updates which were sent to your TS12 and started up a validation.

Your database manager friend isn't too far off the mark. :)

I downloaded a couple of routes a few days ago so perhaps that's caused it. But the thing is the whole process is unacceptable.

I'm only trying to test a signal update, and can't even do that as it's checking the whole database again (15 minutes so far). At least it hasn't locked everything up this time or I wouldn't be posting now).

I don't like this game any more,
Just to be different......... I've just downloaded 900 odd updates in TS12 SP1 with DLC unusually at fairly rapid speed. All present and correct and it only did a short validation, odd as I was fully expecting it to validate for the rest of the evening, just closed and restarted and it's not validating, something bust or extremely unlikely fixed?
900 updates? got a bit behind due to using TANE!
I was hopeful after reading the clam1952 statement about the possibility of a fix for the Validation issue in TS12, but it is not to be. Tonight I'm validating 15000+ items, initially I launched CMP to look for any updates, failed login, and during the close it did a the dreaded flush (for a while) and closed, re-started CMP, this time it logged in and the validation kicked off ... so, now I won't have access to TS12 (latest version) for probably 6-8 hours while this goes on. If I wanted a database manager, I would go buy SQL Server or similar (but I already have it, so I won't) ... but for a Train Simulator (or any game/simulator), this is UNACCEPTABLE. I've learned from experience to just let it do it's thing, even if I can launch TS12, It don't while validation is happening.

Tonight I thought, let's see what happens when I try and launch Train Simulator 2015 (understanding the Trainz validation is going in the background) ... on a laptop. And you know what, it started, I loaded a route and continued my Career in Marias Pass (i.e. I actually got to run the simulator, not mess with a database). So, here's my question. Why should I keep spending money on Trainz (directly or 3rd Party) when a large percentage of my time is waiting on a database (whether it be because of DRM or not).

I'd much rather be writing that I am running JR's American Intermodal or Marias Pass X or any other route in Trainz ... but instead, I'm performing a database asset validation ... oh joy ... how fun ... NOT!!!!!

And yes, I own T:ANE Deluxe Edition ... sure, tell me it's better about validation (is it? I don't know, I haven't added much other than what came with it ... but here's the real kicker ... it won't run on my laptop (works fine on my Desktop, but tonight I'm on my Laptop), so TS 12 will probably be the last on this laptop. And yes, my Desktop went through the same process for TS 12 a couple nights ago ... kind of thinking this is the dreaded DRM ... and frankly, it's STILL UNACCEPTABLE.

Is Trainz a better simulator than Train Simulator 2015 ... well, if you can't use it whenever you want, it's not!!!!!!!! I have NEVER had any type of issues starting up TS 2015, loading a route and quickly being able to use it. And don't give me the old story that I have to deal with Steam DRM ... if Steam is down (or inaccessible due to internet issues), I can STILL launch it in offline mode, and use the simulator ... I just can't buy anything (or access the community while STEAM is down) ... and yes, I have TS 2015 installed on both my desktop and laptop.

I get DRM, I get needing to keep databases stable ... I really do ... I'm a software developer by trade and use database regularly, but this is a disaster ... frankly, to me, the writing on the wall is starting to become very clear. The amount of money I spend on Trainz is (already) significantly less that what I'm now spending on TS 2015 (and it's not because TS 2015 is overpriced ... patience will allow you to get some really good sales ... just like Trainz assets are often on sale, so are TS 2015 assets at times) ... and frankly even if it does cost a bit more, at least I can use it. I bought Train Simulator (2014) for the first time a little over a year ago. How many times have I had to wait for validation since ???? N-E-V-E-R!!!! Even the auto updates aren't even close to as much of a hassle as Trainz asset validation is.

Since I'm running Windows 8.1 (and will update to Windows 10 soon), I've tried the Windows 7 compatibility tricks mentioned elsewhere ... to fix the validation issues ... it doesn't work ... evidently nothing does.

Would I prefer to be using Trainz vs TS 2015 ... I really don't know anymore, both have their negatives, both have their positives. So, it comes down to which can I actually use ... and I'm not talking about using it for a significant of amount of time to keep a database stable rather than actually using it as a simulator. THERE'S GOT TO BE A BETTER WAY!!!! Please FIGURE IT OUT!!!!
Last edited:
There must've been something that caused your connection, jkfrench. For a short time, about an hour or so ago, I lost connection to the forums here and to the DLS and servers. Perhaps there is a connection issue related to the flooding in that region where the servers are located. Things are up and running now, but are slow.

I do understand your frustration though.

There must've been something that caused your connection, jkfrench. For a short time, about an hour or so ago, I lost connection to the forums here and to the DLS and servers. Perhaps there is a connection issue related to the flooding in that region where the servers are located. Things are up and running now, but are slow.

I do understand your frustration though.


Even if I lost connectivity for a little while (of even failed logging in), it shouldn't have to re-validate 15000+ assets afterwards ... if I couldn't login, it didn't update the database right? So, why should it flush my assets and require a validation. Not because the database became unstable. This EXACT same thing happened, in the exact same way on my desktop about 3 days ago ... same invalid login, same flush, same 15000+ asset validation that occured on my laptop tonight (and it's still going). I monitor the TADDaemon like a hawk to make sure I don't inadvertently corrupt something by doing something while it's closing down. I think it is the DRM working it's magic ... seems to happen about once every 30-40 days ... maybe more, I'll try to keep track this time (posting to the forum will give me a timestamp). Everytime I see an invalid login and the asset flushing when closing CMP (along with a lengthy shutdown) and am able to login immediately thereafter (no problem), I know that the next CMP run will force a huge asset validation (and again, if I can't login to CMP, the database shouldn't get corrupted because I can't download anything!!!!). I don't think it has anything to do with connectivity, I think the failed login is a remnant of the DRM process (I don't know if everyone sees it or not, but I definitely do). I don't know why we just can't have a login/license key check rather than this mess. And if it's not DRM and just the failed login (due to server issues) that's even worse (and I'll say it one more time, I couldn't login, so I couldn't download anything to update the database ... why in the world would it need to validate anything after any failed login????????).
Where do I find TS10?

I own TS12, after reading all the database issues you have experienced, (Im an old Steam Acount too) Im thinking I might want to regress into TS10....

Thanks for all the great info here, Im glad I have not purchased TANE yet either, shades of WIN8, I always wait 1-2 yrs for things to iron out, or I don't buy it period, learned that after buying a new model year truck that turned out to be a lemon and costs 1000$ in repair bills, because the idiots (engineers) tried to shave off metal, and other items that should never have been.

One more thing I didn't mention and is important ... actually the flush happens on every shutdown of TADDaemon ... but when it says something like 20000+ Assets Changed State (there's more to the message, just can't remember what it is) around the time of the flush (I think it's right after), that's really the indication that I'm in for a long validation day/evening (and it's also why I think it's DRM related ... and there's always a failed login in the mix). I have had failed logins during server maintenance where it DOESN'T go through the validation (and Asset States don't change) ... that I would guess is a connectivity issue, but it's a reasonable connectivity issue (I don't expect the DLS servers to be up every hour of every day). So, I really think the whole Asset Change message is the key ... whatever kicks that off (DRM) is what is really causing the huge validation process. If I were to also guess, I say this very well could happen locally (no server connectivity required) ... the DRM clock ticks, I try to access DLS, time for DRM check, reset asset states ... close CMP, next CMP launch, do the validate (login works fine ... and if it didn't ... I'd guess validations would fail and I'd likely have a boat load of missing dependencies due to failed validations, etc making TS 12 pretty much unusable until a validation can occur again ... I've had that happen too ... which also brings me pause. Because N3V will eventually stop supporting TS 12 and at that time, after the DRM period expires, TS 12 will be useless ... it may take years ... and I may not really care by then ... but still ... I've purchased it, I've supported it, it should be my decision when I stop using it ... not expecting customer support forever, NOT even expecting DLS support forever, but as long as I have a computer and OS that will run it, I should be able to use it, including loading assets for the version if supported by 3rd party sites) ... I can still use Microsoft Train Simulator (and it runs fine in Windows 8.1!!!!), can still download and even purchase assets from 3rd Parties ... Trainz (any version) should be no different.