Surveyor: My routes are being saved as 'Read Only'

I've been working on a a couple of routes, switching back and forth periodically, and I've noticed the over last few days that they are being saved with the little "c" like they are built-in content.

I'll make some progress and attempt to save my changes only to be told the route is 'Read Only.' Not able to figure it out, I've been saving new versions with different names and deleting the old ones.

Why is this happening? Have I changed a setting somewhere to enable this without realizing it?

I don't know if it makes any difference... but autosave is enabled.

Absolutely right, thanks.

(That what I get for writing this the next day, on a different computer... at work)

They are still read-only. Can't save with same file name.

I get hit with that bug a lot on large routes, especially if I've just been working on scenes with lots of assets visible.

My route's ground file is currently around 90 MB. I've plopped down tons of buildings in my Morgantown area while I'm working on it; basically I've put any building I might use in the vicinity and I've been positioning them and deleting unused structures as I go, but for now that means I have a zillion assets in the area. If, in Surveyor, I've moved through the Morgantown area at all, even just in passing, when I try to save the route, it says it's read-only and I have to use "Save As" rather than "Save" to get the route saved. In my case, though, I don't actually have to pick a new name -- I just keep using the same name and it gets overwritten with a new KUID.

It's sort of annoying since I'm going through KUID numbers like crazy. :p And I suppose it makes Trainz feel less robust, so I'm sure it taints peoples' impressions of the software. It's never actually caused me any trouble, though, aside from the extra KUID usage and the annoyance of having to first try "Save" and then wait to see if that fails so I can pick "Save As"; so I've been lazy and haven't actually reported the bug to the Help Desk. But maybe someone at Auran will read this message.

- Madeline
Last edited:
The "Read-Only" save message while in surveyor also serves as a warning. It can occur on large routes if an error has happened elsewhere on the route which if the route is saved, could result in a corrupted route file.

The "read-only" message has occured with my route when the terrain on several baseboards became corrupted by the use of the "undo" button. The dreaded "1000 foot high cliffs" suddenly appeared on several baseboards destroying the terrain. This error effectively destroys the route if you disregard the "read only" message and save anyway.

The worse part of this is that you may not know that several baseboards have been corrupted because the "1000 foot high" cliffs do not appear in the area you are working in at the time of the save. They may appear anywhere in your route, and you will not know it unless you check your whole route. Thus you could continue working for days after the "cliffs" have wrecked your route and not know it unless you happen to check your whole route for errors.

For this problem my advice is as follows:
1) do not use the "undo" button when you are working on a large route

2) if you get the "read only" save message, DO NOT SAVE YOUR ROUTE YET

3) check your route over carefully, looking at all baseboards for any terrain or track corruption (stretched track going off into empty space, etc.), giant cliffs, etc. that may have appeared

4) if everything on your route looks normal save your route under a NEW NAME

5) exit Trainz and backup your old route

6) make daily backups of your route as you work on it

This will save you from losing all your hard work on your route. (I almost lost 2 years work and was saved by a backup, so I know). :)

If you need more info on the read only error and the undo button there is another thread about this in more detail.

Hope this helps!:)

If you are using TRS04, just go to:


and burn the "maps" folder to a cd.

I do not know where custom maps are saved in TRS06 since I only use TRS04 for route building.
Thanks, I have 06 but now I know what to look for. Bob
Bob, TRS2006 handles things differently, so there's no point looking in World\Custom\Maps for your route. :p

Just open CMP, click on the "My Content" tab, right-click on your route in the list, and choose "save as CDP" to save it somewhere safe.

If you want to save your route with all the custom content used (which is what I do) the instead of right-clicking on name of your route, simply open up the "pick list" panel on the left of CMP, and drag your route onto it.
Then right-click on it in the pick list and select "add all local dependencies" and it will add all the dependencies of your route to the pick list.
Select them all again and add all the dependencies again.
Repeat this until no new dependencies are added to the pick list (you have all the dependencies and the dependencies dependencies, etc. :D) and then click the "view in main list" button.

You can now select everything in the main list, right-click and save as CDP to save your route and every custom item it uses in one easy to install CDP.

One note is that if your route is huge and the amount of content is staggering, then you may have to save it to several CDPs.
Give it a go in one CDP and see how it goes.

Hopefully you'll have more luck with CMP today than I have.
It's in one of it's moods, and will not run for more than a few seconds before locking up for me. :rolleyes:

Thanks all for the great info!

My route is large... about 250 real-scale miles. It doesn't have anything in the way of assets yet, except for 32 miles of double mainline track and the HOG textures; but I guess those DO count.

My troubles started when I began to merge terrain-only routes and then blended the baseboards. (Thanks BTW to fishlipsatwork for some fantastic DEM landscape routes.)

Norm gave me the idea to check the config file. While there was no problem with my user id, I did find a bunch of 'extra' line-items which I removed and the problem seems to be solved.

I really appreciate all the replies... Not only did I solve my problem, but I have also learned some new things thanks to Maddy25, Leader2302 and Smileyman.

It's replies (and folks) like these that make us all a little more intelligent, our hobby a little more like art, and Trainz a lot more fun!

I had something similar happening to me: I had my large route with all the (several) sessions. One day, there were no sessions! Looking at the files, I found that the sessions had the KUID of the route, but the KUID of the route was changed! And this time the KUID started with a -2:XXXX. So I changed the "Map KUID" in the config files of the sessions, and Bingo, everything works normally... But now I can't delete the sessions at the starting screen (the button lights but does not work). Why the KUID changed.. no body knows, but if any of you knows, let's have it. I have'nt tried yet to change the KUID of the map to a "normal KUID" and see if this solve the anoyance.:confused: