Stuck at load when merging modules of 1 MB or larger file size

Yes, definitely increase your RAM. Why only 1 TB drives? 2 TB are inexpensive now. Put your Trainz data on a 2 TB drive and be done with it. You can probably do some drive clean up and optimization too. The Trainz drive can lose the contents of backup folder periodically along with clearing the cache/internet folder. I've seen Trainz backups eat up to 50 GB of space or more if I do a lot of route building, downloads, and repairs.
In my defense, when I first built this PC, I didn't know Trainz would take up as much space as it does. So I thought a 1 TB drive would be all I would need. It also probably doesn't help that I've also got a few Steam games installed on my D drive as well.

Hindsight really is 20/20. ^^;
Right, system restart completed, DBR run and route reverted.

I'm going to try this one more time. I'll update and let y'all know if it worked or not.

P.S. What is the optimum time for a nine-board, 1.6 MB module to merge with a 6.1 MB route
I'm not sure if this was mentioned or not, but there should be no Consists on either of the Routes, except invisible ones used for Crossing Control.

Always use Find Command, Tools Menu, and look for Consists on each Route.

Prior to deleting them off my Routes, I make sure to save the ones I want in Trains Tab "add Consist" Button.

Also, if you want to see what Consists are installed Globally in your Trainz, Open CM and use Consist Category to display all the Consists you've made, bought with Routes, Payware etc. You might be surprised how many you have collected over time from yours, DLC and Payware purchases!

As a Bonus, if you do a Consists search on DLS, it will blow one's mind how many have been maid by Members. And you might see something you like too.

I think this one thing some folks are not aware of when they Merge Routes, I should also say, I have merged many Routes that had a few consists on one or both, but the Rub is, where is the cutoff point, that caused the Merge not to work?

So the cleaner the Route, less is more is a bonus when playing the merge Game.

Hope this is of some help.
Updating from the related thread to this one.

Turns out that it was the turntables that were causing the issues.

From the Route emerging issues thread:
The track replacement went off without a hitch, and the module merges just fine now! However, I've also found another issue that was playing into my merging problems. It turns out that, for some reason, my game/PC refuses to merge any route that has a turntable onto an existing route! And just to be sure that it was the turntable that was causing the hangs, I created a new route with just a turntable sitting in the middle, then I tried to merge it with one of my other projects, and right on queue, it hung like a condemned outlaw.

You can get around this by using the offending route as the base route and merging everything else onto it, or just remove the turntable from the offending route, merge it, and then re-add the turntable.

Merry Christmas y'all!