Starting SP SD40T-2 In "The Walong Stall" and "The DPU Push" Does Not Work

Starting SP SD40T-2 In "The Walong Stall" and "The DPU Push" Does Not Work

In the "The Walong Stall" and "The DPU Push" sessions of the Trainz Railroad Simulator 2019 Mojave Subdivision route, the Southern Pacific SD40T-2 Locomotive (the lead locomotive in my assigned 2 loco lash-up) I was assigned with at the start of the 2 sessions, do not operate correctly. When I attempt to move the lead SP locomotive (the Southern Pacific SD40T-2), it inches slightly, but at a very, very slow pace and at times gets up to 3 mph, but slows back down again to below 0 mph. I have attempted to figure out the problem countless times, seeing if any of the brakes are still active, seeing if the loco isn't on, applying sand to gain more traction, and even turning the engine off and then turning it back on again, but nothing worked. When I spawn another Southern Pacific SD40T-2 locomotive, the spawned locomotive works normally like any other locomotive, yet my starting loco is very stubborn and doesn't feel it has to operate per my request to it. It doesn't even move in DCC mode. What is the problem that I am encountering?

Another issue of the Mojave Sub is the fact none of the railroad crossings work at all. They don't activate when a train (or road-rail vehicle) approaches the crossing. While I haven't checked whether or not it's because they're not even set to activate, I'm positive that it's not because they haven't been set to activate. Does anyone know why they're not activating?

I am not the only one who encountered this problem as there is another steam user who rated the Trainz 2019 DLC Mojave Subdivision with a thumbs down, stating that the 2 sessions I had mentioned were broken, and that his starting loco wouldn't move as well. But there hasn't been any discussion of the problem on the Trainz Railroad Simulator 2019 Discussions section on steam, so I am assuming there hasn't been a fix for it.

Note 2:
I am aware that Legacy Of The Burlington Northern V2 for Trainz 2019 has suffered from a similar Rail Crossing issue, all of the railroad crossings in Legacy Of The Burlington Northern V2 have been fixed (not sure when, but I know it was 4 or 6 months ago), but the RXRs in The Mojave Subdivision have not been fixed. But can someone tell me what is actually causing the railroad crossings to not work correctly and how N3V games fixes them?
When TANE first came out, I was able to run both the sessions you note with no problems. There were some other problems with some of the sessions, where they couldn't be completed because the game dumped you out when you reached such and such location, so the Mojave wasn't working completely right. But, Walong Stall worked, and so did the DPU Push. Also, all the train crossings worked too.

Through several updates of TANE, those being SP2, SP3, and finally SP4, most of the sessions stopped working right for me. In fact, I found that the engines for DPU Push were now all locked in place when trying to start up the long train, and playing in Cab Mode. I was still able to move the train properly in DCC. By this time, other things weren't working either, such as the railroad crossings.

In the meantime, TRS19 had come out, and I immediately snapped that up, hoping that all the problems with the Mojave Route would now be fixed. I really liked the route and the sessions, those that worked. I was very disappointed to find that all the problems from TANE came over with TRS19, including all the railroad crossings not working.

For the DPU Push, when I tried to start up the long consist in TRS19 in Cab Mode, after coupling the pusher engines to the rear, my train would not move, or as you noted, it inched a little and then stopped. I had the sander going, and made sure the brake dump was in play, clearing out all the brake pressure, but the train would not move. Because it was TRS19, I could shift, in game, from Cab Mode to DCC within the session, unlike in TANE, and I could do this and get the train moving, but as soon as I switched it back to Cab Mode, the train came to a screaming halt and refused to budge.

I mentioned this in the forum, but no one else seemed to be having the same trouble, or they just weren't playing any of the sessions.

I reported this to N3V, and I spent a lot of time with N3V QC guys, trying to figure out what the problem was, but that never happened. There was never an answer to what was happening in my game.

The only "fix" seemed to be to save the session to my kuid, and then edit the session engines out, replace them with the same type of engines, and Voila, suddenly I was able to drive the long train like it was supposed to be driven, in cab mode. However, doing this messed up the session, so I no longer had the game instructions on where to proceed, etc. Since I had run the session many times before, I already knew how to run the session, so I could play it, just without any navigational displays.

Oddly enough, the Walong Stall works right for me in TRS19. More of the mysterious ways Trainz works or doesn't work.

I was wondering at the time why N3V didn't fix this, since it was one of the flagship routes that came with the game (and still does) and would show off how nice the game was. I was told that since the route and sessions weren't developed by N3V, they would leave any fixing of the route and sessions to the original author of the route. And, as you see, that never happened.

The DPU Push is a really neat session, and I'd love to see it fixed, but if it hasn't happened by now, it's not likely that it ever will.

Today I tried the Mojave route since updating to SP4. I started the East #991, but when it loaded, it told me my train derailed which was a major violation. Then it shut down to the session screen. I tried a couple of times. I then tried the Mojave to Bakersfield and got the same thing, my train had derailed. I can't even start a session. I haven't tried the others. Some of my other routes work, but have lots of stutters.

John K
All you have to do is use the "Get consist" tool in the train tab in surveryor, delete the current consist, then past the consist you created and you shouldn't have any problems. Or just move it a few inches or feet and then it should work. And well I am also getting some stutters with my game as well, but I just turned my graphics settings all the way down.
My problem with the DPU Push session is that the first three coal cars refuse to be uncoupled at the first turnout, stopping the session right there.:'(