TRS19 install has problems with certain locomotives in certain sessions


New member
TRS19 is great and offers a near infinite number of improvements over TS2010 and TS2 Mac. This is not a thread intended to criticize TRS19 in any way.

I posted twice previously about the issue I am experiencing, once in the TRS19 FAQ and once in the TRS19 Marias Pass threads over two weeks ago.

Hoping for help from N3V and the Trainz community I will ask here:

Has anyone experienced issues with locomotives not working properly while using Cab mode in sessions running TRS19?

I recognize this is a very specific question for what appears to be a very specific circumstance. Nonetheless, I am asking for help, please.

I have experienced various issues with locomotives not working properly while attempting to use Cab mode in several sessions using TRS19.

This issue is not universal in my primary/large installation of TRS19 but has occurred in several sessions in different routes including:

Mojave Sub TRS19 dlc
Marias Pass TS2 Mac version from HP Trainz
some WIP sessions

The locomotive problems encountered range from locomotives that are completely incapable of tractive effort in either direction to oddities where Cab mode seems to fail and requires use of DCC or Drive command in order to continue in the session.

In my full TRS19 install two of the Mojave Sub sessions have this problem: none of the player locomotives work properly using Cab mode in Mojave To Bakersfield and The DPU Push; the latter begins with a derail that immediately ends the session. ATSF #991 East and Walong Stall work correctly. Also the dls Mojave Sub sessions work perfectly, unmodified.

Marias Pass X 4.5 Empire Builder Amtrak 7 and 8 sessions require moving from Cab mode to DCC or implementing Drive command in order to continue: at certain locations Cab mode fails and the player locomotives cannot be moved/operated by using Cab mode. I need to test more but Heavy Haul over Marias Pass works properly through or past the CFAC interchange. CFAC sessions seem to work fine but I need to test more.

In the WIP sessions each of dennr’s Union Pacific Dash 9s (modified and updated with permission of davesnow and norfolksouthern37) all exhibit the same behavior: using Cab mode no positive tractive effort, no movement forwards or backwards is possible. Even more than this the locomotives that won't work in Cab mode oddly seem to act like tractive effort black holes, that is they not only do not move in either direction but also seem to negate the tractive effort of other locomotives that operate normally (in the situation as described these locomotives are more than dead weight…they seem to exert “negative tractive force”?). These locomotives work perfectly outside of two sessions made by dennr who is an experienced, veteran and talented session creator. Additionally other locomotives modified by dennr work perfectly in the same session: Union Pacific SD59Xs and ES44ACs (also modified by permission of davesnow and norfolksouthern37).

For what it is worth, in each of these cases I have been able to replace the locomotives by means of session edits in Surveyor using the asset identifying tool, deleting and then replacing the exact locomotive asset; this fixes the locomotive Cab mode functionality, allowing sessions where these issues have cropped up to be run properly.

Several DBR and a few EDBR have been performed to no avail.

I have deleted all unessential obsolete assets: in TRS19 I have found that at least one passenger asset — Passengers <kuid-3:11061> — that is obsolete will cause issues with the obsolete table and other versions of passengers if it is deleted so I am always careful not to delete that. I use a few types of passenger commodities depending on the route, rolling stock, era, my need to occasionally see Tom Baker’s doppleganger, etc. :p

TRS19 build 100240
i9 9900K
GeForce RTX 2080 8 GB
only Win 10 Defender used for antivirus

As of the last weekend in June I have a second smaller install intended for beta testing for beta testing and session building; with my second install all locomotives operate normally.

This smaller install includes
Canadian Rocky Mountains Golden, BC
C&O Hinton Division
Kick Starter County
Kick Starter County 2
ECML Edinburgh to Dundee
ECML Kings Cross to Edinburgh
Healesville 1910-1923
Sebino Lake
and the route for the WIP sessions.

The full install has many routes and sessions including the TRS19 international version routes as well as several TRS19 dlc routes like N3V’s Mojave Sub, others from the DLS like UMR19, a few msgsapper routes, etc and my own installs from TS2 Mac backup files like Marias Pass X 4.5.

In trying to troubleshoot this problem I have tried to consider and test

locomotives and engine specs

TRS19’s excessive acceleration/excessive curve speed/rough handling warnings

session issues:
a) some asset, rule or command is causing or contributing to the weird behavior in some sessions with some locomotives

b) problems with modifying session content or attempting to run some modified session content

some conflict with procedural track and AI drivers in TRS19 under certain session conditions

some conflict or corruption in my full installation of TRS19

To be clear though, at this point I am not certain about any possible causes or even the source of the issue(s) but it does seem clear that my full TRS19 install has consistent issues with certain locomotives not running properly in Cab mode in certain sessions. I recognize this is both highly specific and extremely generalized.

Any thoughts or ideas about what might be causing this problem/these problems?

Any thoughts or ideas about possible solutions?

Recognizing I could reinstall TRS19 and that might solve the issues I have experienced, how might this be done in such a way that might solve what is occurring but also retain the large TRS19 database for the install exhibiting the problems?

I have spent well over 40 hours in the past month installing, fixing as necessary and testing lots of different content and would very much like to try to find a solution short of completely starting over with a new TRS19 installation and a new database.

Thank you for reading this long post and considering the issues here.
Thank you very much for offering any suggestions or insights.

Two things come to mind, although not sure they apply here.

First, derailment at the start usually happens to me when the map is updated, but the session is not (ie. the map is <kuid2:xxxx:xxxxxx:2> but the session was created on map <kuid2:xxxx:xxxxxx:1> and track was altered somewhere in the newer version). You could check the session config.txt and see if it calls for an older version of the map.

Second, the traction issue. Only thing I can think of is the engine spec and again, a version difference between when the session was created and the loco placed, and when you tried to run it. Though the only thing I have seen there is that usually the updated engine spec is ignored until the engine is removed and placed again. It does not normally cause traction issues but maybe worth a look.

Perhaps start with one of the locos with a traction issue. Open Content Manager, find the loco and its dependencies. See if they show as "Installed, Payware"/"Built-in" or "Modified, Payware". If any shows as modified, you could try reverting to original. To be honest this is a big stretch, and I doubt you will find the version as the problem.

My experience with uninstalling and reinstalling TRS19 is on a PC and started with the digital download (installed then removed) and ended with the Steam version (installed). When I uninstalled the digital download version, it left the data folder in place with any downloaded content as well as the database. When I installed from Steam, it created a new data folder, and I simply followed the notes for Moving the data folder to then point the new install to the old data. Whether you will have the same experience on a Mac, I can't say, but I certainly hope so.

Hopefully someone will come along with a better idea and better suggestions. Might be worth opening a ticket with the Help Desk. Whatever happens I wish you luck in solving your issues.

Eric (aka. WheelChock)
Thank you very much for your time, help and suggestions Eric.
Thank you very much for reading that very long opening post!

1) derail in N3V's Mojave Sub DPU Push
I have not checked session route config/version matches. That is an excellent consideration!

2) traction and proper Cab mode function
I will take a look at config/version matches for the locomotives within sessions as well.

Based on your reply I will also recheck, reinvestigate engine specs and focus on built-in and payware components specifically.
I did previously modify the locomotives that have exhibited unusual Cab mode behavior and did a couple of engine spec swap outs but that did not alter or improve the Cab mode oddities, though I have not specifically tried to revert any engine specs (built-in or payware).

Thank you, I will look into those possibilities tonight.

TRS19 is on a PC; TS2 Mac is on an old Mac Mini.
This is my first PC; I've used Win/DOS machines at work going back decades but there is still a learning curve as well as a relative degree of comfort to be attained for using TRS19 Win 10 (vs. TS2 Mac on my Mini).

I appreciate you sharing your experience with TRS19 reinstallation.

Considering the issues with Cab mode in TRS19 Mojave Sub a Help Desk ticket may be in order.

That's an interesting report. To try to narrow things down further, I suggest making a series of changes to one of your problem sessions until you narrow down whether it is track, loco, rules, etc:
- Edit Session
- Make a small change (like adding a tree), then click Save. You will be prompted to save a new route and session.
- Exit Surveyor, go into Sessions and Drive Session on your newly create session (which is basically a clone of the original)
- Does the problem still occur?
- If yes, Edit the session again, and this time open the Train tab and click the Properties ? tool and change the engine spec of the loco you are driving.
- Choose a different engine spec (just make sure its for a diesel)
- Does the new engine spec have the same issue?
- Next Create Session and place the same loco in the problem area of the track
- Does it behave the same?
- Next would be to start editing the track (which changes the route of course)

By going through a variety of tests you'll end up with more information as to which factors are causing the problem.

Oh and also, ensure that you have the latest version of TRS19 installed (100240) as there were problems in earlier builds with some engines not wanting to get started.
Thank you for your suggestions Tony!
And thank you for taking the time to read that really long and detailed report. I have build 100240.

I hope I can narrow the field in terms of troubleshooting the combination of factors that is causing or contributing to the issue: Cab mode operation, certain sessions and session rules, certain locomotives/engine specs, track

Your post and Eric's are a great help.

Cab mode is how I always run routes for the first time; being a dispatcher and running several consists at once is great fun but I tend to stick to Cab mode for exploring most new content, whether new routes, new locomotives or new sessions.

I will implement all of the suggestions and report back.

With TRS19 running on a new PC all of the suggestions you have been made should only take a couple of hours to run some good tests.
Running on a 2012 Mac Mini with its built-in GPU, with TS2 Mac that might take a couple of days.

I am amazed at how fast so much can be done in TRS19 Surveyor.

Thanks again!

Last edited: