Several Errors when importing FBX (Blender/Substance)


The Golden Empire
Hello all,

I've lately been attempting to import some of my simpler models into TS22 but am continuously hitting snags.

I use the standard Blender to Substance workflow and used the export parameters from this video for exporting texture maps from Substance. I then loaded the created maps into the node trees in Blender and re-exported the FBX's out of blender and attempted to import to Trainz when I was given several errors. I've also tried rebaking the maps just for good measure but I still get the same errors. Forgot to mention I also made sure to tick triangulate when I export the mesh.
Here's a screenshot of those errors.
errors by S M, on Flickr
I trimmed down the image to show just one set of errors but they occur for all 4 LOD levels

I've browsed the few threads that mention these errors but I still can't seem to resolve them.

Thanks in advance. Any input is appreciated, and just let me know if I need to provide more info
I’ve encountered this as well. Check the shading setup of the lod2 blender file used for exporting to fbx and look for differences in the albedo file name. Trainz is expecting to see the same albedo file name it sees in lod0 and lod1 blender files. Hope this helps. Still new at this.
Substance Painter has changed a bit since that video was made but the basics are much the same. Those filenames are a bit long and I'd probably try shortening them if possible. The length shouldn't be a problem but worthwhile checking out.
I assume the texture.txt files and the images are in the right place?
I prefer to make my own texture.txt files rather than let the Triainz import process do it.
Also check your Principled BSDF Shader node layout is correct for Trainz. i.e. the parameter image is connected to the roughness input. The last error suggests that might be an issue.