Help: TRS19 Force-Crashes when going into driver mode.


New member
Hello, and apologies if this has already been posted, but I could not find it for the life of me.
I recently switched to a new PC and transferred my files over from my older PC and set everything up following the guide, everything works fine like it should until I came across a specific issue. For some reason, on a particular route, placing an engine down and then going into driver mode just force crashes the game without warning, without any messages, it just completely closes. It shouldn't be a storage problem since this is a brand new computer with plenty of storage across two hard drives, and it can't be a graphics card issue since my old PC's GPU got up to 92% while this new one only gets to about 5% on the same route with the same engines. Below is a list of solutions I tried which all didn't work, among other information I posted to Twitter.
-New PC with plenty of open storage using a Nvidia RTX 3060 Ti card, 2 weeks old, store bought.
-Changing build numbers on route, engine and building did not work.
-Changed settings to lowest possible and highest possible, did not work.
-Turned draw distance all the way down, nothing.
-"Mesh-table-lod-transition-distance" in the config didn't work at 500 or 1800 (two random examples)
-Tried uninstalling and reinstalling, same issue.
-Tried replacing the local data folder and so on with the one from my old PC again, no change.
-Always runs as administrator
-SP1; Build 105100 (This is the build I prefer to stay on as it's the best for my model exporting and runs the exact same as another collaborator I work with so having the same setup is ideal; he doesn't have any of these issues).
-Replaced the ACSLib several times with different versions; no change.
-Several database repairs; nothing again.
I was able to load up several other routes and models by the same creators on the highest settings and the game runs like butter so I don't think it's a PC problem, but this specific route (and the models too?) are important to a project I'm working on, and I cannot continue without them. (Said engines, routes, buildings, etc also don't have any errors or missing deps) I'm beginning to run out of options and I'm not sure what else to do.

EDIT: Uninstalling completely and going up to SP4 fixed it. Not sure what the issue was.
Last edited: