Firefox not launching CM from Downlaod Helper link


Trainz Veteran
Recently my Firefox 6 stopped automatically launching Content Manager (for TS12) whenever I clicked on the Download Helper link on the DLS or on the Download button on the Download Cart. Firefox gave me an alert message along the lines that Trainz was not listed as a protocol. This was obviously a problem with my system and not the DLS.

EDIT: March 10,2016: For those who have T:ANE installed the solution described here DOES NOT WORK. Instead, it is recommended that you download and use the protocol changer tool provided by Shane Turner (shaneturner). This tool will, in fact, work for all versions of Trainz. The tool can be found at ...

It took some investigating and Googling. One of the suggested remedies for this problem is to reinstall the program (e.g. Trainz), but that seemed a "bridge too far" for me. Alternatively, you could edit your system registry.

I found this page at Microsoft.

In a nutshell it seems that the URL protocol that tells Firefox what to do when I click on a link that has "Trainz:" as its identified protocol (e.g. the Download Helper link) was missing from the WIN 7 registry. Possibly an over-eager virus/spam/cookie cleaner had deleted this information (I think I know which program to blame for that). I carefully rebuilt the registry entry as described in the MSDN document, restarted Firefox and tried the Download helper link on the DLS - success!!

The steps involved are not for those who are squeamish (with good reason) about manually altering the system registry.

Basically (Windows 7 instructions): EDIT: T:ANE has a different registry structure so this is for TS12 only

  1. in the "Search Programs and Files" box above the "Start" button type regedit
  2. when it appears in the search results list click "regedit.exe". You may get a warning about making changes to your computer. Click "Yes".
  3. locate and open the HKEY_CLASSES_ROOT folder
  4. scroll down the very long list looking for a folder named "Trainz" - there may be one called "TrainzMap.document" which you should ignore.
  5. if there is no "Trainz" folder then its absence is the cause of your problem. If the folder is present then some of its data may have been corrupted - specifically check step 24.
  6. scroll back to the top and select HKEY_CLASSES_ROOT
  7. right click on HKEY_CLASSES_ROOT and select New --> Key
  8. rename the key (called "new key#1") to "Trainz" (without the quotes)
  9. an empty string value called "(Default)" will be automatically created in the new key. Right click on this and select Modify
  10. in the Value Data box type "URL:Trainz Protocol" (without the quotes)
  11. right click under your new string value and select New --> String Value
  12. rename the "New String#1" as "URL Protocol" (without the quotes) and leave it blank (do not select Modify)
  13. again right click under your new string value and select New --> Key
  14. rename the new key to "DefaultIcon" (one word and without the quotes)
  15. right click on the empty string value called "(Default)" in your new DefaultIcon key and select Modify
  16. in the Value Data box type "ContentManager.exe,1" (without the quotes)
  17. select the Trainz key you created in step 8 above and right click. Select New --> Key
  18. rename the new key to "Shell" (without the quotes)
  19. right mouse click on the Shell key and select New --> Key again
  20. rename the new key to "Open" (without the quotes)
  21. right mouse click on the Open key and select New --> Key again
  22. rename the new key to "Command" (without the quotes)
  23. right click on the new empty string value called "(Default)" in your new Command key and select Modify
  24. in the Value Data box type the full path and name of the Content Manager program (but this time WITH the quotes), e.g. "D:program Files\N3V Games\TS12\bin\ContentManager.exe" followed immediately by a space and then (WITH the quotes) "%1"

The final "Key" structure should look like:


Exit Regedit (the alterations will be automatically saved), fire up FireFox and test. It worked first time for me.

Windows 10 Changes:

Peter Ware
Last edited:
Why don't you just download directly within Content Manager's Download Helper? Downloads and commits to Trainz directly.

Bob Weber
Yes, I could have done that but if you are already in the DLS and see an asset that you want, why go the "round-about route" of manually starting Trainz Launcher then CM when the "Download Helper" link is right in front of you. I also sometimes place many items in my download cart which the "Download" button, if the link is working, will automatically download for me.
The main advantage of using CM vs DLS is that CM will also download all dependencies, if they're on the DLS.

Bob Weber
Thank you Peter, you've solved my problem.

For the record, my issue was slightly different. I'd, perhaps unwisely, installed a new version of Trainz without first uninstalling the old one. With the old version now uninstalled, nothing happened when I clicked on the Download Helper link on the DLS.
When I looked, the registry was still pointing to the old location of ContentManager.exe. I changed it to the current location (Peter’s points 23 + 24) and it works.
I was wondering about that myself, @pware. I was also wondering if you thought that the protocol changer tool you mentioned in post one would work on Firefox 122.0.1 for KUbuntu. I just didn`t want to contribute to necromancy until you replied yourself.
Fair enough. Thank you. Downloading,

Edit: No, I`m not. It requires .NET, so it must be a Windows executable, which in turn means that it is unlikely to work with Linux Firefox. Thank you anyway.