Coal Country - Free Steam Session with K&L Trainz


I'll make sure I get this out the way first: *The session is free, you need to have bought the route and train pack in order to enjoy it*

Liked Coal Country? Felt inspired by K&L Trainz's awesome videos and locomotives? With permission from Steve I've developed a roughly hour long session using the recently released PRR Decapods, coal cars, and cabeese(?).
Assembling a train for export, you will make pickups at local coal tipples battling the grades to remain in control, put your skills to the test in Realistic Mode, or cheat in DCC :p , up to you.

The session is freely available at under the freeware section, a link will also soon be provided on the Coal Country page at JR. To play you will need:

The Locomotive:

The Route: This route is for TANE only.

Teaser Video:

I'm interested in your feedback :) , let me know what you like, or don't like (don't want to hear about the length) about the route! Do you enjoy the sessions, do you not play the sessions at all? A lot of work goes into them so I'd be keen to know.




Cheers, Rich
I will be the first , MORE collaboration of this sort would be really appreciated :D scratchy well done :mop: . The route , content, and all !!!! And yes I'm a PRR guy , all the way baby..... LOL

I am having problems with the session.
No matter what I do I cannot get any instructions beyond loading at the first mine, once the train is loaded.
Just get the loading bubble.
Hi Mike, can you PM me a screenshot of where it gets up to?

Enter the mine
Stop train at the marker and decouple the loco
Couple to the other coal cars in the siding
Load those coal cars under the tipple
Couple them to the rest of the train and load the second half
Move forward to the stop marker where you will get you a message telling you to wait for the other freight train to overtake.
Follow the freight train up the hill to the town, there should be a green forward marker just before it goes into double track.
Go down the hill to load at the Parker tipple
Hi Scratchy,
When I load the second half it just stays on the load bubble. It just keeps counting the distance from the couple point with the load bubble.
Don't get the stop marker.
Last edited:
Ok, im going to have to run the session to try understand. I didnt think there was a load bubble for the second half. Just a bubble above the first empty coal car of the back half of the train.
Hi Scratchy,
I ran the session again to get a screenshot and it worked ok.
Starting afresh seemed to sort it. It was also easier to work out the sequence of events from your information. I have never really liked the bubble system.
I still have a problem to sort with the big freight train that didn't show up.
It is sitting at the end of the straight the other side of the yards.
It is sitting there with it's wheels turning at 1 mph and going nowhere.
It is also disconnected from the first wagon, a flatcar, with a space the length of a wagon.
It doesn't cause any problem with the session except I don't have to wait for it.
Also I have only just installed SP2 last week, after dumping it 6 months ago when it wrecked a big route of mine.
I installed Coal Country from the original JR files from when I purchased it when it was first released. Has there been an update since SP2 came out?
Thanks for your help.
I have one Unknown asset 156765:1599
Would anyone be able to tell me what it is and where I can download it?
Thank you
Mike, if there is a wagon sized gap it sounds like you may be missing a dependency. Is the wagon in the screenshot above in your game?

Mustang13, I don't have that asset installed lol, it looks like one of Simulatortrain's what are you missing it off?
Hi Scratchy,
I checked out the freight train and the flatcar has an invisible section on the front of it.The green arrow is a wagon length in front of the wagon.
It doesn't show any faults in CM and I have no missing assets.
Just a bit strange.
I am not worried by it as I was able to finish the session without it.
I enjoyed the session once I got my head around the bubbles. Also I have gained some really great steam assets.

edit:The screenshot appears to have a covered hopper behind the loco.
Just checked and the PRR LO 2003 hopper is missing the same missing dependency listed above. Checked the config and it is the bogies.
Last edited:
The overtaking freight train never came for me either as I waited outside of Richmond Tipple. I just ran the hill hoping I would not have to stop.

What a driving challenge it was getting up that hill (took three tries), down the one to Parker, and then double heading out of town. By the time the helper coupled, it only had about 60 psi in the boiler, so I had to steam it up on the way out.


Driving that session was a blast. Thanks for putting it together and thank you and Steve for some great content! I would love to see more JR and K&L collaboration.
How I got around the freight train problem was to delete the flatcar, that got rid of the hopper. Then I replaced the flatcar and added another airslide behind the loco.
Saved it as a new session and all works ok.
Couldn't get rid of the faulty hopper completely. I removed it from the config and it shows as missing dependency.
Tried to delete missing assets and it wanted a new route and session.
It doesn't cause any drama as a missing dependency in the session.
... i purchased and downed it today from k&ltrainz and didn't have the issue as described by mikeaust ... smooth session and as a real modelrailroader i used easy mode, so i did not have the experience as frimbo ...
have fun everybody

So there is the freight train I have been waiting on! And, yes, I am cheating a bit on the motive power ....