.
Results 1 to 8 of 8

Thread: Trainz 2009 - crashing on startup

  1. #1

    Exclamation Trainz 2009 - crashing on startup

    Hi All,

    This is my first thread but probably not my last.

    Can you help?

    I am running Trainz 2009 with the Service Pack 1 loaded.

    When I startup the program and click start on the main menu I get the following error message box appearing:

    "Trainz has encountered a problem and needs to close. We are sorry for the inconvenience."

    clicked more information and this appears:

    "AppName: trainz.exe AppVer: 1.5.0.38017 ModName: msvcr80.dll
    ModVer: 8.0.50727.42 Offset: 000176d9"

    If I click ok, TS2009 shuts down.

    I can only continue to run TS2009 when I leave the error dialog box open. As soon as I click ok to the error message TS shuts down!!

    Should I replace the offended dll file in each folder?

    I have reinstalled the program twice without change.

    Any ideas most welcome!

    Thanx, S.

  2. #2
    Join Date
    Nov 2006
    Location
    New Zealand, Wellington, Upper Hutt
    Posts
    3,796
    Blog Entries
    3
     

    Default

    Hi stoker001,

    First welcome to trainz, I hope you have a good experience once you get it running.
    As for your problem, a bit more information is required to see if the members on the forum can sort it out. Are you running Vista or XP or some other OS? What is your computer specs including CPU, Memory, Graphics card? Do you have the latest drivers installed?

    Hope we can help,
    Bill69
    If you are going to try cross-country skiing,
    Start with a small country.



  3. #3
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,163
     

    Default

    msvcr80.dll is used in all sorts of applications. For some reason, Trainz is crashing on your system when it gets to this stage. The challenge is figuring out what is different on your system.

    Does CM2 work correctly?
    Does the same error happen if you just install Trainz and not SP1?
    Has it always happened (i.e. did it work correctly at some point)?
    Have you installed any other software recently? e.g. movie players etc. If so, try uninstalling that and retrying.

    It could be hardware related (faulty memory etc). It could be a faulty Windows install. It could be a bug on our end (although we have had no other reports the same as this one).

    Sorry we can't be of more help.

    Tony

  4. #4

    Default

    reinstall .net 3.5 framework

    http://www.microsoft.com/downloads/d...displaylang=en

    see if that doesnt help.
    System.Console.WriteLine("Signature Here");

  5. #5

    Default

    My PC specs are as follows:

    CPU = P-4 2.4GHz
    Memory = 2.0Gb
    Video Card = NVIDIA GeForce4 Ti 4800 SE

    The program runs into the same problem with or without TS2009 SP-1 installed.

    I am in the process of installing MS .NET Framework 3.5 and also I noticed that XP SP-3 has not been installed.

    I will post back when I have downloaded & installed these updates.

    Many thanks on your comments so far...

  6. #6

    Default

    you dont need xp-sp3 installed to use trainz though the .net framework is essential.

    msvcr80.dll was updated in the .net framework and may solve your issue. i hope it works for you.
    System.Console.WriteLine("Signature Here");

  7. #7

    Default

    Problem solved!

    Initially I tried installing .net 3.5 framework but failed.

    Then I ran XP SP3 and then repeated the installation of .net 3.5 framework.

    This time it worked.

    TS2009 is running without a problem.

    Thanks so much especially Winterpaw for the advice.

  8. #8

    Default

    no problem
    System.Console.WriteLine("Signature Here");

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •