"Missing" Loco Stuck In Portal

Rate this Entry
Quote Originally Posted by RHKluckhohn View Post
Hope someone has the answer to this, I'm tearing out what's left of my hair.

I ported the FDL Fond Du Lac Branch from 12 (61388) to T:ANE (90945) and have a clean conversion except for the consists in two portals. They contain <kuid:17894:1539> MILW SD40-2, which is faulty and unusable in T:ANE.

I removed the loco from the consists in 12 and it was no longer in the kuid list in config.txt before the port, yet after the port, there it still was in the portal consists. T:ANE insists it is a missing dependency and won't validate the route. Tried deleting and rebuilding the entire consist with an available loco. No dice. The SD came back after the port.

I tried every combination of deleting in route, deleting in session etc. with no luck. If no one has the answer I'll have to try going back to 12, changing out the loco, deleting it from CMP in 12, "Delete Missing Assets" there and trying the port again. The step after that is to delete the two portals and see what that does, which means having to rebuild six consists. With no guarantee of success. Yuck.

"Delete Missing Assets" worked fine with scenery and splines, but not with this. Help?!



  1. RHKluckhohn's Avatar
    Issue resolved by ripping out the two involved portals, installing new replacements and rebuilding the consist list in each with valid assets. Took a day.