Unable to install Blue Comet, PRR Fleet of Modernism, and Aerotrain


33 Year Old Railfan
I have Trainz 12 Pre-SP1 and am trying to install the Blue Comet, Fleet of Modernism and Aerotrain DLC. However, they will not appear in Trainz's Content Manager. I cannot figure out what is causing this problem. Can someone help me?
To be honest, I was having problems with my computer and I uninstalled it. Now whenever I try to reinstall it, it will not appear in Trainz 12.
Have you tried a QDR after removing it?

Trainz did an automatic QDR when I started it. I selected 'Content' instead of 'Start' to see if they were successfully installed, and they did not appear. I then exited out of Trainz and deleted everything in TS12/UserData/cache/libraries. Also, I uninstalled it a long time ago, so I did not know at that time to do a QDR. Also, where I should I put it in the Trainz file on my computer? Userdata? Extras?
...where I should I put it in the Trainz file on my computer? Userdata? Extras?
I guess that DLC files are packed in .JA files so try copy these files to builtin folder and in options enter your DLC serial number.
Put the serial number in the Launcher options...

Hello. I am trying to do this but when I click "Add" it says that "The serial is invalid. Please use English characters." I was able to install on MyTrainz, but not the launcher. Is there a fix?
Copy from the online registration and paste into the launcher, if that doesn't work then you are probably not running Trainz as Administrator?

Right Click on the launcher icon > run as Administrator then try it.
I am running Trainz as an admin. I have downloaded the Installer, and THAT doesn't work.. BTW I am running Trainz 2010.
Just to check? an Admin account is not the same as specifically running as Administrator as in Win7 upwards the Admin account is crippled and you do not have full Admin rights.
I had no problem, did the purchase, added the CD-key as per instructions, it downloaded itself when I launched Trainz. 61388 build.
All right, I managed to get it to install. It turns out I had to put the .exe extension on the end of the installer. Thanks for the help though.
Last edited:
Add the "CD Key" where?
Put .exe on the end of what?

There's a known issue with the downloads where the installer/setup utility doesn't have the .exe on the end so the installer won't work.

For users prior to TS12 SP1, you put the CD Key in where you put your TS2009 or TS2010 CD-Key in when you first Launch Trainz in the Options. The installer may ask for it, but I can't remember.

For those who have multiple installations like TS2009, TS2010, TS12 ect the installer may get confused as to where you want to install the Comet
Make sure you have the correct location where the location is listed
For example I got two locations listed when I first tried to install it, I wanted to install to to TRS2009 but could not as this is at an earlier build and when I browsed to the TS2010 location it had put in two locations = Program Files\Auran\TRS2009\TS2010
I had to change the location to Program Files\Auran\TS2010 and for TS12 Program Files\Auran\TS12, make sure it does not put in two locations like Program Files\Auran\TRS2009\TS12 It wont locate them together it will only work with one location listed.
I have installed it to both TS2010 and TS12, the installer does ask you to input the CD Key and wont install unless you do.
On my installation I first did TS2010 this installed without incident the CD Keys are put in for you in Options and you dont have to do them manually .
One more thing that cropped up fo me was when I went to Surveyor to run the loco/coaches they were no where to be found
I found out you need to go to Railyard locate them in there and click on FAV so they are all lit up Green when you then go into Surveyor the Loco/Coaches are now available to you .
In TS12 I did not have to do this as they were already checked in the Fav, In TS12 it does download a Cdp for the Blue Comet at least it did for me.
Last edited:
I successfully got the Blue Comet to work, but when I try to install the 'PRR T1 - A Fleet of Modernism' it in the builtin (C:\Users\Jordon\TS12\Builtin) folder, it says 'An existing Trainz (TS2009 or TS2010) installation was not detected at this location'. Instead, I have to put it in C:\Users\Jordon\TS12, just like I did the Blue Comet. Also, I have to make a Program Shortcut in the Start Menu (Auran\TS12). Another thing is that I start up the Trainz Launcher, select 'Options', type in the serial number, it comes up as 'Content Pack (48286)', unlike when I put in the serial number for the Blue Comet, it shows 'Blue Comet Content Pack (44355)'. Can someone help me get this to work?