Turntable Problem


Well-known member
Turntable problem.
Since build 119450, a problem with exiting turntables has appeared.
In the first screenie, the loco approaches the turntable.
In the second screenie, the loco having gained the table with no trouble, is turned and upon exit, it will derail.
I've tried more than a dozen tables from 2.4 to 4.6 build versions
What am I doing wrong ???.
Any ideas please.


Cheers, evilcrow
Thanks for the tip and video.
The tables I've been using come with built in "stubs". Up to the latest version of TRS 22+, I've had no problems.
Let me have a try at your suggestion.

Cheers and thanks, evilcrow.
Just to confirm this is a problem in TRS22+ occurs with IM or Trainzmesh with or without lod using the new method or lm.txt.

About to try direct tract connect on one of mine with no stubs.

As an aside the annoying waggling track issue can be solved by making the track part of the turntable and attacking invisible track to the table instead of actual track.
Hello Malc,
I too found the "waggling" most annoying. I made a clone of one of Samplaire's bridge L300 tracks converted it to category-class HM and kind "MESH".
Added attachment points and an invisible track, looked OK and no "waggle".
Cheers, Ken
Hmm, loosing the attachments for the end of the stubs works however still requires the kuid for attached track that won't be visible, however it seems to be working OK.
Hello Malc,

The problem would appear to be the "stub" tracks. Having down loaded Steve Flanders one track, two exits TT http://www.jatws.org/ing4trainz/gwr-buildings.htm <kuid:169585:40430>.
I removed the attachment points for the stub tracks in IM editor, the spinner attachment points remain.
In game then attach the running track to the spinner and all is well (after a fashion).
Also today on the DLS a reskin/mod by "philskene" "NG24 65' Turntable (iron) - 1 track" <kuid2:69871:3670:1> that has no stub tracks, the running track attaches to the spinner direct, has waggle though when rotating, but seems to work OK.

A TT with many entry/exit tracks would in trs22+ present problems !!!

Cheers, Ken
It appears that I'm stuck with this issue too! been bugging me for about 2 weeks now. All the turntables in UK style I have barring the AJS turntable seem to be stuck with this issue, including the Steve Flanders turntables (real shame because they became my go-to)
Is there a fix for this per-chance that doesn't involve a .im editor?

Kind Regards,