Trainz Plus Release Candidate 116069 now available


Trainz Plus - enjoy Trainz from just 20 cents a da
Trainz Plus Release Candidate 115985 to Trainz Plus Release Candidate 116069 (PC) is now available.

This update fixes a few issues noted in the previous release candidate - thanks to everyone who reported these issues as the majority of them are isolated cases affecting specific content only.

We're also continuing to test an issue with certain objects switching layers, so based upon the outcome of that fix this may or may not become the official release version.

Multiplayer-Surveyor Beta Server Test
This build has MPS support on our Beta server. This means that any work done will not make it through to the live server when the time comes to update to that server.

Meanwhile, we'd love to get as much testing of both Surveyor Classic and S20 tools in MPS over the weekend. We will co-ordinate testing through our Discord Server.

  • Fix derailment on loading certain sessions
  • Fix derailment when coupling for some steam locos
  • Fix a crash for null traincontrols
  • Fix a crash when clicking on Properties for certain vehicles (e.g. in LoBN2)
  • Fix a shutdown hang
  • Fix a crash when showing certain routes in S20 asset preview

Known Issues:
There are a number of fixes that are not included in this build as yet (most requiring additional testing).
  • Potential fix for steam physics simulation boiler units
  • Potential fix for wheels spin up to 70% faster in DCC mode (Physx)
  • Gradient control fails in Surveyor Classic after switching modules
  • Painstshed locos are white
  • Interlocking tower path displays get stuck on
  • Show Buddy List" should be toggle
  • Fix app not exiting if "Authorized DRM Resources" is the last window closed
  • Potential deadlock fix for ECML session freeze
  • DLC packs in Content Store on Steam version may not show as purchased
  • Potential fix for coupling issue in MPS
  • Problem interacting with spline when hidden layer spline nearby
Hi Tony,
This update fails after the commit to install (tried it on 2 separate install both failed).

Working here. Perhaps try rebooting your PC? Other options are that something has been modified, is open in another program etc.
Last edited:
Hi Tony
Rebooted - turned of antivirus as well, same problem after hitting install update program closes does not reopen.
Checked Task Manager - no Trainz programs or install programs open.
There has been no software changes to my computer other tha Win11 updates since my last Trainz update
Update to build 116069 went very smoothly. From start to finish, including the DBR, took less than 2 minutes.
I just updated without issues myself. The DBR is running quickly. I'll be up and running and testing soon.
Hi Tony,
All good - rebooted again and closed a few apps etc and install proceeded. Thanks for your advise mate.
I took a quick look around and did some poking. So far so good with nothing apparent on first looks. Will continue to test.
Updated very quickly, DBR was fast too.

* Fix a crash when showing certain routes in S20 asset preview

I confirm this appears to be fixed, at least for the assets I have tested so far.
I will continue to monitor and report any further issues I come across.
Keep up the good work!
Installed update without problems, I am noticing something strange. Loaded rolling stock is now displaying the amount that they are loaded in driver and it never goes away.

Simple repro steps:
Create new route.
Lay a segment of track.
Change to session layer.
Add a loadable piece of rolling stock.
Use properties to load a commodity into the car.
Surveyor displays the load level as expected.
Change to Driver.
Load level is still displayed and doesn't fade out as expected.

I'm using Surveyor Classic.

Edit: I check and same issue using Surveyor 2
Last edited:
I am not sure if you guys have this, but in surveyor 2.0 when I am moving a building and also pressing right click to move around, the building is not selected and I need to click again to drag.
Fix derailment when coupling for some steam locos:

Tested 3 simultaneosly running trains executing rounaround command in a loop for more than one hour.
No more derailing.
Much appreciated for correcting this failure.
Still has missing asset <kuid:565249:100506> by ILIOSIN to these items:

<kuid2:450495:100002:6> 01 Winter Park Express - Westbound (Morning)
<kuid2:450495:100004:6> 02 Winter Park Express - Eastbound (Evening)
<kuid2:565249:100992:1> Amtrak Superliner I Coach Baggage
<kuid2:565249:100993:1> Amtrak Superliner II Coach

Extended database didn't help any.

For some reason, my TS22 build 115985 does not show my beta streams...when I go into Trainz settings and click on the update button it tells me no updates are available. I used to be able to change to differents streams, but nothing is offered anymore. Could this be something on N3V's side?

UPDATE: Just an FYI on how I conquered this problem. In looking at the patcher file on TRS19, it appeared it was corrupted; maybe during patching to 115985. I did a clean and reinstall from build 114800 and the patcher came back to me. Updated to current build with no problems!
Last edited:
Loaded rolling stock is now displaying the amount that they are loaded in driver and it never goes away.
When in Driver > Display Menu > Commodity overlays > choose an option

moving a building and also pressing right click to move around, the building is not selected
Thanks for the report. Task raise.

my TS22 build 115985 does not show my beta streams
Do you have a current Trainz Plus or Gold membership? If you do and Trainz Plus Beta is not in your still please submit a helpdesk ticket.

Still has missing asset <kuid:565249:100506>
This will be fixed when the update is officially released. (If we fixed it now, it would break all the non-beta builds).