Track follows ground texture instead of being straight between splines.


Active member
Using Jarrah Procedural track which I have used many times. In the past, if I laid a piece of track from point A to point B, and the two points were at different heights, the track was a gradual slope from one point to the next. In fact, I have laid a BUNCH of it on the 600 baseboard layout w/o a problem until now. When I lay a piece of track now, it follows the topography: up and down over the hills and valleys instead of being a continuous slope. What in the world is going on?
I will assume that you are using S2.0.

When laying track (or any spline) check the Grade setting in the Tools Option Palette. If it is 0% or "-" then the spline will follow the existing topography otherwise it will set the spline to a fixed gradient between spline endpoints.

My guess.
Let me try to explain better: if I put a real tall hill and a deep valley on the grid......and then lay a piece of track through the valley and through the hill, previously the track would reamin level to the ground (assuming that the gradient was at 0). But now, the track runs straight down into the valley and then over top of the hill.

I know that there is track that does this, but the Jarrah track never did that.
Let me try to explain it this way: if I had 2 hills and I went to place a track from the top of one hill to the top of the other hill, that track was "hanging" in the air and then I could chose to fill the space under the track with the "Smooth Spline Height" command. That is what I want, but I can longer do that because there is nothing to fill: the track goes down the side of the hill, across the lower area, and then goes up the side of the next hill.

It is impossible to fill the space under the track because there isn't any: the track is running on the ground.
LOL mate! I get what your saying ;)

Best to use Surveyor Classic, for this trick.

After laying the track, click the 'Advanced' options arrow to open the advanced track tools
Click on that 'Hill' looking thingy! Then click on the circle that allows the splines to join, this will then level the track to the way you want it..
I still don't think that I am being understood. Up until a couple hours ago, if I laid a track form the base up to say a hill that was 40 meters high. That track stretched from the ground to the top of the hill, Then, I could fill the ground in under the track. But now, the track will run along the ground until it gets to the hill and then just run up the side of the hill. I am talking about a single piece of track: no other track joined to it: a spline at each end, but not a track attached to either spline.

Let's take another example: I put 3 hills on the base. I run a piece of track from the top of the first hill to the top of the second one. Then I join a piece of track to that and run it to the top of the third hill, I cannot fill any ground under the track because the track ran down the first hill, along the ground, up the second hill and back down the other side, along the ground and then up the side of the third hill.
A correction to my earlier post, set the grade to "-", not to 0%, to make the splines follow the terrain.

What you are describing can be achieved in S2.0, in fact it is far easier than in Surveyor Classic. In Classic you can only do it with individual segments, in S20 you can do it with multiple segments. I just tried it out using your description above.

The method is:-

  1. Lay the track - a single or multiple connected segments across the terrain
  2. Select a segment endpoint - any endpoint will do
  3. In the Tool Options Palette right click in the Height setting and select Get Height from Selection
  4. For multiple segments double left click on the segment containing that endpoint to select all the segments
  5. Click on the Context Icon for that endpoint and select Apply Height to this Spline Endpoint

All the track segments will then form a smooth curve (or straight graded line) between all the endpoints. While they are all still selected (highlighted) click on a Context Icon (any, segment or endpoint, will do) and select Smooth Ground under Selected
Last edited:
OK, I just tried it again in a new route created for the purpose of creating some screenshots and now I cannot get my method described a few posts above to work. It worked perfectly when I first tried it on an existing route.

More investigations are needed.

To post a screenshot here you will need to upload it to a hosting site - such as Postimages - then import it from there into a forum post. Avoid using the Trainz Gallery as your hosting site as it has had numerous issues these last few months.
Last edited:
I just tried what the OP is attempting with the Jarrah track and TRS22 PE SP2 crashed to the desktop. I repeated with TANE Trk Oak and it worked as expected. It is possible that the issue is with the Jarrah track.

Update: I ran an EDBR and now I can't repeat the CTD so I'm chalking that up to Trainz being Trainz.

As to the OP issue. Check your Settings > Interface Settings and make sure that "Fixed track vertex height" is checked. Unchecked it allowed me to duplicate your issue.

Here is a screenshot. Note that the spline circles so not show due to the software I use but they are white. If the setting above was checked they would be yellow.

Last edited:
Wreeder: THANK YOU! That fixed it! Now, if you could only tell me how I managed to change that in Surveyor 1 without knowing where it was located or what it was for..........

I really needed that fix right now.....sitting here at 4:30 AM because my 3 day old A/C unit quit working already.
I'm glad it was as simple as that. As far as I can tell it requires a mouse click to toggle the status of the setting. I have at times click the wrong item myself so maybe it was just an accident.

I hope you kept the receipt for the A/C unit. :)
:) AC getting prob. But, back to the Trainz thing.......I only use Surveyor 2 for ground track laying or anything else. So, there is no way that I could have accidentally clicked on what you showed in
S2 because I don't even know how to get to that screen! I managed to find it in S1, but I hadn't been on that screen for quite awhile, and all this happened yesterday: that is the weird part.

But, I do thank you for understanding what I was talking about and helping to get it fixed!