Route/Session saving - "Read only error" ! ! !


New member
:'( TRS 2006 build 3337

I'm a Newbie who started last November. I've finally managed to get 5 trains under AI (Artificial Idiots) running on my mainline for traffic without doing any strange things!!

For the last few days I've been working on Sessions for industries and had 3 sessions finished and running fine. Last night while working on the fourth session, I click SAVE and I got a message saying that "It cant overwrite a SAVE ONLY route. Try saving with a different name." !!?? I clicked the green check mark, then clicked SAVE AS . . . the dialog box came up with my route name in the default box. So I clicked on the green check mark.

Today when I started Trainz . . . . the last session is there but the other 3 has disappeared !!!!!!!! Has this happened to any of you? What causes the "READ ONLY" error? Is there a way to avoid it happening?

To avoid this in the future . . .
HOW DO I SAVE A SESSION AS A "SCENARIO" ?? Can it even be done since my route is in progress and keeps changing ?

What is the best thing to do if the "Read Only" error happens ??

Session questions :
#1. When I start a session, the driver the "camera/view" focus on is the wrong train/driver. When I open the Driver Setup in "Edit Session", the "camera/view" ALWAYS shows the train/driver on the top of the list when the session starts . . . is this correct? IS THERE A WAY TO CHANGE THE ORDER OF DRIVERS THAT SHOW UP IN "DRIVER SET UP"?? I want to put at different driver/train at the top of the list so, when the driver session is started, the camera/view is on the train of MY CHOICE.

#2. Is there a way to "copy and or save" the string of "Driver orders" that I enter for each driver in Driver Set Up ???

#3. I thought that "parameters on fixed objects" such as platforms and (concumption rate/production rate/allowed products) on Multi Industry did not change once set. But every time I open my route ONLY (without a session), these parameters are back to default. What am I doing wrong? Was I mis-informed and they all have to be re-set for each session I create?

Please . . . H E L P !!

You've changed the built-in route somehow, set a switch in a different direction, inadvertently added an asset, something, so that now the route is modified with your kuid number. Possibly if you delete assets.tdx and assets.bku then allow Trainz to rebuild the database, CMP will see both the built-in and your modified route. That's why the first 3 sessions don't show as there's no map (to CMP's knowledge).
Scenarios are script driven, you can't create them in Surveyor.
#1. Add the rule Set Camera, Set Camera Now, or Focus Camera (which I haven't tried yet) in Session Set-up to view your chosen driver. Think about it. Driver has no way of knowing which Train you want, so it uses the first in the list.
#2. Check out atilabarut's schedule commands.
#3. Your "parameters on fixed objects" are session dependent unless hardcoded in the config files.

Hello Edion2

Deleting the TDX file will not do any good. You just ran across one of 06's bugs. To fix the missing session, find the missing session in cmp, open it and find the map-kuid tag, click on the 3 ... and when the kuid browser opens type the word map into the top slot and when the maps show up select the map that the session belongs too. Do the same thing in the kuid table, save and commit, your session will be back with the map. If you had more sessions you will have to do the same with them.
A work around to prevent this from happening again is to set the route saves up to automatically save every 5 or 10 minutes and don't manually save the route, as the auto save will overwrite the route without changing the kuid number.

Ahaaaaaa ! Its a bug in 2006 . . . glad to know I'm not losing my mind. I'll set the Auto Save. I will do the "session recovery through CMP" thing. I hope I can get them back.

Thank you so much.



I'll look for the "Set Camera" rule. I guess that would be under "miscellanious" category.

About the "atilabarut's schedule commands" . . . is that a tutorial? Or some kind of rule that I can download from DLS?

As far as parameter on fixed object . . . I guess I was misinformed. I was told that parameters that I would set will remain until changed later . . . oh well.

The route that lost the sessions I created was my own route and not one that is built in. I guess its a bug that the route being worked on randomly becomes "read only".

OK . . . . its a bug BUT . . .

I've been working on my route frequently. Here is what I found out about the "Auto-Save" function. At least for my version, build 3337.

#1 Once you set the "auto-save" parameter and go into Surveyer then quit, the very next time I go into Surveyer, the AUTO-SAVE DOES NOT ACTIVATE. I have to go into "Option" EVERY TIME to re-set the "auto-save" BEFORE starting the Surveyer !!!

#2 EVEN AFTER RE-SETTING AUTO-SAVE . . . If I'm doing some lengthy work on my route . . . AUTO-SAVE DEACTIVATES WITHOUT WARNING !! Auto-Save quit on me once after 20 minutes . . . Once after two hours. It seems to average about 1-1/2 hours into Surveyer . . . IT QUITS !!!!!!

So . . . IS THERE A FIX FOR THIS BUG ?? Most people are running into this problem only occaisionally. I AM HAVING THIS PROBLEM CONTINUOUSLY !!!


Is this a hardware/software combination related problem ??

2. If you NEVER or HARDLY EVER encounter this error, WHAT IS YOUR BUILD # ? At this point I am willing to go buy a version of 2006 without this bug !!!

3. Could this possibly related to the size and complexity of the route ? My route seems to take about 3 to 4 minutes to load. This wasn't a problem when my route was still small and in its infant stages.

Someone . . . Anyone (AURAN) . . . Please help !!!

I've been running build 3092 since SP1 first came out and never had this problem. Didn't even know there was a "bug". I've installed SP1 on three different laptops during that time, each with better specs than the one before, but the same patch file. Makes me wonder if there was some later 'improvement' in the code.

You are so lucky !!

My 2006 came in the US version packaged with Trainz Classic. Can you describe what your box looked like . . . or better yet, is your particular box still available from Amazon or any other online stores ??

I have a computer with Intel core2 duo 1.8 Ghz, 3 meg RAM, running XP home. I would assume your computer is similar?

If your version is still available, I'll get it !

Mine was the limited edition DVD with the metal box when it first came out, when was that, 2005? But as I said, I upgraded to SP1 the second week that was available, downloaded from Auran. That's why I wonder about all these people having problems with CMP and '06. Yours has already been upgraded to SP1 status.
Looks like plain '06 DVD is still here:, but you would need to install SP1. There are threads about where to get SP1 and about installing it.
Yes, my laptop has the same processor, but I still only have 2 megs of RAM, nVidia 8600M GS, Trainz and gmax are installed on the second 120gb hard drive and I'm running Vista Home. But I don't think the computer is the issue. I originally had Trainz and SP1 on a Dell laptop, single processor, then an HP dual core AMD. All with no problem. No one has hit upon why '06 works for some and not others. I still wonder about the patch.
Look on the bright side, supposedly TC3 will be out in another month or so, and we'll see if it's any better.
Sorry I can't be of more help, as you seem determined to get '06 to run.
I think your version is still available at Amazon. I think I'll get it after I get some feedback on moving up to Trains Classic . . . thats if I get too many negative comments about TC.

Good luck. I haven't paid any attention to the TC part of the forum. You'll want to search on how to move the .ja files to TC so '06 built-in content will be available.
OK folks, its been a few weeks. I've been expanding my route.

I think I have reached some kind of a threshold.


I am almost certainly sure that this bug in the TRS2006 it TRIGGERED BY THE SIZE OF YOUR ROUTE. And the "size" is probably the actual file size of the route.

No matter what I do in the "Options" before I start working, I have not seen the AUTO SAVE work in the last dozen times I worked on my route.

I can only save the route using the "SAVE AS" command.

So every time I want to run a session, I have to re-attach it to my route in CMP before going into the Driver mode.

What a F$%^ing hassel.