Red Bug JR Multi Industry in Cold Creek Logistics

Receiving the following error when loading the JR Cold Creek module. I have tried searching for similar issues, and tried the missing/fault commodity fix. No joy. Nothing showing faulty/missing and still have the bug. Any assistance in getting this fixed is greatly appreciated!

Thread Exception: ER_Exception, line 1210, file

Stack dump:


function $void@BaseIndustry::SetQueueInitialCount(ProductQueue,Asset,int), line -1
function $void@IndustryProductInfoQueues::ResetAssetToInitialAmount(), line 139
function $void@IndustryProductInfoQueues::SetInitialAmount(int), line 119
function $void@IndustryProductInfoCollection::SetProperties(Soup,BaseIndustry), line 717
function $void@BaseIndustry::SetProperties(Soup), line 1733
function $void@MultipleIndustryNew::SetProperties(Soup), line 34
Last edited:
Have you checked the industry itself for missing dependencies?


Yes, if you mean did I check the JR multi industry asset for missing dependencies. Even though I am showing no missing dependencies in ALL installed assets, do I need to go to each individual industry in the module and run a check? Appreciate the assist!!
You may need to, as it sounds like a missing commodity to me. You may also want to reinstall the offending industry.

You may need to, as it sounds like a missing commodity to me. You may also want to reinstall the offending industry.


Tried all your suggestions! Reinstalled the entire route and dependencies. CM still showing no missing or faulty dependencies. Found your problem commodity thread. Checked all against what I have installed and no issues there either. Red bug error is still as shown above. Running out of options and patience. If I delete JR multi industry, what functionality do I lose (about to that point)?
Thinking on this some more after reading some of your previous postings on jr multi industry errors. Not ready to give up, so I thought about focusing on the faulty/missing commodities aspect again. I seem to remember some discussions about faulty/missing assets not being reported properly in CM. I am going to search around again for that conversation, but if you happen to recall that topic, maybe you could point me to it? My guess is that I actually DO have issues with my commodities, but am challenged to know which to fix(as a reminder, CM is telling me I have NO faulty/missing dependencies). Maybe use Asset X, or some other tool? At this point, I will take most any suggestion because I pre-ordered the Intermodal module and I am thinking it will need multi industry functionality to work properly. Just a guess. Standing by for any, and all!
Last edited:

I have this module and have successfully run the included sessions with no script errors showing up. The easiest way to test the commodity problem is to create a trivial route with just a couple of pieces of track attached to the JR multi industry asset. When you try to set up the queues, there won't be a list of commodities popping up to choose from (this can take quite a while the first time).

I've had this problem as well in the past and after checking Shanes site for commodity problems and not finding any, I just got frustrated and did a database repair. Worked for me, but who knows?

Appreciate all your assistance and suggestions. I have tried it all and still no luck. I have narrowed it down, I believe, to something on the Cold Creek module because I have no errors with MWG 3.0 where multi industry is installed as well. I have decided to delete the multi industry asset and remove it from the route dependencies. I use CMTM for freight car forwarding, so it was not going to be used anyway. Hopefully it will not be required for the animated cranes and such in the upcoming Intermodal Module!! :)

Thanks again, guys!!