Multiplayer Tips, Tricks, Fixes and Other Things

yea I see your point but that would mean alot of extra work and not only that I also have my main route DPV4.0 PH3 wich much be top of the list. The MP map of DP ( Dragons Pass ) is a lesser map wich rebuilting it over its just to much work to do them both. olny orther thing would be to delete almost everything but the track and main assts "imported stuff" and go 85% built in. That its self would be a big undertakeing alown. + my main map on top. and The Rolling stock will have to all be cloned and uploaded just for that one map or looked at and all non bult in assts replaced. I just don't have the time for a huge over hull like that. and fact I work days form 7 am to 4pm I'm exosted by the weekends. every thing is on DLS inless its one of the rolling stock thats screwing it all up wich woud mean a session fix thats not so bad really.
We can guss as to what it is and stell come up with nothing but I think we'er going have to gut this fish. I'm installing it over olny the route and assts off DLS ans see if anything comes up. The anser lays somewere in the map its self. you wach it being one stuped assat being failty or has a bug thats screwing the hole thing up. can you see if these are any warrnings in the assts. that may be why.

If there was a pice of rolling stock not on DLS it would show as missing or Unknown and I deleted all unknown assts out on the last update. That leaves olny the assts on DLS and its all there CP downloaded averything nothing missing or unknown I tryed it 5 times.
Last edited:
Ok, here's my findings:

The latest version of the session does not use the latest version of the route. To fix this I have downloaded the correct route via FTP link, and imported that, as downloading it in CM only gets the latest version (v6) which the session does not run on.

Now to download the dependencies and see if it will run.

EDIT: I think I've found the problem! There are trains in the Route layer that should be in the session layer. The session uses an outdated route too, so if this is fixed in the latest version of the route, then you need to make sure the next session uses the latest route version too.

So, to sum it up, here's what needs to be fixed.

1. Move all trains to the Session layer.
2. Make sure the session uses the latest version of the route.

Last edited:
Well now it wonts to work all of a sudden I'm running it now Dragons Pass V6.0 MP with the V5.5 session & the MP Beta session also works. I swore it has a mind of its own. Its now working so you can drive it. I don't know I'm just going to leave it No more MP maps for me.
Ok, I'll use it sometime over the weekend. I'm glad to see it working, I like your custom reskins and your steam loco.
I made aew of the models and hert skined some as well He has added his toch to the DP route.

Well now that its works avery one There will Be No more Updates fot DPV6.0 MP I'm done with this BS it works and thats how its going to say. Feel Free To make your own sessions for it and upload them to DLS.
Update for the Steam users related to multiplayer:
Trainz newsletter of September 15th said:
STEAM Gets an Update!

For all of our Trainz fans who use Steam, you'll be happy to know that Trainz Simulator 12 has now been updated. You'll be able to use the latest DLC packs made available through Steam, and also join multiplayer sessions with people who have purchased Trainz 12 outside of Steam.
After a long break, I have made a slight up date to the original post. I also would put this out there for the mod's, could we possibly have this stickied? And maybe some of the off topic stuff removed?
hey guys my name is MATRIX i have just bought this game from the steam store and have noticed everyone running the 49922 build. after installing and speaking with guys in the TRAINZ chat lobby in the game they have told me about the build matching for multiplayer. now i am running up to date according to steam (build 53389) but i am having problems trying to figure out how to get into a multiplayer session.

any help would be appreciated

Hi Matrix,
the problem is:
Only people with the same bulid-number can play together.
When you have bulid 53389 you can only play with people who haves that bulid too.
The german Version haves bulid 50027 and so we can't play with the people together, who haves the international Version with build 49922 and so we can't play together with peoples who have the Steam-version with build 53389.

Can I clear something up here...

For multiplayer purposes, the important part is not the 5-digit build number, but rather the trainz-build number (usually in the form of x.x). For TS12, it's build 3.5 or 3.6 - multiplayer requires the higher of the two. The number in question can be found just above the 5-digit build number on the Launcher.

thanks guys and i know about the build problems for multiplayer i will check the version number and report back here in a few hoours
For TS12, it's build 3.5 or 3.6 - multiplayer requires the higher of the two. The number in question can be found just above the 5-digit build number on the Launcher.Shane
Hello Shane,
you say that the number in format x.y can be found in the Launcher above the 5-digit bulid number.
I can see there only the bulid number but I don't see the other number.

When I look in Explorer with right mouse click at the Trainz.exe, I see for bulid 49992 that the version is 3.6f. Also for Trainz with build 50027 the version is too 3.6f.
But I can not play with the Trainz with build 49992 together with the people who haves build 50027.

Perhaps I don't understand what you mean.

Some useful information to bump this topic

Trainz12 compatible builds (source):

  • 47059 & 47103
  • 47452 & 47772
  • 48249 & 49922
  • 57720, 57825, 57898 & 58414
Any builds not listed above are only compatible with installations that share the same build number.

To find out which build of TS12 you have open the Trainz Launcher and observe the build number in the bottom right corner.
Update for the OP:

When you get the error depicted in the image, try doing the following:
1) Go to Content Manager and locate the offending session.
2) List the dependencies in the main list.
3) Now add the filter "Locally Modified: True".
4) Apply the filter and delete any assets that remain in the list.
5) Now change the "Locally Modified" filter to "Location: Download Station". (In SP1, the filter is "Installed: False".)
6) Download everything there.
7) Remove the "Location" filter. (In SP1, it's the "Installed" filter.)
8) Select everything and return to step 2.
Continue until there are no more assets left to download, or until the list becomes repetitive.
Now, double-check that everything has its dependencies intact, and that nothing is faulty. If you are missing dependencies (unknown location), it could be that the asset version referenced in the config is not on the DLS, but a newer version does exist. In that case, look up the author ID (e.g., if the KUID you need is <kuid:612368:100021>, look up "Author: #612368") and sort by Asset KUID, ascending. Scroll down until you find the KUID you need. Then download the most recent version of that asset from the DLS
If any dependency comes faulty from the DLS, you cannot play the session in multiplayer until the asset is fixed by the DLS cleanup and a working update is released.
Last edited:
Bump. And once again, can this please be stickied? I think it would help a lot of the people who ask about MP.
Trying to start a multiplayer session but users on the other end cannot see the session. Multiple users have tried to start the session but no one else can see it no matter who starts it. Has anyone else experienced this issue before and if so how was it solved?