Loading and unloading products


New member
I'm starting with products loading and unloading process

My first attempt has been with a coal loader and unloader, i worked perfectly .

My second one has been with "Container station. My consist were composed with several container transporters that I have uloaded. Then in Drivers mode with Ai I include following commands:
- Drive to "Cotainer Station" 40 ft Container
the consist went to Container station, stop in every container transporter but the container is not moved to the consist. Why?

Later I tried w"ith Multiple Industry New" then I selecting "?" I clicked in the Multiple indusry new track and then in Queues and then in "+" its opens the product windows but it is blank, without any product Do I need to perform other ditional steps? Which ones?
The container station only loads the Auran (blue) 20 ft and 40ft containers. you just need to make sure you have transporters that have these in their queue, or add them in yourself.

The cars I use are: BR Blue FGA Container flat which can load 20ft Auran Container,

I Command consist to "Dive to" "Container Station" "20fh Cotainer Pickup" followed by "Load" command, but the cars do not load the containers.

Where are the products installed? Do I need to include in Trainz, Where? How?
Firstly has the container station got any containers to load? Check the station properties.
Products can be found by open CMP select installed. Click the + button and then select category and commodity, you should have a list of all products. Rusty rebar is one that will cause problems so get rid if you have it.
Hi Angelsd,
I dont normally use BR rollingstock but I enabled the container flat and ran some tests using a Container Station.
The auran 40 ft containers are not in the queue, but they loaded okay when I added them.
The auran 20ft containers were in the queue and did not load.
I then removed them from the queue and added them again and they loaded ok.
There is a long delay before and after the loading of both types of containers but they load ok.
I used the multiple load icon in the queue window to make all wagons have the same load.
I have no idea why the original loads did not work.
I was able to load them manually ok.
I used the first 20ft Container in the list ( there are 2 listed when I add to queues).
Please note this was in TS2010.
Cranked up TS2012 that I hardly use these days and the same process worked there (doesnt matter which 20ft Container I chose).
Hope this helps,
Last edited:

Thank you for your cooperation but the Container Station, atleast in the trainz 12 or we are talking about different Stations, has it ownproperty windows with the containers and has not the possibility to removecontainers from the queue and not the possibility to include new ones.

Any how thank yyou again
hi angelsd,
You need to change the containers listed in the container wagon by using the ? in the rolingstock section of Surveyor.
Hi Angelsd also.
Click on the wagon if you don't see the container that the IND load then click on the + a list of commodity will show up choose the one you want,
but beside how many and if you want 2 of the same containers or 2 difference ones.
For 2 of the same kind click the load with 2.
for difference kind click the + that load one add your container then click another load that loads one and add a difference container.
Here you will have two difference containers stacked on top of each other.
Thank you all.
With other container wagons such RZD Platform 01, SAR FBX Flatcar or 60ft Flatcar the Container Station works I don't know way not with BR Blue FGA Containerbecause this one allows work with Auran Containers
As I mentioned in one of the my first posts I have a problem with Product Window: when I click on "+" sign in theProperty the Product window opens in black (blue but without product list) a little red buggy appear in the right down corner, if I click on it a widow opens with following information
Vehicle : Thread Exception: ER_Exception, line 2305, file vehicle.gs (1)
Vehicle : ProductFilter.DoesAcceptProduct> null product (file productfilter.gs) (1)

I have notified that if I click over other vehicles the name "Vehicle" change by a name related with the type of element.

Could you give me some idea abut how solve it?

I'm thinking to remove trainz and re-install again, of course copying UserData folder first. Thank you one more time
You have a faulty product like rusty rebar installed. Faulty products will give you a blank window and wagons also cant find the products.