Legacy of The BN Session Issues

Anyone been having issues when playing any of the Legacy of The BN sessions in TRS19 and TRS22? An example is the West Clyde Sawmill session (Images shown below); I completed the other session's objectives as normal (switching the bulkhead flatcars and loading them up), and then I get to the part where I have to couple up the UP GP9s to the consist. Problem is that the driver is not automatically assigned to the GP9s; meaning that I have to manually assign the driver to the GP9s. And now this leads to another issue. After assigning the driver to the GP9s, I can't proceed to couple to the consist without this red signal AND a junction that I can't change manually in the way. Any ideas of how these can be fixed?


I don't believe you couple the GP9's to your consist... you couple your consist to the GP9's. But it's been a LONG time since I ran this session and I could be wrong. And I believe there is a signal or switch issue also. First thing I do with a Tane session in '19 or '22 is delete the session rule that kills the session when running absolute Stops. I can then run red lights as needed. Tane sessions break so often in '19 and' 22 I gave up on them long long ago and frankly, N3V's lack of concern to update what they sell as "compatible" with '19 and '22 is troubling. If you purchase something it should work. But it's been years......
Last edited:
I know this is kind of an old thread, but wanted to chime in and say that I ran into the same sort of issues on the Coal Delivery session. When I looked at the session, I found that there is at least one trigger check for a trigger that doesn't exist, and most (perhaps all) of the trigger checks had the wrong driver. After I fixed those items, at least the popups beyond the session start were appearing.
I had this same issue; I solved it by simply switching to surveyor and coupling the locomotives with the "move train" tool, and then switching back to driver. Session seemed to work fine after that