Help on Layouts please


New member
I have downloaded two layouts by user name misterchugg on Gladstone to Rocky and to Rosedale. Both appeared to download ok and appear in the Surveyor menu but when I click on either of them to load I get an ERROR message saying
NO MAP SELECTED - you attempted to start surveyor without having a map selected. Return and selected a map
Can anyone help me please to fix this error. While I am here also I have downloaded several QR level crossings The booms stay down until a train comes then they go up.
Does anyone know how to fix this problem as well please.
Thanks in advance.
Hi, the error you are getting is very common.

The routes you have downloaded are TRS2006 SP1 routes. (SP1= Service Pack 1) The routes will not run on your version of Trainz.

You will have to download SP1 from the TRS website.
For the boom problem I have no idea.

Happy Holidays!!
I downloaded a tram layout from the download station for trainz 2006, and it wont appear in the game,:( can some body help!

sounds like the route you downloaded requires a service pack to make it work. what version of Trainz are you running ?


I think you will find Ron's layouts (Mrchugg) are for TRAINZ CLASSICS
as for the Boom Gates by Stryker were for 04 and the scripting went wrong in 06 There is a fix though ;)
I have trainz 2006, the layout was from member "rodin hoods" and it had 4 trams, 2 buses, and 1 train, if that helps.
Last edited:

sound like the route could be 2006 sp1. its a shame that not all routes are labelled if they need the service packs or not. to run the route right you may need to upgrade to 2006 sp1. the sp1 patch can be found through the Auran site. i think through Downloads.


hi mate

i only have TC
but i have been told that if you go into my route config file and change it to trainzbuild 2.5 or 2.6 it will work in 2006

cheers and a merry christmas
Hey all!

Hope everyone had a great Christmas!

I have tried to download Gladstone to Rockhampton and the Rosedale layout but in CMP it just goes red in the download box. I have TC and T2006 with service pack. Does not work in either by trying to download through CMP.

Any Ideas?


apparently it helps to REGISTER TC with Auran (which I already thought I had!). Appears problem solved! Its downloading fine now. Would be nice to TCM to make you aware of not being registered.