Glitchy TS12

Hello, all. Chris here.

I was just playing TS12 a minute ago when, after clicking the asset display area when my mouse disappeared. Now whenever i put my cursor over TS12 (it's in windowed mode) my cursor disappears and i must go into Task Manager to see it again, but then it keeps happening and i cannot fix it. Any ideas on how to fix this are greatly appreciated. I really don't want to sit through a DB Repair OR lose all my route work now (someone disabled autosave when i wasn't looking).

Aaaaand, now i feel stupid. Just clicking everywhere fixed it. :confused:

Mods, can we dispose of this thread as it's completely useless now?

Best Regards,
Last edited:
I disagree. It isn't useless if you discovered something.

My mouse has done that a couple of times over the last year or so. I was in Surveyor both times, and it happened right after I clicked and dragged a spline across the screen. Letting go of the mouse button, the cursor disappeared. Since I run full-screen, I just hit the Windows key to move Trainz to the background. The cursor appeared. Then I clicked on the Trainz on the taskbar and re-entered Surveyor. The cursor was back.

So Do you remember just WHERE you clicked and made it re-appear?