custom content not installed


As I am fairly new to trainz please excuse my sometimes irrational behaviour...I know this problem has been aired before and I have just spent ages looking through past threads for a solution to my particular problem....There seems to be numerous varieties of it so here is mine... When I go into surveyor and choose one of my own sessions to play with I get the familiar black screen telling me I have some custom content not installed etc etc...I've tried using a session that does not get this problem and simply changing its name using "create new session only".When I try to use it I get the same old black screen even though the only thing I have changed is the session name...So does surveyor dislike certain names or what..I have tried numerous new session names including some obcene ones and some times it worked and others not (it didn't like the obcene ones by the way)Did I spell obcene right?....
I know that all I have to do is ignore the screen and it will go away and things work ok anyway but it still gives me the screaming wombats when it happens.....I am using trs 2004 by the way..I have several sessions that have never had this problem so I went into them , put in something that was already there and saved it with a new name only to get the missing assets message when I tried to use it...

Hope you can shed light on this and help a silly old fossil out...:sleep:

thanks to all..
I'm a reformed 2004 user - now use 2006, so I'm more than a bit rusty.

Have you used TrainzObjectz to try to pinpoint the asset that TRS thinks is faulty or is missing? That might be the place to start.


PS - irrational behaviour?? Not a bit of it. That's what this forum is all about - especially after you have made an honest search of what is already in it. The subheading under my name says Trainz Veteran - not at all. I'm in this forum a lot looking for the answers to problems that I encounter -- in fact, this has been a real learning week for me. And I'll bet a few others could say the same. Don't be embarassed about asking questions.
Last edited:
Dont take a lot of notice of this screen as in most cases you will never find the problem. If you ever went into 2006 you could find a lot of errors to assets which wont stop it from working. In 06 the image size might be wrong or an incorrect config file but the asset still works, thats why auran have allowed 06 users to be able to switch off this message. We of the 04 following just have to load anyway.
Other creators maps and sessions are in the dispatcher folder. As soon as you alter the map or create a session it becomes your content and found in the custom folder. It was once voiced that trainz did not see everything in the custom folder so classed maps and sessions as missing.
Last edited:

The black screen is singularly unhelpful isn't it? Highly recommend you get Trainzobjectz, load it, then get it to scan your map and see what items it says are missing. It's what we all do.

If the missing ones are not on the DLS, it indicates they are probably from some 3rd-party web site. Post what kuids they are on the forum and with some luck, somebody will recognise them and tell you where to look.

Don't let the screaming wombats get you quite yet.