Accurate track measurement


Content appreciator
I’m trying to build an accurate “one mile train” to use as a measuring tool to place gradients from an old BR gradient profile, but am finding errors with the ruler in Trainz tools.

I had the ruler set to metric and measured 1609.3 metres; a few centimetre short of a mile, but near enough given that the ruler on my version only measures to one decimal place. The ruler arrow points are blurry anyway, so I wasn’t expecting micrometer accuracy.

I went into Surveyor>Edit Route>Working units and change from Metric to Imperial and found that the ruler length now measures 5364.2 feet, when I was expecting something closer to the correct measure of 5280 feet.

Trying it out in reverse, 5280 feet confirms the inaccuracy at 1583.5 metres!

I’ve cross checked the width of a single baseboard. I measured from directly overhead using the compass to ensure correct alignment at a grid square intersection. The ruler was placed exactly along a single grid line, the board was totally flat and the measurements taken using the more accurate mouse arrow pointer with its sharper end touching the centre of the yellow 10m gridline. A perfect 720 meters. So metric looks OK.

However, when the working units are changed, the 720 metres becomes a totally inaccurate 2400.1 feet (which equates to 731.52 metres).

It appears that the factor used to convert to feet is 3.2 x m, when it should be 3.28083990 (3.281 would do).

The lesson seem to be, “Always work in metric”, unless I’m doing something completely wrong (not impossible!)

It is a pain given that my current project is based on historical Imperial scale maps, and I’m keen to correctly apply gradient profiles at the correct track positions from old plans that I have acquired. It appears that I will have to convert all of the mileages into metric, unless I missing something.

Am I right in thinking that the Imperial ruler measurements are inaccurate in Trainz ?

If so, it also calls into question as to whether the odometer option in Edit Session>Display Custom HUD is accurate when Imperial working units are set. I’ve tried moving a loco exactly one mile ahead using this feature, but get very mixed results. Maybe it’s to do with inconsistent speeds or wheelslip, but the results are different each time. However, on a positive note, there appears to be a much smaller margin of error between metric and imperial when using this feature. Maybe the conversion factors are more accurate in this part of the program.

I’m really keen to get my gradient changes set at the correct prototypical distances. Does anyone have any ideas or tips on how to get an accurate measurement?
On the DLS for Trainz 2.1 there are several 1mile, .5mile & .25mile measure sticks, the 1 mile is <kuid:68236:102>.

Thanks John.

I’ve got magandy’s measuring sticks but they give a straight line only.

Interestingly the 1 mile stick comes out at 1609.3 metres when using the Trainz Tool ruler, which seems to confirm the reliability of the metric measurement. Conversion to feet in game still measures an inaccurate 5364.3 though.

Thank you for reminding me about these sticks. They have been useful for checking my “mile long train” length.

I need something which can be placed on the track to accurately measure the distances, most of which aren’t in straight lines. I think I'll build a train with marked vivid coloured rolling stock at eighth of a mile intervals. Magandy's sticks will be useful for setting this up.

Thanks for confirming my observations BD1. I'm not going mad after all!

I'm surprised this hasn't come up before, but I've not seen anything that I can recall in four years, or in the Forum/Google searches I've been doing today.

I'm glad I noticed it before laying down and profiling too much track.

Thanks for the conversion details Peter. I missed your post (I wasn't ignoring it!:D)

Known issue lads! The Imperial/metric conversion in Trainz has always been wrong, its rounded off to an extent that makes conversion not only inaccurate but very nearly sloppy! The only way to get a dead-set 'mile' is create the train using Metrics in Trainz and a calculator to work out however many meters point something it should be. Every mile post I have ever put in on my routes is wrong becuase I created a 5,280' train way back when. I've carted that consist through every Trainz version I've had and I still use it even though I know it's wrong. Sentimental old fool.....

Last edited:
Thanks for the details Andy.

Does anyone have any observations, or answers, regarding the accuracy of the odometer (see penultimate paragraph in my OP)?

Actually it works out well. You mentioned 8ths of a mile which works out nicely at 200 metres or two grid squares Perfect for setting up your measuring train.

I just checked the metric conversion in TS10 and get very very nearly exact conversion over a 720m board (2361.5 feet). I stand by my statement that it has traditionally been wrong, certainly it was wrong in TRS04 where they roughed it out to 40" to a metre instead of the correct 39 and a bit.

In TRS04 a board is about 2403' across (40" = 1 metre), in TS10 it is about 2361.5 which is near enough 39.37" = 1 metre. The difference doesn't look like much till you are putting mile posts on a 200 mile route, but then TRS04 was still more or less seen as a 'Model' Railway Simulator and folks were just starting to realise what was possible.....

Apologies to whoever fixed it whenever it was fixed - I hadn't realised!
It is a great utility, but it has some limitations. For example it won't read past mocrossing objects....
... 8ths of a mile which works out nicely at 200 metres or two grid squares ...

I think it’s a bit more than that Peter.

1/8[SUP]th[/SUP] of a mile = 220 yards = 201.168m

So that would be 20 x 10m grid squares (plus a tiny bit!). Pretty close, and a good cross check.

Thanks for the tip.

There is a Track Scanner object on the DLS here. Is this any use?

Thanks David.

I have the Track Scanner and the Scan Track asset which allows analysis , but haven’t yet explored its full value. I might be wrong, but from what I've managed to explore so far, believe it’s more about analysing what has already been laid rather than helping to prototypically place tracks and gradients in the first place.

I’d be happy to be proved wrong though, if anyone could please advise.
I have the Track Scanner and the Scan Track asset which allows analysis , but haven’t yet explored its full value. I might be wrong, but from what I've managed to explore so far, believe it’s more about analysing what has already been laid rather than helping to prototypically place tracks and gradients in the first place.

I’d be happy to be proved wrong though, if anyone could please advise.
I've just started using it to accurately measure the distance to the next track scanner object (placed at a spline point), and then adjusting the height of each spline point to get a constant, even gradient, knowing what height I want at the start and end of the gradient.

Incidentally, anybody know where I can get gradient profiles of the Midland Rly lines around Nottingham?
Hi all, I've downloaded the track scanner as recommended by Davebird ( thanks Dave). What is it? A spline object, a scenery object. It's on my hard drive, but I can't find it anywhere on my PC. Hope someone can help.

Last edited:
Look under the Track tab, then Trackmark button. You place two special trackmarks and it calculates the distance between provided there are no track-attached scenery objects (mocrossings, industries, etc) in its line of sight....

On my version Track scanner <kuid2:117746:23230:1> is found as a Track Object (not Trackmark).

I understand that you add two to your track at the distance requiring to be measured. When you’ve done that, click the question mark button on the track flyout and click on one of the yellow cone shaped track objects. It then supposed to measure the distance between the two and give you the result after you have pressed the Scan button in the dialogue box.

I’m getting very mixed results (and frustrated!) because it seems to measure beyond the second track scanner as far as the track end. I’m getting reports of several kilometres when the two scanners are only around 100m apart on clear track. In fact I even set up a brand new Route to test it, to be absolutely sure.

What makes it more difficult to understand is that there are no substantial instructions on how to deploy this asset, either in the in-game dialogue box or in the config.txt details.

There is also ScanTrack <kuid2:117746:6:1> which might be related, although I can’t see in either config that one is dependent upon the other.

I’ve tried various combinations of switching the direction of the pointed yellow cone shaped scanners and trying other track markers with just one of the assets. I've also tried different types of track. Nothing has yet produced anything like an accurate result!

I must be missing something somewhere along the line.:confused:
I used to use Trainzmap to do the measuring. By turning on the Fixed Track tool, it made every spline point visible. Place the anchor at one end of the grade and hover the pointer over each point in turn, the distance was shown at the bottom. Using a simple bit of maths the required height of every point was easy to work out, to give a nice smooth grade.

Unfortunately Trainzmap isn't compatable with TS10, can you import your route back into TRS06 and use this?