AAARGH stupid editor


New member
Someone kindly (no, really) pointed out a couple of errors in a session I put on the DLS. So, I thought I have a few minutes, I'll just check them in the editor...

It said I couldn't edit the route as it was on the download station, did I want a clone? Cloning it gave it a different KUID. So then I deleted what I thought was the clone, but since the editor doesn't show KUIDs, it deleted the wrong one, naturally. So I closed the game and went to content editor, downloaded my original from the DLS, and deleted the clone with the wrong KUID, then I did "create a new version" in content editor (giving me the :1 at the end of the original KUID, and to avoid confusion, I changed that to be called "Super Chief special 1.1". Now, I should be able to edit the session, and then upload the new 1.1 once it's done... or so I thought. Opened up the renamed route in editor, all fine. Checked some things and then I wanted to test that one sequence. So, I rename the "proper" Super Chief (the primary player train) loco temporarily, and create a new Super Chief part way along the route, so as to test it. This is exactly what I did in the original testing (it saves spending half an hour plus driving to the relevant point each time). Previously this worked fine. Now, instead of working fine, it's deleting half the AI trains for no obvious reason, then when I exit driver back to the editor to see what's going on, those consists have vanished from the session. :confused: AND why's there no "angry" smiley?

WTF is going on here? All I want to do is tweak a few details about how the AI trains run... :(
Hi Lew - Sifting through what you say in your post I think I understand that you finally made a new version of your Super Chief session, after starting on the wrong foot.

When starting to work on the new session version, do not open the route for editing. Select the route with a single click, and then click the double arrows at the right-hand end of the line where your route is. This will display the sessions attached to the route. There should be two, the original and your new version.

With the new session highlighted, click on Edit Session button on the left of the screen. Your AI trains should all be there. Make any changes necessary to the session and save it.

Cheers - Trevor
He LLewellen,

I posted this message on your other thread, but I'll repeat it here.
[FONT=Helvetica, Arial, sans-serif]Hi LLewellen,

First thing is to try to recover your original Super Chief session.
[FONT=Helvetica, Arial, sans-serif][FONT=Helvetica, Arial, sans-serif]In Content manager, delete the download and the clone.

[/FONT]On your computer, navigate to your TS12 folder TS12/UserData/backups. (Or wherever you put it).

Look in the backup date folder that corresponds to the date that you deleted the Super Chief session. You should see a copy of your session there.

Now, go into Content Manger and from the dropdown File menu, select 'Import Content.'

Navigate to the 'backups' folder and click on the Super Chief folder. This will load it into Content Manager.

You can then raise the revision and edit the session.

The 'heavy' train needs a 'Navigate via Mojave West' command after the trigger command.

The two rescue locos should work as they. They should reverse onto the stalled train, but they didn't do that for me. They just sat there with the message - no path to selected destination.

I flipped them so that the lead loco was facing the stalled train and they happily went to the train and coupled up.

yes I figured the heavy train was going to the wrong trackmark. However I got into hassle trying to edit the thing. I'll give it another go now, got more time.
OK. I deleted everything and got back to the original Super chief session, which, if I try to edit it, says "you can't edit this because it's on the download station". Fair enough. I don't want to clone it, since then it won't list as an update, as I want it to.

If I click "create new version" in content manager, it duly creates KUID ...:100038:1 which should be the update, and marks 100038 as obsolete, as I would expect. I would like to change the name to add 1.1 to the end, which on the face of it I can easily do by editing the config file, then committing the change.

Then I go into the game and select the route, then the sessions, select "super chief special 1.1" which shows up in the list (the original is not visible, since it's obsolete) and click edit route. It opens up fine, with all the trains where they should be etc.

So I made the couple of changes which need making, then saved the route and exit surveyor. Then I try to drive the route and immediately, half the consists disappear. The drivers are still in the list, they still have their expected commands showing (like wait for trigger, say) but they have no train attached to their names because the damned train has evaporated.

Then, if I close driver without saving, and go back to surveyor, the consists are still missing.

Is it changing the name that is messing it up? Something sure as heck is.
I give up. There seems no way to fix this.

I tried it again: make new version of the session in content manager, commit, close CM. This time I left the name alone, I didn't touch the config file or anything.

Open the game, routes > sessions > edit session. All the consists are sitting nicely where they should be. Make 2 changes, save route and return to session menu. re-open route in surveyor: half the trains are gone.

Unless I'm doing something incredibly stupid (always possible) then I have no idea what the <multiple-expletive> thing is playing at. There are no error messages or warnings.
Hi llewellyn,
Since starting to use the latest hot fix I have found the Ai drivers to be very pigheaded about changing direction when what they want is behind them.
What I have been doing is to take over control and reverse the loco in the right direction , then while it is moving, click on continue schedule and most times they happily do the right thing.
Maybe best to leave the problem alone.
Sorry I am no help with your actual problem though.
I give up. There seems no way to fix this.

Hi Llewellen,

Don't give up yet. Try this.

Navigate to your Trainz folder, right click on the blank part of the page and select new/folder. Name the folder Mods (or something else if you prefer)

Now go into Content Manager and open the original session for edit.
Go back to the Trainz folder and navigate to UserData/editing. Open the editing folder and highlight the title of the Super Chief session. Press Control/C, navigate to your new Mods folder open it and click on the page. Press Control/V.

You now have a copy of your session. Open the Config file and change the kuid number to Kuid2:xxxx:xxxxx:1. Save the config. Back out of the folder.

Now go to the Content Manager and import the Mods copy using the import content command.

Hopefully this will give you a perfect copy of your original. Go into Surveyor and make your changes. It should work fine.

I'll give that a go sometime. Thing is, this is one of those frustrating things where the software messes something up without it being obvious why. It should work, as far as I can tell: the create new version makes a superseded KUID and it should be possible to edit that and job done, but the editor is playing stupid tricks.

I'm also working on a fictitious route of my own, which you no doubt appreciate is very time-intensive. This session was supposed to be nice and simple and a way to get familiar with editing again (I did some before, with TS2010EE).

If I edit the KUID, will it louse up and not commit cos the KUID is wrong? Or is that a feature that works with KUID2?

I bet what would also work is delete the damn' thing of the DLS, fix it and re-upload it :)
If I edit the KUID, will it louse up and not commit cos the KUID is wrong? Or is that a feature that works with KUID2?

I bet what would also work is delete the damn' thing of the DLS, fix it and re-upload it :)

If you try to edit the kuid in Content Manager the asset will not commit. But, if you take the asset out of content manager and the editor, change the kuid and re-import, then all will be well.