TRS2019 SP5 Merging


Active member
Hi All

I think there is a bug with merging any routes in 2019 SP5. I have merge big routes together from TS10, 12 & TANE. it worked fine in SP4. No matter which routes I tried to merge, it is stuck on the loading screen. Left it for 12 hours, where it usually take 2 to 5 minutes on big routes, or am I doing something wrong.

I also tried to merge the same routes that I have merge successfully before. No luck
I just did a test merge in build 117095 of two large(ish) routes. One of 150MB and the other of 50MB and it worked fine with less than a minute delay - but that largely depends on your system specs.

The merging occurs in the available system RAM and, failing that, the system virtual RAM is then used which slows down the process significantly. Try increasing the size of your virtual (disk) RAM space and try again. There are many web guides available on how to increase your system virtual RAM.

If it continues to fail then submit a bug report at Trainz Bug Report including details of the two routes and your system specifications.
I had this happen to me the other day and, after some puzzling, I realised I hadn't put the route-layer at the top of the layer hierarchy. Once I did this, the merge went ahead fine.

I noticed build 117095 from pware, mine is 117009, how do I get up to 117095

My system specs:
Build: 117009
i7-9700 @ 3.00GHz
32.0 GB RAM
SAMSUNG 860 EVO M.2 1TB for operating system
SAMSUNG 870 QVO 4TB SSD, where all my trainz versions is installed.
GTX 1060 3GB

I have read a few articles on virtual ram, I increased to 1.5 times. (or what should be enough)

I am trying to merge Mojave Sub Division & Milwaukee Road Avery-Drexel. I moved these along as the Trainz versions came out. The last merge I did, was adding Port Ogden & Northern to my first merge of Mojave Sub Division, Milwaukee Road Avery-Drexel, Tidewater Point Railroad - TS19 Version, on SP4, without any custom virtual RAM

Currently I have a route merged with the following
Milwaukee Road Avery-Drexel
Mojave Sub Division
Tidewater Point Railroad
Small section from Niddertalbahn
Port Ogden & Northern

I start at the east side of Milwaukee Road Avery-Drexel, going over Lookout pass, then going down on to Mojave Sub Division at the end of the northern west side of Milwaukee Road Avery-Drexel, going through the whole Mojave Sub Division, then going up on to Tidewater Point Railroad and then down on the other side to a small section of Niddertalbahn, then onto Port Ogden & Northern, which I modified to have 1 continued track through all the scenery (this is one of the most beautiful routes ever)

I used this merging to learn how to build and with the routes on different heights creating mountain passes to make it nice. So I have planned a whole new merging with all the beautiful routes from 2010, 2012 & TANE. So I really want to start from scratch. I want too merge the following

Milwaukee Road Avery-Drexel
Mojave Sub Division
Tidewater Point Railroad
Port Ogden & Northern
Razorback Classic

These routes are all working with no missing dependencies

This is really what I like to do, merging building

Am I allowed to share to routes?
I noticed build 117095 from pware, mine is 117009, how do I get up to 117095

Build 117009 is the latest build (SP5 HotFix 1) of TRS19 Platinum Edition. 117092 is the latest (SP5 non-beta) version of Trainz Plus. 117297 is the latest (post SP5 beta) version of Trainz Plus.

I suspect that you have the Platinum Edition SP5 version and not the Trainz Plus SP5 version. If that is the case then you will need to set Trainz Plus as your update stream, not TRS19 and perhaps reinstall. TRS19, TRS19 Platinum Edition and Trainz Plus all share the same programming code and the differences you see between them come down to your username and your update stream.

Am I allowed to share to routes?

If by "share" you mean upload your merged routes then you will need permission from the copyright holders of the original and separate routes - this permission may already be in the config.txt files of those routes so check there first. If it is not present then you will need to contact the creators. If they do not respond then that is the same as no permission given.

I can offer no advice on merging the routes you listed as I have very few of them on my system.
I think this might be the problem, the update stream and not being the same programming code. Should I download all the content rather, or will the correct update stream update the content
First thing: I would check what the update stream in your current TRS19 is pointing to. If it is just TRS19, or TRS19 Platinum, then I would change the stream to Trainz Plus. Restart Trainz and see if it picks up the patch (or patches, there may be several in a sequence).

My suggestion.
I installed Trainz + and all the patches, uses the same content folder as TRS2019. everything works, merging works. Now I can play