Trainz Plus Beta 99618 (for Gold Class members)


Trainz Plus - enjoy Trainz from just 20 cents a da
Our first update for Gold Class members is now available for Beta Testing for PC only (Mac to follow next week).

This Beta Test is a "very close to final release" standard. There are some known issues (listed below) and we don't expect a long list of new issues to arise. But, that's why we want as many testers as possible to jump on board. :)

To become a tester, the instructions are simple:
  1. Ensure your Gold Class Membership is active (if you don't have one there's $5 off your first month at the moment )
  2. Take a backup of your current version of TRS19 (Build 98592 only).
  3. Launch TRS19
  4. Click Trainz Settings > Install Tab
  5. Click "Change Trainz Update Stream"
  6. Follow the prompts and click "Change Stream"
  7. Select "Trainz Plus" from the list, then OK and Done.
  8. Now click on "Check for Trainz Updates"
  9. Follow the prompts to update.

More Information:
You can read more information at the news page here.

For specific information on the new functionality, we strongly recommend you use the in-game '?' tool which, when used, takes you to the appropriate Trainz Plus wiki page.

We are keen to hear your feedback on the new features/functionailty. Don't be shy, or if you don't want to post here, use our Feedback at n3vgames email address.

As with all things, once you know how to make the most of the new systems, we're confident you're going to love them.

Known Issues:
  • The build has "Assertions Enabled" and so will provide certain developer related information via messages.
  • Generally you can just click Continue and carry on.
  • Initial loading of the main menu scene takes longer than usual
  • Initial load of first few sessions will show "compiling shaders" longer than usual
  • Crash on exiting Tutorial 1 (Driver). This may occur on other routes.
  • Tutorial 10 - Steam Driver Control digital readouts stuck at 100%
  • Some steam loco keyboard controls not working (sliders are working)
  • Field of View controls still being tweaked
  • File > "Install purchased items from Disk" is showing but not enabled
  • TANE icon appears on the Windows taskbar

Also note that patching does not overwrite your current control settings, so you will need to enter your own hotkeys for the new cameras.


Drone Anchor:
There is a prototype "Anchor" system included for the new Drone camera.

Use Ctrl-Left click to target a traincar or even the terrain. Your arrow keys then orbit you around the target and mouse is used to pitch up and down.

Change cameras to escape from this control system.

Console controller:
We'd love to hear from everyone who has a controller (even if you don't usually use one with your PC).
Last edited:
Hi Tony

Followed your instructions - update went smoothly. On starting, I get an error "Unable to authorise this product. Please check your MyTrainz account details". Tried deleting and reinserting username and password to no avail. Previous versions worked OK. I am a current Gold member.

Any suggestions??


No - it's all my fault for missing one step in the "making everything live" release process.

Enjoy :)
Updating to Trainz Plus was smooth, no problems at all, now updated and running.


EDIT: And omg, I LOVE the new camera options! Thanks for that :)

EDIT 2: And now we can walk on the layout too :Y:
Last edited:
Does this address the stuttering problem?

If you are talking about the stutter that is solved by hiding the HUD, then we believe so. We do not have a reliable repro case on any of our hardware here, so if you do, then please let us know if the issue is solved.

We've made a number of changes in this area (and have some more in progress for the next update), so things should be smoother.​
Updated without any problem. Cameras looking good.

Opened last saved session on my route and in session settings all rules (except for 6 default rules) which I added are missing so it looks as new session.
Weird !

Closed the Surveyor, open for edit original copy of my session, all settings OK, saved and opened again - all OK.
Testing is on. I just have to find all menus which are now quite different.

Kind Regards
Last edited:
Downloaded ok moved a route via CDP from original install 98592 into the new 99618 and found a lot of missing assets including built in. My 98592 version has all the DLC content downloaded but 99618 only has a couple of DLC downloads. AJS Invisible station kuid2:122285:3401:22 Shows built in for 98592 but unknown in 99618 which only has kuid2:122285:3401:20. Is the 22 version hidden in one of the DLC downloads and if so why is it not on the DLS for update? Those who build routes may use assets that have been updated in a DLC package without knowing that those who don't have the package will have it as missing content.

Edit Ctrl + F2 for quick drive not working. Quick drive does work from the tool bar.
Last edited:
After a few hours testing on my route I find quite degraded performance. Lot of stutter with and without user interface with usual roaming camera.

Kind Regards
Well I'm still configuring my system and will be testing soon. I cloned my TRS2019 data and program and will use that instead of my "production" version so nothing gets ruined in case things decide to go weird. This will give me a chance to test things in the same environment I use now with TRS2019 and with the same data so everything will be apples to apples.
i am creating a 200 mile route and everything seems much snappier to me. the only issue i am having, when i usually put textures down, i would left click and then right click to fill large areas, that doesn't work now.

more problems, every 15-30 minutes i crash to the desktop for no reason. sometimes when i save my route the sim crashes.
more over when i close trainz 19 rail driver doesn't go back to RD, it stays on 0. if the sim crashes, raildriver doesn't know the sim crashed and stays on 0. everytime this happens i have to restart my pc.
i am getting a crash window which i have already sent in, continue, exit, ignore errors. for an extensive test i shouldn't have all these problems, i had 0 problems before this update, the new features are great.
Last edited:
I really like the new camera options.

There's an interface issue I would like to address though.

If we have no driver selected, such as while in walk mode, we shouldn't see the previously selected driver's route profile move along or at all in the interface. This is the same with the other none-driver associated cameras as well including fly, drone, and car.
I tested the new camera options but I wish that I can drive the car instead of choosing an AI (traffic) car. The keyboard controls to rotate the world in Surveyor mode don't work. I tried using the game controller and it worked but I don't want vibrations from the controller.
The graphics/textures are slow loading while in Driver. This is noticable when changing from external to internal cameras while driving due to the controls and gauges taking their time unblurring. Externally, this is seen on the freight wagons and other assets, which are blurry then finally come into focus. Changing back and forth, however, does not get better and this occurs again when swapping from an external to an internal camera or moving to another location on a route.
John - afaik since TANE there is always a driver selected. F5 hides the HUD. Does that satisify the requirements of not seeing the controls?

Regarding textures - what texture settings are you using? And detail update rate? Does changing thse help? How long is the dealy and how does that compare to previously?

Jeff - driving cars may come one day, but it's well down the list currently.

" The keyboard controls to rotate the world in Surveyor mode don't work. "
>> I assume you mean the interface option to change from mouse to keyboard panning. I'll investigate why that is turned off.

Nugget - "i would left click and then right click to fill large areas,"
>> thanks for that report - I assume you mean right-click to move forward while holding down the LMB? I've raised a task to fix that one!

John - afaik since TANE there is always a driver selected. F5 hides the HUD. Does that satisify the requirements of not seeing the controls?

Regarding textures - what texture settings are you using? And detail update rate? Does changing thse help? How long is the dealy and how does that compare to previously?


I'll investigate the texture issues in detail tomorrow because it's getting close to bedtime for me.

Hiding the HUD really doesn't fix the solve the problem although that's a quick band-aide. Yes this has been around since day-on for as long as I can remember as well TS12 or earlier I think, but at least T:ANE and since there are new cameras being introduced, perhaps some new or correct camera behavior should be introduced as well.

When I initially used the walk camera (I love that one by the way!), I had no train selected at the time and no driver, and the non-driver white outline image showed where the driver is along with no profile. Later on after riding with a driver, I had the driver's route profile associated with the camera I was using when I posted the issue, but no actual driver image. This was "Vaughn" in this case and this AI driver was no longer selected, however, this camera view showed the route profile in the window.


I would think that no driver should be shown when no particular consist is selected since these cameras shouldn't be connected to any driver, and they definitely should not show the profile for the last used drive.

I know it's a bit complicated...
im currently having problems finding Trainz Plus in the file where it should be at. im a current Gold Pass holder as well
More Problems

i edited my last post in this thread, i went into my route to start editing, more crashes, serious issues putting spline points down and deleting track, i am almost to the point i am gonna have to halt my route building until these bugs are fixed, i have been able to reproduce these issues extremely to often to go unnoticed from beta testers before this was released to gold members.i must say i am pretty disappointed with this update.