Railway Simulator (Trainz12) patching problem


New member
Hi all

This is my first post so please bear with me if I've posted in the wrong area or haven't provided the right info. About 3 weeks ago I purchased Railways Simulator (powered by Trainz12) from Just Trains via Amazon. The retail DVD box-set arrived a couple of days later and I went about the installation. I am running 32-bit Windows 8 Pro on a Dell Inspiron 530 with a Core 2 Quad CPU Q8200 @ 2.3GHz, 4Gb RAM, a 250Gb SSD and a 2Tb Hard Disk. I have patched the original installation up to build 49922 but cannot get the SP1 patch to work and now don't know what to do. I have read tips and suggestions on patching prior to dropping this note and all in all have done the following:-

  • Tried to patch online via the Auran Patcher
  • Tried to manually download the patch and apply it (both the 49922 to 57720 and the 49922 to 58414 patches)
  • Have run both of the above as Administrator
  • Have disabled Windows Firewall when attempting the above
  • Have disconnected from the internet when attempting the manual patch
  • Have reinstalled from scratch after every failure

When attempting to patch online via the Auran Patcher it states it is downloading the patch but then nothing further and after several hours the PC goes to sleep. Checking in the Users/Appdata/.../Temp.. folder it does appear that it has downloaded the patch. When I attempted to open the Zip file in the Temp folder it says it is corrupt. When attempting the manual download it always freezes pretty much exactly halfway through (the green bar still shows the left to right animation but the bar doesn't progress any further once it gets to above halfway between the 'Apply Update' and 'Cancel' boxes). Again I have left this overnight so 8 hours +. I have also tried copying the manual patch from the 3Tb disk to the SSD that Windows 8 & the Trainz app is installed on but get the same stall halfway result.

Please can someone help. I'm getting close to binning it now which would be a great shame.


The progress bar will sit at 50% for the majority of the patching process, it can take many hours, 8+ for the patch to install on some systems. Maybe setting you computer not to sleep may help, maybe that's disturbing the patching process. I can't offer much more, I one of the lucky ones who have had no issues installing any of the patches or hot fixes. Maybe start all over on a fresh install. If it doesn't help, install up to 499222, which is pretty stable as it is and wait for N3V to clean up the mess that SP1 and it's brethren have caused. Good Luck.
Thanks mate- I left it again overnight and it did complete the download - after about 10+ hours!

I amnow getting problems downloading content. So I tried to download a couple of model layouts - so for example the Desktop model layout + the Hornby and in the Content Manager I get a red bar through some of the content items within the layout and it doesn't download them. Then when i try to do a Quickdrive there seems to be engines missing from the Constructs. I read somewhere that it means I need to do a database repair. Is that trust if so how do I initiate it?
That can be done in the Content Manager under File > Extended Database Repair.

The red bar issue may be a result of the ongoing server problems that have happened over the last few days - however, hovering over the red bar will tell you what the error is.

The Quickdrive consists frequently do not include a locomotive, which is a peculiar anomaly I know.