Moving assets from one layer to another can already be done in TANE SP2. How?


92 year oldTrainz veteran
I have been trying to move existing track and scenery assets on the Route layer to a second layer or a session layer.

Moving assets from one layer to another can already be done in TANE

The above is a quote from a recent post which did not explain the 'How' of doing it.

This is a relatively old route I am updating and has 8 driving sessions but these do not appear in the F6 Session Layer box. I have created a new session layer but can not find how to move assets from the Route layer to the Session layer. The Replace function does not offer this as a choice.

Select the asset in surveyor, click the question mark, then the asset, change the layer in the layer box. This is for a track mark

They wont, you are getting confused with session layer and sessions. Session layer are different layers within the route session you are working on and can be used to separate assets. One layer could be for scenery, another for track etc. The sessions are located when you open trainz, select the route and click view sessions.

I've spent some hours in T:ANE today doing what I think Peter/narrowgauge is talking about, and the only reliable way was per item using the Question mark thingy in the correct tab for the object. I tried the Replace/Bulk Replace option and asked it for 100% random change to a given Layer, but nothing happen on the screen and I only saw them move after i had been inside the route folder and changed around the file *.trk and *.trc so something did not work like I thought it would.

But, I think I got fixed what I needed fixing, but in Peter's case it is probably something I mention he might try in order to change around tracks using built in walls, fills etc.

I mention he could try take the meshes he built of the track, remove the track part, export as a separate kuid number keeping all the other parts, and then using a trick with saving the files inside the route folder and possible a session folder, before changing all tracks from a Route Layer into a Session Layer inside the route in Surveyor.
From there he could save out that Session as a "Old Track Session" and save that in a safe place.

Then he can use the source files saved in the first place to open up the route again with the Tracks as a Route Layer and change those tracks into another track type without any base built in, no walls, fills etc. Making track appearing to hang in mid air and so on.

Then, he save this route, exit Trainz, and use the saved "Old Track Session" to enter the route again, now with the above new track in same place as the old track bases is also located, making the appearance of track more like it was before, except they are now separate models.

Finally, he moved the Session Layer into a Route Layer and voila, both splines is now inside a Route Layer and in the route and all is as it was before, except he now has doubled the splines at the same location, without having to fiddle with it inside of Surveyor.

I did a similar trick using TransDEM to add 3-sets of UTM tiles at same location, using three different Route Layers, it works nicely, took a while to make it work as I had to use the Session Layer and not a Route Layer as TransDEM overwrote those for each export, but it works and made me happy.
Hence I though he might try the same for what he was thinking.

How I moved from Route to Session Layer and back was the way of making a temp Layer where I wanted to go, and merged the Layer I needed moved into this new temp layer. That worked nicely. :)

Hi teddytoot,

Not sure if I understand what you say?
I tried the Help Menu inside Trainz but it lead me to a Wiki with hardly any info about that part and I saw no changes if I selected the same layer so to speak. But as I did not know what to look for or not, I might have missed it.

I think you say that in order to bulk move items we need to have both the Layer to mode to and the Bound layer to pointing at same Layer, is that correct?
Anyone know why, what it means, I am very rusty when it comes to Trainz...

Moving individual assets - for example this house located here, but not that identical house located over there - can only be done by the method described in post #2 by Clam.

Moving bulk assets - for example all the houses with a particular kuid number - can be done using the Bulk Asset Replacement Tool. Despite the word "Replacement" in its name, it does give you the option of moving assets from one layer to another.
Thank you, everybody.

I had tried the method described by Malc but the window he showed would not appear. I was selecting the item 'in the list', clicking on the ? and all I got was a single line at the top of the track menu.

Then came the dawn! As he pointed out, it is necessary to select the item twice in the sequence in two separate places., which I did and it worked. Not a particularly intuitive process but it worked.

I must admit that despite my many years in Trainz, I am a comparative novice in the route building area and have to approach these problems with the aid of the manual, the WIKI, and the internet. I was unable to find anything that worked. Having been though this experience, I can understand why people try Trainz, try to make a route and give up in sheer frustration. At the bottom of page 157 in the Tane manual there is a 'Tip' about this. No mention of the double selection of the item. I followed the printed instructions and hit a brick wall.

Anyway, thanks again, hopefully I can, with Linda's help, work my through this update.

I have just read the post by PWare just before mine.

Back to the drawing board!

I thought that what I was doing was to move ALL the instances of selected asset to the new layer which is what I need to do. Reading that later post, it seems that I have to use the 'replace' process which was, I believe, the process referred to in my initial post. I have tried this but because of the lack of DETAILED instructions in the manual and other places, I had no luck. In the window that appeared there is no mention of 'layers' or anything that would give me a clue.

Please, could someone list the sequence for this process.

Jeez! I hate this part of Trainz.

I have just learned that with Trainz, don't expect anything to be simple. Ignore what it says, poke around and hidden things will appear.

Prompted by PWare's post, I went back to the Replace tool, and ignoring the dread words 'randomly move 18%' I dug a bit deeper and found that was what I was after.

Thank you all. It is not all N3V's fault, there is a an element of 'old age' creeping in to the equation which I will have to watch for.

My head hurts from banging it on my keyboard.

I have finally come to this conclusion:-

Yes, it is possible to transfer tracks between layers


No, it doesn't work if the track is not 'fresh' (not added in that current building session)

Please, please, prove me wrong.

I made a target track consisting of a length of track on a blank board, I saved this route and reopened it. I then added a section of the same track to the 'old' (previous) track section.

I transferred this to a new layer, the 'new' part transferred, the 'old' part did not

I tried replacing the target track with something different, this replaced new and old occurrences of the target which I could then transfer completely.

I then reversed the process and tried the transfer again. Back to head banging time, the new track transferred correctly, the 'old' track did not transfer.

Thinking about this as I type, it may be possible to replace the 'old' track with a 'dummy' (clone) track, I can then change the original one in CM and then change back. I dunno! Maybe. More testing, more head banging.

You're not the only one with problems, Peter. I've just spent a few days dealing with layers on what I thought would be a fairly simple task.

My initial plan was to move all my 'green' assets on to a new route layer called 'Foliage', so that I could hide all the trees and hedges to identify problems, if necessary. All went nicely using the Bulk Transfer Tool until it came to splines.

I had watched the N3V video and consulted the forum and I was aware that I could not bulk move bridges,tunnels or multi-tracks but splines should be OK and I'm sure I've moved them in the past. (in the video it mentions moving track)

However, splines would not be moved using the Bulk Asset Transfer tool.

I then started to move the splines individually (as stated above). Bearing in mind that I was in 'Route Edit' and I was moving between 'Route Layers' I was a bit surprised when I didn't get the option to save the route. On each save I was only given the option to overwrite session or create new session. (I have reported this as a bug). I ended up with several default sessions which was not what I was trying to achieve.

The only way I could ensure that I was offered the chance to overwrite the route was to add an unwanted asset to the route just prior to saving. On the next save I would delete that asset so that the route physically changed prior to each save. The layer changes were recorded.

One thing to be very careful of if you make a mistake is not to use the Undo tool at the top of Surveyor (or Ctrl-Z presumably). I did that a couple of times and ended up with assets scattered all over the different route layers, including those created by Trans-DEM which were locked and hidden.

I have a feeling (because I've experienced problems in the past when changing properties of track marks) that certain changes aren't recorded in the same way within the game engine. But what do I know!
Last edited:
I seem to recall that when the Bulk Replacement Tool first appeared in TANE (I think it was one of the "hot fixes") it had problems with some (but not all) splines - and that may have included some track types. I have successfully used it to replace one fence spline with another in SP1 and I recall using it successfully to replace non-procedural track with procedural track in a route imported into the original TANE from TS12.
I seem to recall that when the Bulk Replacement Tool first appeared in TANE (I think it was one of the "hot fixes") it had problems with some (but not all) splines - and that may have included some track types. I have successfully used it to replace one fence spline with another in SP1 and I recall using it successfully to replace non-procedural track with procedural track in a route imported into the original TANE from TS12.

I'm sure I've used it before as well. It may be just the change of layers that is causing the problem.
I've come to the conclusion that 'layers' are seriously screwed up, especially when it comes to moving splines.

I've spent ages trying to move splines from one layer to another, saving the route and finding that the spline is still on the same layer when I re-open the route.

I then thought "to hell with it", I'll get rid of the additional layers that I've created and leave everything on the route-layer. So I merged each layer individually with the route-layer and then saved.

When I re-opened the route the additional layers had gone, leaving only the route-layer, but so had at least 50% of my carefully placed assets (several hours of work). Not just splines either.

The only good news is that I made a cdp of the route before I started messing with the layers.
Did you not open the route session for edit as it is most likely still in there. Open the route only creates a new session.

Sorry stagecoach but I'm not sure what you're trying to say here. Are you saying that I should edit layers in the session not the route edit?
You should always edit session layers in the session and that includes moving objects between a Session layer and a route layer.

Route layers you can edit in either the Session or the Route but I prefer to always edit route layers in a session to be safe - it does not matter which session.