Locos not showing up...missing dependencies, or?


Professional Iconoclast
I have recently tried several downloads that dont show up.
Firstly... I am running a fresh install of 2004, SP4, and while some downloads are fine, others are not.
Engines that dont appear are

PRR H9 2-8-0
any of the 0-6-0 steam switchers (have tried several - tenders ok, engines, no)
Alco C425 (several versions - although the GBW C424 worked fine)
UP C30-7
Berkshire scenic railway Alco S2 (although the L&NE S2 DID work)
couple of others that escape me at the moment.

they appear on the listing in railyard but no icon picture in the column, or model in the main window, no picture in the surveyor preview window, and no show on the track.

I read another post about someone with a similar problem with one of the subpar 2-8-2s but my download of this worked fine! Yet I have the same problem that he reported on these other engines. They download fine but just dont show up.

I am wondering, is this missing dependencies, or is it some other problem such as incompatible versions.
Is there a way to trace what the fault might be, and to fix it? I know these have worked for others, at some time, but it seems there might be a large number of missing KUIDs at the DLS at the moment? I was curious if others have had the same problem lately.

Your thoughts would be appreciated, gentlemen and lady (hello Angela!)

Once you've installed trainz objects, find the troublesome loco under the rolling stock checkbox down the bottom. Right click the row and select show required rollingstock parts and it will display all parts that make up your loco, if something is missing it will say 'not found'. Then you have the option to search download station etc. :) If you used content manager you could re install the cdp packages. Befor you exit Trainz Object go to menu and delete the dispatcher chump file and if it asks you to delete the edit text file say yes...
Last edited:
That trainz object file...what a gods send! Have manage to fix up a couple of errors with it, have my V&O geeps and C30-7s showing up now. Working on an edit around for the 0-6-0.

Yes, "Trainz Objectz" is a marvellous tool for 2004. It has been indespensable at times for me.

Sadly, though, the 9F's I d/loaded from the DLS still won't show up, although according to T.O. there is nothing missing!
Hi seward,

I have only downloaded the green one "Evening Star" There was trouble at the start, it was one of the dependacies missing something but I can't remember which one. I did manage to find it and fix it and it now runs well.

Sorry I can't remember what it was.
Similair problem

HI need help

can anyone tell me the dependencies for the:

Class 158
Class 375
Gner class 43

Hymek and class 27 also if anyone has them.