Jointed Rail DLC Causes Game Crash in Trainz 2019


Standard Cab Fanatic
A few days ago I purchased a few Southern Engines from the Jointed Rail site, most if not all work and run just fine. I've noticed however that when I use the SD35, whether it's in surveyor or in quickdrive, my game usually crashes moments after the engine is placed on screen. I've only so far noticed it with this unit but I will check the others I have purchased.

The GP50, The SD40-2, SD45, and GP38-2 all work fine. I also bought a WC F45 and that has no problem either.

I tried to figure out what the issue was. Trainz 19 has crashed before on me plenty of times when I play the game (that's a story for another time...) and despite making RAM upgrades, clearing out space, and other things, it continues to crash. Not commonly, but still quite more than I like. Despite this I continue to play, as it only happens once in a while. I noticed it crashing more frequently though after buying these units, and I couldn't pinpoint why until I noticed it only happens when the SD35 model is on screen.

After doing some research, I made the conclusion that it was either my antivirus program, or that there's something in the model itself, whether it's an old script or a faulty script, etc., that is causing the game to crash. I tried the antivirus method and removed trainz from the check, but no dice. That makes me think that it's with the model.

Unfortunately since I am unable to refund the model i'm sort of stuck with it, not that that's a bad thing, I quite like the unit. But i'm reaching out to see if anyone else has this issue or has had the issue with something similar, and if there's any way to fix it. My thought is going through and manually diagnosing each dependancy, but I simply don't have the patience or time to go do that at this current moment. So for now, i've just decided to shelf the unit and use the other items i've purchased.

Thank you for any feedback!