Interlocking Towers Junction control


New member
I am using the Enhanced TRC3 Invisible Interlocking Tower kuid2:61392:8101:78. The Junction within the path will not return to its previous position after the train leaves the IT path. I seem to think it use to automatically reset. I tried the Auran default junction with the same results. Can someone please enlighten me concerning this.

Most likely I will completely remove the towers as I did in TRS19. It's just unstable and unreliable and too prone to problems which really messes up an AI route. I have been testing it all day, hours and hours with random faults and problems. The IT Enhanced Manager rule has a yellow comment at the bottom of the window that reads "Session has 1 interlocking tower with invalid security token(s)". I can't get that to go away. On one occasion, the EIT data was completely wiped as if nothing was ever entered. On another, the EIT and the Safetran CLight Signal (script error) at the EIT entrance path faulted and had to be replaced to even get it working again. In addition, "Manual control is disabled", and I hate that one. It really screws up an AI route. But I was able to take control of the junction using TRS22 edit mode, even when it says disabled. In classic edit mode I get "$grps_edit_tool_item_locked". Also, I had to replace twice the track marker I was using to send a train through the EIT path. That however may not be an EIT problem, cause I've seen that in TRS19.

Btw, I have seen Pguy has made a lot of updates in October. Anything related to EIT I have upgraded.

One last note: I tried using the N3V Interlocking Tower Crowcombe Heathfield Signal Box with same Junction not resetting. I don't know the relationship between it and EIT to get the same results. Anyways, I need to take a look again at alternate ways to protect my track crossovers, I have wasted all day with this.

When editing a path ensure that "path clear option for owned junctions :" is set to "restore junctions direction on path cleared".

I've been using EITs for years with just the occasional hiccup. If there are any bugs found Pierre is usually quickly on the case and fixes them. It may take a while as any fixes need to be tested properly.

I too have had the odd tower lose all of its settings but I haven't been able to pinpoint what causes it and it happens very rarely.


Last edited:
Hi Marv999.

Sorry to learn you have such problems with using the EIT system. Most EITs trainz users says they are using them (EITs) because they found EITs help to make reliable AI train schedules where standard AI schedules are know to encounter many common pitfalls making unreliable their sessions ...

A few comments on your described problems in this thread :

"Session has 1 interlocking tower with invalid security token(s)" is an error message informing that the EIT system has detected that some tower have currently an internal security token that should enable setting this tower path objects to their target state that no longer works. It is clearly an internal logical error inside the IT or EIT system that in general reveals a more problematic problem with some corrupted route or session files. To clear the problem you can try to do a Delete Missing Assets command on your route and session that will first delete any missing assets from your route and session, but will also check several internal route/session data structure and will try to repair and fix any latent corrupted data problem in your route and session. Generally it works and enable to fix such corrupted route and session.
If you have some previously saved backups of your route and session, you can also try to roll back your route/session to those saved backup to see if you can get rid of the security token problem.
If you have identified the tower culprit, you can also delete and recreate the tower object causing the problem.

For junctions not returning to their initial direction, as it was explained by Brian, it is a parameter option at the path level to choose if the tower will restore initial junction directions or not when a path is released. So first just check if the path option is set or not to restore junctions initial direction or not.

About the fact that "Manual control is disabled" it is the base of ITs philosophy which is that IT takes control at initialisation of all its paths objects and will never release it during the session, making mandatory to request a path activation inside the tower to change any path objects direction or state. If you don't want this base behavior, do not use ITs or EITs. ITs or EITs are here to help you to create reliable manual or AI session and not to make thing more complex for you. Most EITs trainz users find EITs helps making reliable complex sessions with a lot of AI trains on huge route, but if it is not your case just do not use them and use some other methods to make your AI train sessions more reliable.
If however you still uses EITs, remember that using tower with dynamic ownership option makes dynamic paths release all control on their path objects when path is not set, except the entry signal that for some technical reason needs always to be owned and under control of their owning tower. With dynamic paths, manual control of junctions is only disabled while the path is active and will return to enabled when all paths using the junction are inactive.

So again sorry you did not appreciate using EITs tower functionalities, but as I said earlier there are other ways to make AI sessions more reliable if you do not like EITs inherent complexity.

Thanks for the replies, Ken, especially pguy. Will relook at what I am doing. I'm a little late with my reply but I got so frustrated I did NO trainz stuff for a while, because of a different problem. Bug report sent to N3V. My route got really messed up with dark water all over the route. It seems to have appeared when I was using the marquee tool to place prefab tracks that was preloaded with the game in the scrapbook. This is a very new route and I have not even placed water on the map. Anyways, really appreciated the replies and I will take another look at using EIT.

Btw, I also noted that TRC crossing also is not working correctly. The TRC 4 trigger will not hold the distance setting for front or back. It keeps going back to 1600 meters. I almost think this is causing the token problem with EIT.