Floating containers


New member
I downloaded the JR freeware ttx 3 unit well cars, along with its dependencies. When I load it using norfolksouthern37's instant load library (or any other instant load command I could find), about 1/3 of the time, it results in the top container floating above the bottom one. What can I do to fix it?
Don't know if there is anything you can do to fix it, that usually happens when a HC container is loaded on top of a SC container, load the containers manually, SC containers on top of SC containers and HC containers on top of HC containers.
that may not be the whole story. the container sets you have may be out of date. instant load is loading what it thinks is the correct containers but if your containers are out of date it may be loading the wrong ones.
checl to see if you have the latest instant load and core library.

they are on the DLS

Instant Load Library v 0.5 - norfolksouthern37
3rd November 2015

Type: Miscellaneous | Version: TS12 | KUID2: <KUID2:45324:555110:3>

Instant Load Command - norfolksouthern37
3rd November 2015

Instantly load a train with a random product selected from its product que. InstantLoad will not load locos or loco tenders
Type: Driver Command | Version: TS12 | KUID2: <KUID2:45324:555017:7>

I didnt make any changes recently to how containers are chosen, only made it more compatible with new wellcars created by other authors. if you still have the problem with the containers then remove the container packs completely and then install the ones from JR. maybe een try updating the cars. I dont know what the issue is but I cant reproduce it withe the latest items.
I have your latest commands, and I downloaded the cars and containers 2 weeks ago. I'll try reinstalling the container packs though...
After re downloading and overwriting all of the containers, it still is happening
I'm using the load all command by the way...
Last edited:
Sorry to be such a bother, but does anyone know how to fix this?
I have the latest containers, latest commands, latest cars.
I really don't know what to do
So sorry to bump an old thread, but after having tried everything (and I mean everything) I am vexed. I have the newest libraries, containers, cars and commands, and yet it doesn't work. The number of cars with floating containers has decreased, and it seems to be limited (mostly) to the 3 unit ones, but they are still there. I just spend half an hour loading the same train, and each time one or two or three cars would have floating containers. Maybe it's a setting in game that I don't know of, but well... I don't know. So please, if any of you have suggestions, please, please, post!
Thanks, and sorry for the rant!
if you find containers that appear to be floating find out what the container underneath is as far as asset kuid. try to update it.

if it appears to happen only on one wellcar asset then try to update that.

there really is no way they can 'float' if the right assets are being used. I know it is somewhat of a hassle that they got changed but it happened a long time ago when there became too many container assets and they were re-worked. the very large container packs at JR should be the most up to date sets.
I have had this problem since I can remember. It always seems to be a problem with the 20ft containers on the bottom. It almost seems like the 20ft containers are standard but the attachment point for the upper container is for a lower high cube. I have just tried to block out the gap in my mind all these years, and although aesthetically unappealing, it's not that big of deal. All my containers are up to date with he latest ones on the JR website as I reinstalled them after buying the American Intermodal route.

Let me say though, if this is the most of my problems, I am good with it. You guys do amazing work and I look forward to seeing what is next..
yes this is precisely what happened. at once point early on Joe had the 20ft containers with a different model. that was changed and as a result all of the queues had to be changed for each wellcar.

this is why i am suspecting that the floating is only happening with certain cars if all of the containers are up to date, but the only way to know would be to see the config.txt queues.
I can save them for you and send you a zip if you would like.....are all the wells on JR up to dated. Because I thought I downloaded them again but I might be mistaken??
Last edited:
It seems to be a problem only if 20s are on the bottom.
I did 3 trials of instant load with a 30 car train (10 units of 3 Maxi IV) -- load all (with an instant unload in between) and I got:
Trial 1:
48 floating over 2 20s
'' ''
Trial 2:
45/2x 20
45/2x 20
40/2x 20
40/2x 20
Trial 3:
40/ 2x 20
45/2x 20
53/2x 20
40/2x 20

My well cars are:

Do you want the config files of the cars themselves? Or something else?
Edit: After some more testing, I discovered that the problem is 100% limited to the 3 unit cars; all my single-unit ones work perfectly!
Last edited:
items were checked and verified at JR.

a good way to tell if you have the latest wellcars is that they are all using the EOT mesh library and can have it fixed to them in game. Most of the kuids end in :3 or :4 but not all of them so that might be another way to check. in any case, they should all reference the EOT library.