Faulty assets keep returning in route


Well-known member
How do I fix two faulty assets that keep coming back when I replace the kuid's in the config? Plant Shrub 05 and Tree SugarMaple 02. I replaced them with newer versions that aren't faulty. Can I obsolete the older ones since they don't work in 19 anyway? The errors are texture and other errors and some of the textures are blank on the sugar maple tree and the PEV tool can't fix it. How do I obsolete something?
You can't replace assets in the config file, this must be carried out in the route or session by replacing or deleting missing assets. The config file is only a record of what is in the route.
But it works temporarily. I tried it and it does replace an asset. I could then use the bulk replace tool and change it to something else, save the route, and the problem should be gone. I don't know how else to replace a faulty asset that I can't fix other than obsoleting it. Can you obsolete a faulty asset with the same one that works in 19? How do you obsolete a faulty asset? Do you have to add something to the config of the working or faulty asset?
As stagecoach says, you can't replace a faulty asset in the route's config.txt file because the config.txt file only contains a list of the assets and the actual asset information is stored in the route data files.

What you can do is:

Download a suitable tree.

Open the tree for editing.

Open explorer and copy the tree's data folder from editing to your desktop.

Change the kuid of the tree you put on your desktop to the one that's faulty by editing the config.txt file.

Back in Content Manager...

Import your changed tree's folder.

Revert the original you have open.

This will replace the faulty asset with a new one you can then replace with Bulk update if you want.
But then why does the faulty warning go away after I replace kuids in the config when I go back into Trainz and the red exclamation point box is gone in the thumbnail of the route? Replacing the kuids does do something but sometimes if I save the route the newer save will have the errors back.
But then why does the faulty warning go away after I replace kuids in the config when I go back into Trainz and the red exclamation point box is gone in the thumbnail of the route? Replacing the kuids does do something but sometimes if I save the route the newer save will have the errors back.
It goes away because the asset isn't read from the files and cached, but as soon as it's referenced again the error returns.
They should have made a simpler way of replacing a faulty asset with a good one within CMP. I thought there was an external tool that could do that back in the 2004 days. But Trainz 2004 wasn't as strict as newer Trainz versions. Some assets that worked in 2004 will error in TANE and 19. And the problem is old routes with old assets that are imported into newer Trainz versions. Sometimes some assets will now error whereas in an older Trainz version they didn't error. One solution would be to use the bulk replace tool in an older Trainz version then save and import into a newer Trainz version. But, if I imported the route into 19 and made some changes and saved, it's too late. You can't put the route back into an older Trainz version to use the bulk asset replace tool. The tool cannot be used to replace faulty assets in Surveyor. I don't want to have random missing trees and bushes on the route. And I have no idea where they are on the route to begin with. I'm going to try JCitron's suggestion. I'm not having any luck with the Plant Shrub 05 because it doesn't have any folders, just a config and a thumbnail. It won't let me import it. There is a different version of Plant Shrub 05 in 19 that works, but I want the route to read that version not the faulty one. As well as the Tree SugarMaple 02. There is a working one of that in 19 as well. But that has folders in it, so it might work if I do that workaround. Is there a way to obsolete the faulty Plant Shrub 05 so that only the working version is used by a route that calls for it?
Last edited:
N3V is looking into a way to bulk replace missing and faulty assets we were told a while ago. When this occurs, who knows.

The reason for the stricter error checking was due to crashes. TRS2004 had minimal error checking and would horse through content errors. This not only caused performance issues due to the horsing through and checking, but also caused instability. TRS2004 would load up fine, but crash randomly to the desktop, or usually on exit with the infamous GPF errors. The long-term workaround for that error was to do a Save-As rather than a Save before exiting. Then due to many user complaints, error checking started in TRS2006 and got more and more strict with intervening versions. Today, content-related crashes are pretty rare compared to the olden days. To allow for backwards compatibility, older assets are allowed to co-exist with newer ones in the newer versions as long as they follow the rules for the build that the assets were created at. This works for 90-99% of the assets.

One of the problems was that early Auran content creators made errors in their own content and many, many content creators cloned those assets, causing more faulty content than was necessary. If Auran had been strict about errors back in the old days, we wouldn't be in the mess we have today.

The issue with the older Speed Trees is a different issue altogether. When N3V released, T:ANE, a 64-bit version of Trainz, they had to upgrade their 32-bit version SpeedTrees, the software developer IDV had no direct upgrade and any tree developed using the 32-bit libraries is now faulty. Sadly, IDV is notorious for doing this even between interim versions. Trees created in version 6.5 are not compatible with version 7, or whatever version is out there today. This makes creating new trees difficult for us because N3V is locked into 6.5 or whatever version they use, and any tree created above that version won't work at all.
How about this? I have a modified and added on to route from Bound Brook, NJ to Harrisburg, PA which has Roon's NS Reading Line route which was height adjusted in an older Trainz as well as a fixed Reading and Northern route (TANE or 19) with the faulty Pofig trees replaced from the DLS by etozorak. I wanted to create a super route at least from the New York (Manhattan) area to Harrisburg, PA area and have Norfolk Southern, CSX, Amtrak, Reading and Northern, and a few other tourist railroads and shortlines for my own use. I managed to fix the few faulty assets, except a clone of a JR dk grey dirty weathered track which I could obsolete and replace it with JR Dk Grey Dirty track. The sugar maple tree I obsoleted the faulty one with an identical working one. The Plant Shrub 05 I replaced the config info with the config info from the working one but kept the old kuid, which is Auran the former owner of Trainz before N3V. The working one is also under Auran as well. Now I have another head scratching problem. In my modified route which includes the NS Reading Line by Rooneth (Josh Drumm) some of the road splines which originally used a black road with white dashed lines are missing and replaced with the white missing spline. The problem is that I can't replace the spline with anything, but I can delete it under tracks but it shows up in the list under roads. I can though manually lay down new roads and use the white dashed lines as a guide then delete them. But I didn't want to have to do this over 50 miles of route. Not all roads are missing, just ones that originally used a built in I believe black road with white dashes. The missing road is only on the NS Reading Line portion for about 50 miles of route from Reading, PA to Phillipsburg, NJ. If I try to do a bulk replace with the missing spline, nothing happens. I did the trick to have a new version number of the missing spline show up in the list in surveyor. That normally lets you bulk replace the missing spline with something else. But it doesn't work in my route.
Last edited:
This is because road splines have changed to a kind track like all splines. When a spline is missing regardless of the type, meaning grass, fence, road, or track, these will appear as white-dashed lines.

Here's something in my notes that might help you replace the white lines.

The dashed white lines isn't "a missing asset" - it's the asset that Trainz turns to when it can't find the asset it is supposed to draw there. These white lines are, in themselves, an asset. You can find this asset in CM. It's called "Missing spline", and it's by Rob. Open it for edit. Change the KUID from <kuid:523:1124> to <kuid2:523:1124:1>, and remove the whole privileges container (containing the line "permit-listing 0") Then install that asset as if it were a new asset - e.g. drag the folder from windows explorer back onto the CM interface. Once it's installed, revert the original one (you can't commit changes to it as it's a built-in asset). Result: The dashed white lines now show up in the menu, and can be selected just like any other track spline. You could lay some down if you wanted. More to the point, you can now use the 'replace items' tool to change them to any track spline you have installed...

I will add this. When you install the folder, use the install content option. This will save much time. Also don't panic when the creator is shown as AURAN.


<kuid2:523:1124:1> ==== Update from <kuid2:523:1124:2> to <kuid2:523:1124:3> for T: ANE and up. All other procedures apply.

Need to change .texture file using PEV's Images2TGA.
I did that already but the wihte dashed lines are supposed to be a road. I can delete them with the track delete, but they still show up in the road list. If I use bulk replace nothing happens. It worked on other routes. I think the dashed lines are stuck. I can't replace them. I can only delete them and lay down road in their place. And obsoleting the latest missing spline does nothing. I tried obsoleting it with a road but it didn't work. I guess I'll just lay down roads manually where the dashed splines are and use them as a template when laying the road and delete the dashed splines after laying a road. This is a route that I just got back into, I merged routes and DEM's together a few years ago. I have multiple saves of the route because of changes made.