Error patching 43434 to 44088


I am trying to apply the 43434 to 44088 patch and keep getting this error:
Ready to install from local patch file.
Current version: 43434.

Checking for available disk space for patching.
Unpacking patch file...
Patching from 43434 to 44088...

Failed patch command: "C:\Program Files (x86)\Auran\TS2010\bin\jpatchl-w32.exe" "C:\Program Files (x86)\Auran\TS2010\bin\plugins\TNISpeedTree.dll.pbk" "C:\Users\JOHNFA~1\AppData\Local\Temp\file1796101\data\bin\plugins\TNISpeedTree.dll.diff" "C:\Program Files (x86)\Auran\TS2010\bin\plugins\TNISpeedTree.dll"
An unknown error (4792486) occurred while patching file bin\plugins\TNISpeedTree.dll

Failed to apply the patch: 43434_to_44088
Patching aborted.
Patching has always gone just fine before.

I downloaded the patch again to make sure it was not corrupted but same problem.

Windows 7 Pro 64 bit. 1 TB hard disk (lots of room left on the drive). 6gb RAM, I7 920
You may need to re-install TS2010, then make sure you are running Trainz as admin during the patch if using Windows Vista or Windows 7.

Also, make sure your antivirus software is turned off during the patching.

Thanks Shane

Tried turning off the anti-virus. No change.

I have admin rights.

I hate to think of re-installing 2010, I had such a hard time getting the RailDriver to work with it under Windows 7 64 bit.

I might just leave it as-is. I use RailWorks most of the time and only run TrainZ once in a while.

The TrainZ diagnostic runs just fine with no errors. The current installation of TrainZ works fine also.
Last edited:
By 'admin rights' I am assuming you are using the 'run as administrator' option, and that you have to click Yes each time you run the program - if not, you will need to set the program to run as admin.

Apart from a re-install, you are probably not going to be able to patch any further (unless someone else knows better)

Well I am the administrator but just for drill I ran it as administrator but same problem.

I'll deal with it later. Thanks for your help.
Unsure if this will help you jfail, what worked for me may not work for you in your case, but at least it's worth a shot.

Disable internet and antivirus.

Run disk clean up, defrag system and ccleaner (go the whole hog).

Run an extended database repair in TS2010, then close TS down and run the 43434 - 44088 fix.

IF it works out ok, do an extended database repair after the patch has been installed. Then you should be right.


Well Shane was right on the money.

I had to uninstall TrainZ and reinstall it. Of course that took quite awhile to get it all reinstalled with the patches etc.

The patch works fine now.

Thanks to all of you for the help.