Download helper not functioning


A Thomas Trainz Fan
Hi there; I'm rather late to TS19 due to tech issues I previously had putting me off for a couple years I finally have it mostly working, but I have an issue with the download helper in content manager. It keeps disconnecting and reconnecting, and therefore I can't get anything from the dls atm. To make matters worse, ftp doesn't work anymore because Chrome disabled it.

For the record, I don't have a proper wifi router atm either; I have a T-Mobile internet hotspot (we just moved recently and kinda live out in the sticks, so we can't get any proper wifi atm); I'm assuming this is the reason why, but I can't find any other sort of answers online. I've had to get all my DLS assets from friends who grabbed and install them, and I don't want to keep burdening them with this, so any sort of help or answer would be appreciated.
I would definitely suspect your internet connection. Wifi networks can be unreliable with large files and being on a tethered connection is most likely making everything worse.
It's not tethered afaik? I'm not using an ethernet cable. And I've never had this issue before; this is the only semblance of wifi I can get down here until further notice. It's my literal only option and it's not working.

There has to be a workaround that doesn't evolve messaging my friends to look through their own databases or download stuff from the dls for me, then send it to me through the likes of discord and such. I can't use FTP like at all because of Chrome either. I've tried it on Edge as well and all it did was force Chrome to open, which of course can't use FTP now.

I need a better workaround.
If everything else is working (such as web browsing, Discord, etc) then I would suspect one or both of the following:-

Do you have TRS19.exe added to your antivirus real time scanning exclusion list? If not, add it.
Are you using a VPN? If so disable it when downloading from the DLS to see if that makes a difference.
No VPN here, not sure if it's on my antivirus exclusion list, will double check!

Edit: Yes, it's on my exclusion list. I will look into Windows SCP (they might want to rename that though, as my brain defaults to the SCP Foundation seeing those letters).
Last edited:
In another thread a user mentioned that TMobile will not download from the DLS and gives the same error you have. It has something to do with how they have their 5G network locked down.
Alrighty, that makes perfect sense then; it IS T-Mobile's fault. What a pity.

I have WinSCP downloaded and installed now, but I have absolutely no idea how to use it to get content from the dls. Is there a tutorial somewhere on how to do that?
You're the person who's in the best position to help SodorProductions, as you live in Haverhill, which is on the north side of Boston, and he lives in Rochester, which is on the south side of Boston. According to my iPhone, it's just an hour and 42 minutes' drive from Haverhill to Rochester. I suggest swapping E-Mails via Private Message (PM) just in case he needs help in the future.
Much obliged for all the help, yall.
I tried using winscp. No good. Managed to get deep into T-Mobile gurus. The tech said they will look into it.. It took a loong time and never hear from them. Your computer is capable to connect to port 21 or 80 (widely used). Auran offers only port 21. T-Mobile filters out this port. I discovered ATT does the same. Verizon used to allow it, recently I also had problems here. If you have a wired connection, even T-Mobile does not allow it. So it is a mess. My wireless T-Mobile downloads easily at 300+Mgz, so I will never go back to wired. And finally head of N3V said that port 21 has been used for many years without any complain from anyone (except me), so: When I need to download anything, I go to the nearest street hotspot, connect there with my laptop and take a coffee. All for the sake of progress.
Unless N3V is actively being non-standard or not actually offering sftp, the standard for sftp is port 22, because port 21 is unsecured ftp.
Unless N3V is actively being non-standard or not actually offering sftp, the standard for sftp is port 22, because port 21 is unsecured ftp.
If you open DLS, and click on Download details, It states that N3V uses FTP port 21. As most of the people uses wired connections with local ISP, connection is possible. But for who uses wireless LTE or 5G,,,, well, too bad...